Author Topic: AvastUI.exe hogs CPU!  (Read 14390 times)

0 Members and 1 Guest are viewing this topic.

Offline AntDude

  • Jr. Member
  • **
  • Posts: 64
AvastUI.exe hogs CPU!
« on: May 12, 2010, 03:47:45 PM »
Hello!

On Sunday, I had to replace a client's Norton AntiVirus CE on an old Dell Optiplex GX260 PC with an Intel Pentium 4/IV Prescott CPU, 512 MB of RAM, IDE Maxtor HDD, and an old updated Windows 2000 SP4 (IE6) due to its slowness (much faster without it). After researching and being told to try the latest Avast free/personal, I installed it and it seems to mostly work. However, there were a few problems.

I noticed AvastUI.exe likes to hog CPU (50% on hyperthreading Intel Pentium 4/IV Prescott CPU) when I access real-time shields option in Avast GUI program. I do see graphs gets updated. I can't exit or do much in Avast when this happen. I can't even kill it. Windows 2000 is almost very slow too. I have to wait a long time after clicking close/exit on it. I did not see any intense disk access. What's up with that? :(

I did also notice updating showed avast.setup hogging a little, but not horrible. I assume that's normal on a slow old PC.

I believe the PC has the latest drivers, but it's very old from early 2000s. Are there fixes for these CPU issues?

Thank you in advance. :)
« Last Edit: May 15, 2010, 11:24:24 PM by antdude »

doktornotor

  • Guest
Re: AvastUI.exe hogs CPU!
« Reply #1 on: May 12, 2010, 03:57:41 PM »
The fix would be to use the Norton Removal Tool I'd say... and after that, do manual digging and uninstalling their left-over drivers which get ignored by the removal tool as well.

Offline AntDude

  • Jr. Member
  • **
  • Posts: 64
Re: AvastUI.exe hogs CPU!
« Reply #2 on: May 12, 2010, 04:04:11 PM »
The fix would be to use the Norton Removal Tool I'd say... and after that, do manual digging and uninstalling their left-over drivers which get ignored by the removal tool as well.
I don't see one for this Corporate Edition v7.60.926. I did manually remove its left over registry datas, files, folders/directories, etc.

FYI, the major slow down only happens in GUI's real-time option. Other options and in background/minimized are OK.

doktornotor

  • Guest
Re: AvastUI.exe hogs CPU!
« Reply #3 on: May 12, 2010, 04:16:18 PM »
I don't see one for this Corporate Edition v7.60.926. I did manually remove its left over registry datas, files, folders/directories, etc.

Well, not really something we could solve here. The policy w/ "enterprise" products has always been that their removal tools are super-secret and available on-demand only after providing a proof of valid license and wasting ages w/ Symantec technical support. I could give you a "warez" version of SEP removal tool, but for outdated stuff such as 7.x of their corporate client, sorry, no idea. One thing I'm sure about is that their standard uninstall procedure fails miserably, causing whole lot of after-effects.

Sorry I can't help you more with this one.  :(

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71213
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: AvastUI.exe hogs CPU!
« Reply #4 on: May 12, 2010, 04:25:29 PM »
That's bad... :(
Don't know if Ccleaner can help you, but you could try...
http://www.piriform.com/ccleaner
asyn
Win 8.1 [x64] - Avast PremSec 21.7.6459.IBC [UI.658] - EEK - Firefox ESR 78.12 [NS/uBO/PB] - TB 78.12
Avast-Tools: Secure Browser 92.0 - Cleanup 21.2 - SecureLine 5.12 - Driver Updater 21.2 - CCleaner 5.83
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline AntDude

  • Jr. Member
  • **
  • Posts: 64
Re: AvastUI.exe hogs CPU!
« Reply #5 on: May 12, 2010, 04:31:37 PM »
Thanks. Now come come the slow down only happens during real-time shields screens though? Is the graph part doing something intensive to majorly slow down?

doktornotor

  • Guest
Re: AvastUI.exe hogs CPU!
« Reply #6 on: May 12, 2010, 04:32:47 PM »
Is the graph part doing something intensive to majorly slow down?

Well, the graph part is using ActiveX version of Adobe Flash... junky enough as well.

Offline AntDude

  • Jr. Member
  • **
  • Posts: 64
Re: AvastUI.exe hogs CPU!
« Reply #7 on: May 12, 2010, 04:36:27 PM »
Is the graph part doing something intensive to majorly slow down?

Well, the graph part is using ActiveX version of Adobe Flash... junky enough as well.
ActiveX of Flash? What the? I think that's the problem. I know Flash v10 is choppy in Web browsers on that old PC due to onboard Intel video chipset. Is there a way to disable the graphs or use lower quality? Or slow down the monitoring?

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71213
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: AvastUI.exe hogs CPU!
« Reply #8 on: May 12, 2010, 04:53:35 PM »
Thanks. Now come come the slow down only happens during real-time shields screens though? Is the graph part doing something intensive to majorly slow down?

You're welcome..!! :)
Just leave these screens closed, they're not that important.
asyn
Win 8.1 [x64] - Avast PremSec 21.7.6459.IBC [UI.658] - EEK - Firefox ESR 78.12 [NS/uBO/PB] - TB 78.12
Avast-Tools: Secure Browser 92.0 - Cleanup 21.2 - SecureLine 5.12 - Driver Updater 21.2 - CCleaner 5.83
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline AntDude

  • Jr. Member
  • **
  • Posts: 64
Re: AvastUI.exe hogs CPU!
« Reply #9 on: May 15, 2010, 11:23:59 PM »
FYI if this helps at all.

W2K's Device Manager says Intel 82845 G/GL/GE/PE/GV graphics controller and v6.14.104342 (6/21/2005) for the Dell Optiplex's video.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71213
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: AvastUI.exe hogs CPU!
« Reply #10 on: May 16, 2010, 10:08:02 AM »
@antdude:
You should hide your Email in the forum, so it can't be harvested by spammers...!
asyn
Win 8.1 [x64] - Avast PremSec 21.7.6459.IBC [UI.658] - EEK - Firefox ESR 78.12 [NS/uBO/PB] - TB 78.12
Avast-Tools: Secure Browser 92.0 - Cleanup 21.2 - SecureLine 5.12 - Driver Updater 21.2 - CCleaner 5.83
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline yonatan

  • Avast team
  • Jr. Member
  • *
  • Posts: 68
Re: AvastUI.exe hogs CPU!
« Reply #11 on: May 16, 2010, 11:53:04 AM »
Hi,

This graph is not base on ActiveX nor Flash.
does the CPU returns to normal level after you stop the shield?

thanks Yonatan

Offline AntDude

  • Jr. Member
  • **
  • Posts: 64
Re: AvastUI.exe hogs CPU!
« Reply #12 on: May 16, 2010, 03:24:56 PM »
Hi,

This graph is not base on ActiveX nor Flash.
does the CPU returns to normal level after you stop the shield?

thanks Yonatan

Yes.

Offline bb4buck

  • Newbie
  • *
  • Posts: 2
Re: AvastUI.exe hogs CPU!
« Reply #13 on: May 20, 2010, 05:51:22 AM »
 ??? >:( I have the exact same problem on a customer's PC. Windows XP Home SP3...using S3 video drivers onboard video. Every graph causes CPU 100% and only when open. I have to close each graph to do anything at all. Is Avast only doing this on this type of hardware? It's basically un-usable. This happened when the registration window was open also...

Thanks...
-Todd

Offline AntDude

  • Jr. Member
  • **
  • Posts: 64
Re: AvastUI.exe hogs CPU!
« Reply #14 on: May 20, 2010, 05:53:38 AM »
??? >:( I have the exact same problem on a customer's PC. Windows XP Home SP3...using S3 video drivers onboard video. Every graph causes CPU 100% and only when open. I have to close each graph to do anything at all. Is Avast only doing this on this type of hardware? It's basically un-usable. This happened when the registration window was open also...
It seems Avast has problems with graphic rendering on low-end/old onboard video chipsets. I don't recall having problems with the free version's registration (the one to enter an e-mail address).