Author Topic: Gmail +SSl  (Read 10020 times)

0 Members and 1 Guest are viewing this topic.

Offline De Hollander

  • Jr. Member
  • **
  • Posts: 68
Gmail +SSl
« on: June 18, 2010, 09:35:03 PM »
I like to share this with you...  ;)

After reading a couple of topics regarding problems with  Gmail and SSL, I decided to try it for my self with Windows Mail and the default settings for Gmail:

pop.gmail.com / 995 / No SSl
smtp.gmail.com /465 / No SSl

I wasn't able to retrieve or send mail

After changing the port numbers to there default numbers under Windows Mail

pop.gmail.com / 110 / No SSl
smtp.gmail.com /25 / No SSl

The mailscanner works, and I was able to send and retrieve mail.

BTW, I never use Windows Mail.  

« Last Edit: June 18, 2010, 09:45:30 PM by De Hollander »

Offline kraken

  • Newbie
  • *
  • Posts: 6
Re: Gmail +SSl
« Reply #1 on: June 22, 2010, 12:50:58 AM »
I have also not been able to send mail on smtp.gmail.com . If I disable resident protection I can send mail fine. It has no effect on receiving email (IMAP.google.com), just sending / smtp is being blocked. 
I tried removing the servers listed in avast mail shield - SSL accounts, so it would redetect the smtp connection. It detects the connection and puts it back like it should but it still BLOCKS outgoing smtp.
In my case I am using Windows Vista x64 with Mozilla Thunderbird with the latest Avast 5.

Why would Avast be blocking gmail smtp?

Offline sded

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1718
  • Me llamo Ed
Re: Gmail +SSl
« Reply #2 on: June 22, 2010, 01:00:34 AM »
Try port 587, no security for smtp.   Works for me with various versions of TB.
Windows 7 x64HP-SP1-No UAC, Opera 11.51, Avast! Internet Security 6.0.128, Webroot SecureAnywhere latest beta, Windows FW off, MVPS HOSTS, SAS/MBAM offline, Macrium Reflect just in case ;)

Offline kraken

  • Newbie
  • *
  • Posts: 6
Re: Gmail +SSl
« Reply #3 on: June 22, 2010, 01:11:17 AM »
I just figured something out. My email client was configured with port 587/STARTTLS but Avast was setting it to port 465/SSL within the mail shield server setting. Unfortunately changing it to port 587 was not enough in avast, I also had to set encrytion to "none" within avast to get it to send.  So yeah the gmail connection is being automatically set incorrectly within avast. But get this, after successfully sending mail, it set the setting back to TLS and it stops working after sending one email. It keeps port 587, but it changes it back to TLS and it fails. So even if I change it, it changes back to a setting that doesn't work. LOL
It does the same thing if I try to use port 465 with SSL instead of port 587 with STARTTLS. Either way it fails unless I either temporarily disable the mail shield or set it to none for encryption within avast, but then it will set itself back to ssl or tls and stop working after sending one email. :(
FAIL
« Last Edit: June 22, 2010, 01:15:39 AM by kraken »

Offline bks

  • Newbie
  • *
  • Posts: 3
Re: Gmail +SSl
« Reply #4 on: July 30, 2010, 06:38:03 PM »
I just figured something out. My email client was configured with port 587/STARTTLS but Avast was setting it to port 465/SSL within the mail shield server setting. Unfortunately changing it to port 587 was not enough in avast, I also had to set encrytion to "none" within avast to get it to send.  So yeah the gmail connection is being automatically set incorrectly within avast. But get this, after successfully sending mail, it set the setting back to TLS and it stops working after sending one email. It keeps port 587, but it changes it back to TLS and it fails. So even if I change it, it changes back to a setting that doesn't work. LOL
It does the same thing if I try to use port 465 with SSL instead of port 587 with STARTTLS. Either way it fails unless I either temporarily disable the mail shield or set it to none for encryption within avast, but then it will set itself back to ssl or tls and stop working after sending one email. :(
FAIL

I tested what you posted and found mine does the exact same thing -  If I set the encryption on port 587 to none, it works for one email, but then changes it back to TLS and will not work anymore.  This is because avast is set up to automatically gather the port and encryption settings on each port so you send one mail, then it updates it, and it stops working.  So avast either needs to allow you to override this setting and keep it at none, or they need to fix the problem with TLS so you can send mails with it set to that setting. 

There is a valid workaround tho, as I can use secure smtp if I turn off the avast filter for outgoing mail (that's not the best workaround, but all that is available).   

fyi - If the filter is on I get this error:   "Sending of message failed.  An error occurred sending mail: Unable to establish a secure link with SMTP server smtp.me.com using STARTTLS since it doesn't advertise that feature. Switch off STARTTLS for that server or contact your service provider."

This problem started this week after I updated to Avast 5.0.  So for now I just have to keep the filter turned off on outgoing mail.

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9443
Re: Gmail +SSl
« Reply #5 on: July 30, 2010, 08:26:10 PM »
I like to share this with you...  ;)

 ;D ... I missed that post >>> well thank you :D >>> this has been explained and described again and again all over the forums for months and months, but okay, thanks ;D

 but wait, I got a question: how do you explain that it works now ???


« Last Edit: July 30, 2010, 08:28:36 PM by Logos »
w7 - ais7

Offline jadinolf

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
Re: Gmail +SSl
« Reply #6 on: July 30, 2010, 11:00:37 PM »
Try port 587, no security for smtp.   Works for me with various versions of TB.

Ed, if it wasn't for you, I'd still be trying to send messages with avast! installed. Your suggestion of 587 did it but now Port 25 works also.

My ISP uses pop.gmail and smtp.gmail, folks.
printed on 100% recycled bytes

Offline didierSWE

  • Newbie
  • *
  • Posts: 1
Re: Gmail +SSl
« Reply #7 on: September 01, 2010, 11:05:49 AM »
I am getting the same problem (after an update on my mail-server side)

Offline harlen

  • Newbie
  • *
  • Posts: 2
Please HELP with GMAIL & SSL
« Reply #8 on: January 20, 2012, 02:24:51 PM »
Hello,

I read a previous topic on this but it seemed horrendously complicated and unresolved!


I have just installed Avast on a new machine.
With every mail I am getting an avast notice saying I must disable SSL so that incoming mail can be scanned.

I use gmail (POP & SMTP, with Outlook Express ) and I know if I disable SSL I cannot use it.

For now, I have unchecked "automatically detect & warn about unprotected SSL connections"
( in SSL Accounts/Expert Settings/Mail Shield )
This seems to stop the nuisance notice from Avast, but is this OK?

Gmail is an extremly common mail server, surely Avast can work with it. I see other Web recommendations for this issue require dumping Avast! Surely not?

Many Thanks

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 10898
  • No support PM's thanks
Re: Please HELP with GMAIL & SSL
« Reply #9 on: January 20, 2012, 02:30:19 PM »
Hello,

I read a previous topic on this but it seemed horrendously complicated and unresolved!


I have just installed Avast on a new machine.
With every mail I am getting an avast notice saying I must disable SSL so that incoming mail can be scanned.

I use gmail (POP & SMTP, with Outlook Express ) and I know if I disable SSL I cannot use it.

For now, I have unchecked "automatically detect & warn about unprotected SSL connections"
( in SSL Accounts/Expert Settings/Mail Shield )
This seems to stop the nuisance notice from Avast, but is this OK?

Gmail is an extremly common mail server, surely Avast can work with it. I see other Web recommendations for this issue require dumping Avast! Surely not?

Many Thanks

Avast works fine with Gmail, you need to disable the incomming and outgoing security in outlook so that avast can then takeover, see here http://support.avast.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=917&nav=0

Offline Pondus

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 36047
Re: Gmail +SSl
« Reply #10 on: January 20, 2012, 03:34:39 PM »
Quote
Gmail is an extremly common mail server, surely Avast can work with it. I see other Web recommendations for this issue require dumping Avast! Surely not?
It works just fine..

Quote
This seems to stop the nuisance notice from Avast, but is this OK?
It is OK...if you do not want avast to scan the mail. It is already scanned by Gmails own security programs

the warning is there to tell you that IF you want avast to scan your mail for virus, you must dissable SSL in your email client and enable SSL in avast
Chief Wiggum: Uh, no, you got the wrong number. This is 9-1…2.


Offline harlen

  • Newbie
  • *
  • Posts: 2
Re: Gmail +SSl
« Reply #11 on: January 20, 2012, 03:55:56 PM »
Thanks Craig.
I've studied the video.

I'm using Outlook Express (not Outlook) but I think I understand it.

However, the information in (Ports etc. ) is already in the SSL accounts (in expert settings/Webshield)......And I know (from previous wrong settings) that if I disable SLL in my Gmail account in OE (as the video states) my gmail will not work!
So I can't do that.
What is wrong with the action I have taken to stop the notice?
Isn't the mail scanned by Gmail?

Offline Pondus

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 36047
Re: Gmail +SSl
« Reply #12 on: January 20, 2012, 04:11:22 PM »
Quote
What is wrong with the action I have taken to stop the notice?
Isn't the mail scanned by Gmail?
did you not read my post?

Gmail is protecting all accounts with Postini spam/virus filter, using twin AV engines from Authentium and McAfee, so your mail is protected

IF you want additional scan from avast you must dissable the SSL settings in your mail client and let avast take care of the SSL connection....

what is SSL/TLS   http://en.wikipedia.org/wiki/Transport_Layer_Security


avast! 6.x: Some e-mails are not scanned by the Mail Shield
http://support.avast.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=842&nav=0


« Last Edit: January 20, 2012, 11:01:50 PM by Pondus »
Chief Wiggum: Uh, no, you got the wrong number. This is 9-1…2.


Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: Gmail +SSl
« Reply #13 on: January 20, 2012, 04:51:38 PM »
if I disable SLL in my Gmail account in OE (as the video states) my gmail will not work!
So I can't do that.
Yes you can. You are missing the point. Gmail requires SSL. You EITHER set it in your email client (OE) OR in Avast, not both and not in neither, but MUST be one (and only one) of them.
Quote
What is wrong with the action I have taken to stop the notice?
Isn't the mail scanned by Gmail?

If:
_OE without SSL for gmail account; AND
_Avast with SSL for gmail account

then you can receive and send emails for that gmail account, AND avast also scans them.

If:
_OE with SSL for gmail account; AND
_Avast without SSL for gmail account

then you can receive and send emails for that gmail account, AND avast will NOT scan them (only the built in gmail protection in their server will scan for malware).

If either:

_OE with SSL for gmail account; AND also
_Avast with SSL for gmail account

OR

_OE without SSL for gmail account; AND also
_Avast without SSL for gmail account

then you can NOT receive and send emails for that gmail account.

HTH.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?