Author Topic: No Sound in Firefox and IE8  (Read 14963 times)

0 Members and 1 Guest are viewing this topic.

Offline tonyy

  • Newbie
  • *
  • Posts: 5
No Sound in Firefox and IE8
« on: July 02, 2010, 03:21:27 PM »
We are running Avast pro 5.0.594 and I am pleased to say that IE8 now runs in the sandbox.  However there is no sound, nor when using Firefox 3.6.6 in the sandbox.  We tested this on 3 different hardware set-ups - however all running XP SP3.

A couple of our users need their browser to be in the sandbox, but they do view sites with sound.  Business sites with sound include technical webcasts and tutorials.  We have not been thorough in our checks (did not check all types of sound source), but the common sites do not work.  For a quick check You-tube was the reference as it does not require log in.

I have run Firefox in the sandbox for a week and the only amusing problem was watching it trying to update itself, at least IE8 will update outside of the sandbox via Windows update.  As we do not want to have to visit every user weekly we may have to insist on IE8 as I cannot see how to get Firefox updated any other way.  So apart from sound and updates I found no other problem.
« Last Edit: July 02, 2010, 03:23:28 PM by tonyy »

Offline bobo1

  • Poster
  • *
  • Posts: 471
Re: No Sound in Firefox and IE8
« Reply #1 on: July 02, 2010, 05:20:35 PM »
No sound problem using avast free on my computer latest version?. Maybe a bug in full version. Check sound properties via control pannel in xp? or use avast free just as good as long as you use a good firewall!
« Last Edit: July 02, 2010, 05:22:36 PM by bobo1 »
IBM T41 INTEL CENTRINO 1.6GHZ  3. XP SP3. 1000 MB RAM. 80GB HARD DRIVE. AVAST 9. MALWAREBYTES FREE.
NEW TEST RIG FUJITSU (SCALEO) 2.8GHZ 3000MB RAM DVI HD OUT SVGA PENT 4 AVAST 9. GAMING RIG

Offline tonyy

  • Newbie
  • *
  • Posts: 5
Re: No Sound in Firefox and IE8
« Reply #2 on: July 05, 2010, 10:48:42 AM »
Sorry Bobo1,

Sandbox is a new feature of Avast Pro and is a virtual machine for running software isolated from the rest of the system. :)

I also run Avast free at home and have no known problems or side effects ;), that is why we are new customers to Avast Pro (kicking out McAfee).  The main difference in the pro version is that more granular settings are available which are either hidden (e.g. right click not active) or greyed out, plus of course the extra features described on the website (pointless repeating that data here).  From the information available the main engine is the main engine regardless of version.

Our 15 machines are functioning perfectly and are evenly aged over 5 years and all running XP.  There are no problems on any machine except when we try to run the browsers in the sandbox.  Programs outside the sandbox still give sound it is just the browser when in the sandbox which does not.

Oh. If anyone suspects McAfee.  We uninstalled, removal tooled, and sanitised ;D the machines first before installation (we were thorough), except on one machine where a Malware infection was so bad it was vaporised first.

Offline the_slasher

  • Newbie
  • *
  • Posts: 3
Re: No Sound in Firefox and IE8
« Reply #3 on: July 05, 2010, 05:50:15 PM »
hi tonyy, i have the same experience however it's just in firefox 3.6.6 (i never tested in ie 8) but for me the sound was being diverted to another output. maybe you can open the playback devices while playing youtube to see which one is being used. then disable that leaving only the playback device that points to the speakers.

when this sound diversion happens. I can see that firefox.exe and audiodg.exe are being virtualized. hhm did you install/update to the latest flash player? i only started noticing this after that update (although i don't usually watch on youtube hehe)

Offline tonyy

  • Newbie
  • *
  • Posts: 5
Re: No Sound in Firefox and IE8
« Reply #4 on: July 06, 2010, 11:44:14 AM »
 :-\ Well I only have one sound device and the settings looked ok.  I can even be playing a sound track in the background (media player) which continues.  Normally the sounds would mix.

 8) Just tried running media player virtualised 8)  It ran but on selecting a track and pressing play it didn't.  Message:"The sound device was either not present or busy".

I tested this pre and post the latest (yesterday) flash update.  However when either IE or Firefox are virtualised there are no other runtimes shown in the virtualisation monitor window

Offline Jon_T

  • Full Member
  • ***
  • Posts: 129
Re: No Sound in Firefox and IE8
« Reply #5 on: July 12, 2010, 01:11:18 AM »
However there is no sound, nor when using Firefox 3.6.6 in the sandbox.  We tested this on 3 different hardware set-ups - however all running XP SP3. ...

Ditto ... This has been the only problem I've had with avast! 5 with IE 8 and Fx 3.6.x on both of my Dell Win XP SP3 systems.

Before first installing avast! 5 IS, I uninstalled Sandboxie just to make sure to eliminate any possible problems/issues. I've tried the uninstall/reinstall of avast! 5 and did not help.  Given the there has been known issues with avast! 5's visualization process I figured I wait to see if newer versions would address the problem -- it has not.  So I've gone back to using Sandboxie until avast! can fix the problem.
Core2Duo E6300 • 2GB Ram • WinXP Pro SP3 (LUA) • avast! AIS 5.0.6077 (w/o FW/SF) • Online Armor Premium • MBAM (resident) • SAS Pro (on demand) • SpywareBlaster

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2085
Re: No Sound in Firefox and IE8
« Reply #6 on: July 31, 2010, 01:34:12 AM »
@tonyy, the_slasher, Jon_T:

confirmed and I've already fixed it today, sorry for delay -- this happened only under some OSes (WinXP in your cases). When audio library in your browsers tried to access some restricted registry keys, it was blocked by sandbox and thus was not properly initialized (= no sound).

Offline jadinolf

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
Re: No Sound in Firefox and IE8
« Reply #7 on: July 31, 2010, 07:04:07 AM »
@tonyy, the_slasher, Jon_T:

confirmed and I've already fixed it today, sorry for delay -- this happened only under some OSes (WinXP in your cases). When audio library in your browsers tried to access some restricted registry keys, it was blocked by sandbox and thus was not properly initialized (= no sound).

Really?

No sound here.
printed on 100% recycled bytes

Offline CBell

  • Full Member
  • ***
  • Posts: 151
Re: No Sound in Firefox and IE8
« Reply #8 on: July 31, 2010, 07:13:38 AM »
@tonyy, the_slasher, Jon_T:

confirmed and I've already fixed it today, sorry for delay -- this happened only under some OSes (WinXP in your cases). When audio library in your browsers tried to access some restricted registry keys, it was blocked by sandbox and thus was not properly initialized (= no sound).

Really?

No sound here.


He probably fixed it in the private build
Win7 64bit / Avast Premier / Malwarebytes Pro

Offline jadinolf

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
Re: No Sound in Firefox and IE8
« Reply #9 on: July 31, 2010, 07:43:24 AM »
@tonyy, the_slasher, Jon_T:

confirmed and I've already fixed it today, sorry for delay -- this happened only under some OSes (WinXP in your cases). When audio library in your browsers tried to access some restricted registry keys, it was blocked by sandbox and thus was not properly initialized (= no sound).

Really?

No sound here.


He probably fixed it in the private build

What does that mean? Not familiar with the term.
printed on 100% recycled bytes

Offline Dch48

  • Massive Poster
  • ****
  • Posts: 3150
Re: No Sound in Firefox and IE8
« Reply #10 on: July 31, 2010, 07:55:27 AM »
It means he fixed it for the next release of Avast! not in the present one.
Avatar FX6327X desktop, FX-6300 CPU, RX 470 GPU, 8GB RAM, Windows 10 Home 64 bit
HP dv6-6140us laptop, A8-3500M APU, 8GB RAM, Windows 7 Home Premium 64 bit
RCA W101 v2 10" tablet, Intel Atom Bay Trail Z3735F processor, 2GB RAM, Windows 10 Home 32 bit

Offline jadinolf

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
Re: No Sound in Firefox and IE8
« Reply #11 on: July 31, 2010, 03:35:53 PM »
It means he fixed it for the next release of Avast! not in the present one.

Ah... thank you.
printed on 100% recycled bytes

Offline Dch48

  • Massive Poster
  • ****
  • Posts: 3150
Re: No Sound in Firefox and IE8
« Reply #12 on: July 31, 2010, 09:55:11 PM »
This points out why I do not use any form of sandboxing and won't unless I'm forced into it. It just causes too many headaches.
Avatar FX6327X desktop, FX-6300 CPU, RX 470 GPU, 8GB RAM, Windows 10 Home 64 bit
HP dv6-6140us laptop, A8-3500M APU, 8GB RAM, Windows 7 Home Premium 64 bit
RCA W101 v2 10" tablet, Intel Atom Bay Trail Z3735F processor, 2GB RAM, Windows 10 Home 32 bit

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2085
Re: No Sound in Firefox and IE8
« Reply #13 on: July 31, 2010, 10:53:46 PM »
This points out why I do not use any form of sandboxing and won't unless I'm forced into it. It just causes too many headaches.

Well, it takes some time to iron out the kinks.. I usually test it under 7 different OSes with different applications, but I'm not able to reveal all bugs unless someone reports it here or by email. Some of them are not present only on specific OSes, etc.

Offline Rednose

  • Pirate Party Member
  • Avast Überevangelist
  • Massive Poster
  • *****
  • Posts: 3744
  • Bits of Freedom : https://www.bof.nl
    • Nederlandstalig Avast! forum
Re: No Sound in Firefox and IE8
« Reply #14 on: August 01, 2010, 01:56:07 AM »
Petr,

You are doing great :) But I assume it is no surprise hearing that from me ;)

Greetz, Red.
OS: Win 10 / iOS 14 / Debian 10 / Tails 4
Real Time: Avast Premium Security
On Demand: Malwarebytes
VPN: NordVPN ( NordLynx ) with CyberSec