Author Topic: Another AIS Firewall Issue  (Read 2093 times)

0 Members and 1 Guest are viewing this topic.

MAG

  • Guest
Another AIS Firewall Issue
« on: July 23, 2010, 02:30:05 PM »
I got fed up with the UI constantly configuring itself to access the internet (a bug discussed in another thread), so I went into firewall application rules and selected "Bock all connections" against avastUI.exe.

Click on the summary tab, go back to the application rules, and the rule has changed to "internet out other wise auto-decide".

Surely it shouldn't do this - this was not a new progam with no defined rules on the application rules page - it was an existing program that had a rule defined by me  - Block.

So I change the policy from "auto-decide" to "ask" for new programs. Now avastIU.exe stays blocked - and I don't get asked anything!

Now this may all be expected behaviour, but it doesn't seem logical to me.

PS - It has now popped up asking me if I want to allow avastUI.exe to access the Web. Since it still shows the "Block" rule for avastUI.exe I assume it thinks this is a different file?
« Last Edit: July 23, 2010, 02:57:59 PM by mag »

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Another AIS Firewall Issue
« Reply #1 on: July 23, 2010, 03:47:29 PM »
Hi Mag, where do you have avast installed? Is it the default C:\Program Files\Alwil Software\Avast5\ folder?

How is this folder represented in the rules DB, would you mind sending me the rules.xml file?

Thanks. Lukas.

MAG

  • Guest
Re: Another AIS Firewall Issue
« Reply #2 on: July 23, 2010, 04:22:42 PM »
1. - yes that's where it is (I've always just let avast install to its default location)
2.  - I've e-mailed you the rules.xml file (to rypacek)
Thanks for your help