Author Topic: ASLR/DEP disabled to AvastUI.exe  (Read 15391 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82561
  • No support PMs thanks
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #15 on: August 04, 2010, 03:45:47 PM »
<snip>
Thanks for your reply
Yes

Thought i would ad a attachment

Thanks for the 'small' attachment ;D

If you play with the Process Explorer, 'Process' column heading you will see some differences in the results as the column (my small image attachment), aside from changing the ordering it is also a toggle for different views.

So why my system with the same OS, XP Pro SP3 and avast 5.0 free shows DEP for both avastUI and avastSvc yet yours doesn't is beyond me.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4257.552) UI-1.0.440/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline ardvark

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1512
  • John 3:16 (I'm not an "avast! evangelist")
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #16 on: August 04, 2010, 07:43:53 PM »
Hi all....

Was there something you had to enable in Process Explorer to see this information? My copy doesn't and I'm running as an administrator. ???

Regards...

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82561
  • No support PMs thanks
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #17 on: August 04, 2010, 08:22:06 PM »
Only in the columns that are viewed if you don't have that category selected then there will be no corresponding column.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4257.552) UI-1.0.440/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2096
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #18 on: August 04, 2010, 08:38:05 PM »
There is however some disparity even between the same OS XP SP3 as some are showing DEP used yet others aren't. Now as far as I'm aware DEP is also hardware dependant and I don't know if AMD processors are fully DEP enabled. There is also that wrinkle about what analysis tool you are using (process explorer) and if you are running it as Admin, etc. So those may be other areas where there will be disparity between different user systems.

There is a small utility available to determine hardware DEP capability.

http://www.grc.com/securable.htm

Quote
Modern processors incorporate features beneficial to
security.  SecurAble displays the status of the three
most significant security-related processor features:

SecurAble probes the system's processor to determine the presence, absence and operational status of three modern processor features:

    * 64-bit instruction extensions,
    * Hardware support for detecting and preventing
      the execution of code in program data areas, ... and
    * Hardware support for system resource “virtualization.”
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: Avast Premium Security 19.7.2388, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68.0.2, MBam Free, CCleaner

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82561
  • No support PMs thanks
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #19 on: August 04, 2010, 09:44:29 PM »
That's a pretty old tool just over two years old, ancient in terms of processor development so I though it wouldn't recognise the later AMD/Intel CPUs; though it does seem to do that.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4257.552) UI-1.0.440/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2096
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #20 on: August 04, 2010, 09:54:45 PM »
My machine is older than the program.  Perhaps someone with an I7 processor installed could test Securable and report if it's valid for newer processors.
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: Avast Premium Security 19.7.2388, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68.0.2, MBam Free, CCleaner

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82561
  • No support PMs thanks
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #21 on: August 04, 2010, 10:51:29 PM »
Mine is less than two years and the intel Core2Duo E8300 is less than two years old I believe and it was able to detect that correctly and say that Hardware DEP is disabled on my system (I need to check out the BIOS settings), so only software DEP protection.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4257.552) UI-1.0.440/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Silviu C.

  • Full Member
  • ***
  • Posts: 108
  • White'n nerdy
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #22 on: August 04, 2010, 11:57:28 PM »
Look for some feature with NX bit or No-execute bit in the BIOS.

Are you sure that DEP is in opt-in mode on your system? I ask because I do remember looking at Avast in procexp and it did not see it use DEP and because I highly doubt that the guy that programmed ClocX would bother to use DEP...
Someone is speaking well of you.

How unusual!

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82561
  • No support PMs thanks
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #23 on: August 05, 2010, 12:47:31 AM »
I I did opt-in on the software DEP in the OS some time ago (see image) as virtually all of the processes in my process explorer list are DEP, the exceptions are the ones that aren't only 3 of them.

I have only 2 that are DEP (permanent) Firefox and the Plugin Container for Firefox.
« Last Edit: August 05, 2010, 12:55:02 AM by DavidR »
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4257.552) UI-1.0.440/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Silviu C.

  • Full Member
  • ***
  • Posts: 108
  • White'n nerdy
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #24 on: August 05, 2010, 02:12:10 AM »
Ah, there it is. That is why Avast shows as using DEP. I guess as long as apps do not act badly with this setting it's certainly worth keeping it that way.
Someone is speaking well of you.

How unusual!

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82561
  • No support PMs thanks
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #25 on: August 05, 2010, 02:30:08 AM »
Well I don't have any BSODs or any unexplained behaviour.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4257.552) UI-1.0.440/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

crofty59

  • Guest
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #26 on: August 05, 2010, 02:30:57 AM »
Thanks DavidR

Sorry for the large attachment.
it is also a mystery to me, why DEP doesn't show on my system for Avast.


Cheers

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82561
  • No support PMs thanks
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #27 on: August 05, 2010, 03:54:34 AM »
Well if you read the last few posts, it may be that I'm forcing it to be used by my selection of the software DEP protection for all applications (my last image posted).
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4257.552) UI-1.0.440/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

crofty59

  • Guest
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #28 on: August 05, 2010, 06:57:05 AM »
Well if you read the last few posts, it may be that I'm forcing it to be used by my selection of the software DEP protection for all applications (my last image posted).

Thanks DavidR
I did read the last few posts, but i am not the "sharpest tool in the shed".
I will go and check it out.
Cheers

Edit: Took me a couple of minutes on Google to find where to go to change (dep) settings. :-[
       So now dep is showing on (AvastSvc.exe and also AvastUI.exe.)
 
      Thanks once again DavidR
Cheers
« Last Edit: August 05, 2010, 07:11:46 AM by crofty59 »

Offline ardvark

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1512
  • John 3:16 (I'm not an "avast! evangelist")
Re: ASLR/DEP disabled to AvastUI.exe
« Reply #29 on: August 05, 2010, 08:56:31 AM »
Only in the columns that are viewed if you don't have that category selected then there will be no corresponding column.

Hi David...

Got it, thank you! :)

Regards...