Author Topic: Scanning outgoing emails with SSL enabled - cant send in Outlook Express  (Read 4359 times)

Offline sh2811

  • Newbie
  • *
  • Posts: 15
    • Personal Message (Offline)
Hi.
I am using Demon's SMTP server to send emails and they tell me to use port 465 with SSL enabled. Avast popped up and told me to disable SSL in my mail client and allow Avast to scan the outgoing mail and apply the security itself.
I disabled SSL in Outlook Express and checked the SSL settings in Avast which appear correct.
However I can not send out emails with that configuration, OE just times-out.
Can anyone suggest what is going on please? I switched to Avast from Antivir and one reason for that was to show the outbound emails had been scanned.
I assume I don't need to reboot my machine for the changes to take effect?

Many thanks,
Stu.

Offline sh2811

  • Newbie
  • *
  • Posts: 15
    • Personal Message (Offline)
Hmmm no ideas anyone? Did I mention the monetary reward available for supplying the correct solution? Joking aside... can't anyone help please?
I have rebooted since the last message and of course that made no difference. I'm guessing Avast must be able to do this as the help message states it should work so is this a bug?
Thanks (hopefully).
Stu

Offline DavidR

  • avast! Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69210
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Offline)
IF you have disabled (unchecked) the SSL required on OE - Try deleting the entry for this account in the avast Mail Shield, Expert settings, SSL Accounts and reboot. This should recreate the entry.

However, I have never used Avira and I don't know how its email scanning works, although if you say it doesn't scan outbound email I don't know if there might still be some conflict there if there are any remnants of Avira left behind.

Are you able to receive and scan inbound email with avast ?

- Avira AntiVir Uninstall Package & RegistryCleaner (choose appropriate version): http://www.avira.com/en/support/support_downloads.html, Avira RegistryCleaner.
- Also see, How to Remove Antivir Antivirus
http://www.pchell.com/virus/uninstallantivir.shtml

Uninstall Avira Antivir Completely
http://www.themisteriosos.com/uninstall-avira-antivir-completely.htm
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2018/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline jadinolf

  • avast! Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
  • Gender: Male
    • Personal Message (Offline)
I don't use your email client but I had to change from port 465 to 25 and then I could send mail.

Offline sh2811

  • Newbie
  • *
  • Posts: 15
    • Personal Message (Offline)
Many thanks to both of you.

I ran the Avira Antivir registry tool which 3 entries that mentioned Avira so I removed those. Avira had uninstalled successfully as far as I could tell when I removed it, i.e. no remnants in add/remove programs and no error messages. So I suspect that part was all OK.

I then changed the SMTP settings in OE to use port 465 without SSL and then deleted all entries in Avast's SSL accounts section. I didn't try a full reboot as my patience wouldn't let me (thought I would keep that option for later as a last resort).

OE would still not send a message.

I then tried changing OE to use port 25, again without SSL, and also deleting all Avast's SSL accounts again. This time OE sent the message without issue and added the "outbound message clean signature". I had sent it to myself so it came back in again straight away. Marvellous! Solved. Thank you!

So how does Avast know to enable SSL for that account? Where is it getting its setup information from?

I am a little curious and surprised as Avast added two entries in its SSL accounts;
Demon.net - SMTP - Port 465 - SSL
Demon.net - POP3 - Port 995 - SSL.
OE is set to use port 25 but Avast has created an SMTP account using port 465. So does Avast redirect the SMTP port 25 to 465 that Demon requires? How does it know Demon wants 465 or is that a standard port number used for SSL connections?
Also, why has Avast created a POP3 account using port 995 and with SSL enabled when OE uses port 110 for its POP3 incoming emails and with SSL disabled?

Big thanks for the help and pointers. I never thought to try setting OE to use a port number other than what Demon require.
Stu.

Offline sh2811

  • Newbie
  • *
  • Posts: 15
    • Personal Message (Offline)
Forgot to say that yes i could receive and scan incoming emails using Avast without issue. Demon say to use port 110 without SSL for the POP3 connection.
As for Avira If memory serves me correctly it didn't scan incoming or outgoing messages which seems a bit of a strange idea to me.
Stu

Offline jadinolf

  • avast! Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
  • Gender: Male
    • Personal Message (Offline)
Forgot to say that yes i could receive and scan incoming emails using Avast without issue. Demon say to use port 110 without SSL for the POP3 connection.
As for Avira If memory serves me correctly it didn't scan incoming or outgoing messages which seems a bit of a strange idea to me.
Stu
Glad you got it working. port 587 also worked for me.

I had terrible problems when Version 5 was in beta but a great guy on this forum set me straight regarding ports. I never would have known to change it.

edit: I would just ignore that SSL information.
« Last Edit: August 23, 2010, 04:38:37 PM by jadinolf »

Offline sh2811

  • Newbie
  • *
  • Posts: 15
    • Personal Message (Offline)
Thanks jadinolf.
I have a terrible affliction whereby I always need to know the answers so ignoring the SSL info doesn't sit comfortably in my annoying head! I wish I was wired differently at times! Maybe DavidR can shed some light?

I'm curious and want to be sure of what is going on as I just changed back to using Demon's SMTP server. I use Demon for my email account but am with T-Mobile for my phone & internet connection (I don't have a landline). Many months ago I had an email issue and T-Mobile told me that I wouldn't be able to access Demon's SMTP server because my connection was with T-Mobile. That seemed odd to me but I just accepted it as I wanted my post to leave my PC. It now turns out that advice was incorrect so I have switched back to using Demon's SMTP and POP3 servers but want to be sure it is all set up the best it can be especially as I had been having some posts returned as undeliverable. That issue was down to T-Mobile not using authenticated SMTP servers and the email recipient's server rejecting non-authenticated mails. I guess I am trying to dot all the 'i's and cross all the 't's.

I really appreciate the help especially as there were no takers when I first asked for advice.
Stu.

Offline jadinolf

  • avast! Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
  • Gender: Male
    • Personal Message (Offline)
Stu, I don't know what that info is all about. I  do know that my info is wrong and since I no longer use SSL, who cares?

Some one will be along to give you the correct information.

Now, what was this about a monetary award??? Was that Pounds, Euros or USD? ;)


Offline sh2811

  • Newbie
  • *
  • Posts: 15
    • Personal Message (Offline)
Thanks again jadinolf. No problem - nobody knows everything! Did I not say that the reward was for a complete solution? You gave me the 'change back to port 25' solution but sadly don't have all the answers. Now it may be argued that is a mere technicality but but but.... Panicking? Me? Tell you what... pop round and I'll buy you a drink. You'll have to cover the plane ticket though I'm afraid. I could always dig out some French Francs or German Deutschmarks I have in a pot somewhere. What do you mean they aren't used anymore?. OK you caught me out, I may have stretched the truth a little. Sorry. I am in your debt though. Thanks again.

Offline jadinolf

  • avast! Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
  • Gender: Male
    • Personal Message (Offline)
Re: Scanning outgoing emails with SSL enabled - cant send in Outlook Express
« Reply #10 on: August 23, 2010, 08:00:25 PM »
Thanks again jadinolf. No problem - nobody knows everything! Did I not say that the reward was for a complete solution? You gave me the 'change back to port 25' solution but sadly don't have all the answers. Now it may be argued that is a mere technicality but but but.... Panicking? Me? Tell you what... pop round and I'll buy you a drink. You'll have to cover the plane ticket though I'm afraid. I could always dig out some French Francs or German Deutschmarks I have in a pot somewhere. What do you mean they aren't used anymore?. OK you caught me out, I may have stretched the truth a little. Sorry. I am in your debt though. Thanks again.
:)

Offline Pondus

  • avast! Überevangelist
  • Maybe Bot
  • *****
  • Posts: 21689
  • Gender: Male
    • Personal Message (Offline)
Re: Scanning outgoing emails with SSL enabled - cant send in Outlook Express
« Reply #11 on: August 23, 2010, 08:26:21 PM »
Quote
However, I have never used Avira and I don't know how its email scanning works, although if you say it doesn't scan outbound email I don't know if there might still be some conflict there if there are any remnants of Avira left behind.
It does not...work....... Avira free does not have a mailscanner
Chief Wiggum: Uh, no, you got the wrong number. This is 9-1…2.


Offline sh2811

  • Newbie
  • *
  • Posts: 15
    • Personal Message (Offline)
Re: Scanning outgoing emails with SSL enabled - cant send in Outlook Express
« Reply #12 on: August 23, 2010, 08:32:41 PM »
Hi. Yep, thought so. I'm sure there is a good reason for not having one but it seems like a feature most people like to have.

Offline Pondus

  • avast! Überevangelist
  • Maybe Bot
  • *****
  • Posts: 21689
  • Gender: Male
    • Personal Message (Offline)
Re: Scanning outgoing emails with SSL enabled - cant send in Outlook Express
« Reply #13 on: August 23, 2010, 08:53:03 PM »
Quote
Hi. Yep, thought so. I'm sure there is a good reason for not having one but it seems like a feature most people like to have.
yea....there was a debate here about that.
anyway free versions must have some limitations compared to full version, if not why buy the full?
Chief Wiggum: Uh, no, you got the wrong number. This is 9-1…2.


Offline logos

  • avast! Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9456
  • Gender: Male
    • Personal Message (Offline)
Re: Scanning outgoing emails with SSL enabled - cant send in Outlook Express
« Reply #14 on: August 23, 2010, 08:57:32 PM »
@ sh2811: it's quite simple, Avast mail shield, when it's turned on, detects your email accounts in clients, and can immediately tell if the account requires ssl or not. If it does, you need to deactivate ssl in the client (OE in your case) and use standard ports. All your incoming and outgoing messages will be rerouted internally to the mail shield proxy that will in turn redo (reroute) the ssl incoming and outgoing connections to your email provider server using ssl ports.
w7 - ais7

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now