Author Topic: On-Access protection isn't working!!!!  (Read 3320 times)

0 Members and 1 Guest are viewing this topic.

Offline Geas

  • Newbie
  • *
  • Posts: 3
  • avast! rulez!
On-Access protection isn't working!!!!
« on: July 06, 2003, 06:40:25 AM »
Hello I'm new to the forum.

Here's the issue.... Since the last update, everytime on-access protection tries to launch one of the 3 modules (e-mail, standard shield, etc) a popup window tells me this:

Title bar-> avast!:The AAVM subsystem detected an RPC error.
Body->The operation could not be completed
Button-> Accept
(I'm a spanish avast! user...so the message was translated by me)

On-access control task bar icon looks like it's disabled (looks excatly like when you issue the STOP & EXIT command)

Just once the event viewer did show this error report:

Tipo de suceso:   Error
Origen del suceso:   avast!
Categoría del suceso:   Client
Id. suceso:   90
Fecha:      05-07-03
Hora:      23:43:23
Usuario:      NT AUTHORITY\SYSTEM
Equipo:   **********
Descripción: AAVM - initialization error: AavmStart: avworkInitialize failed, 0000A413.

OS: Windows XP Spanish (all updates, SP1..etc..etc.etc...)

Thanks in advance for any help you could provide.

Gaston.
« Last Edit: July 06, 2003, 06:41:38 AM by Geas »

Offline Geas

  • Newbie
  • *
  • Posts: 3
  • avast! rulez!
Re:On-Access protection isn't working!!!! on 4.0.235
« Reply #1 on: July 06, 2003, 08:14:38 AM »
just for you to know, I've uninstalled the current version 4.0.235 (spanish), and reinstalled the Feb2003 4.0.168 (english) version of avast!
The downgrade solved the problem and now avast! On-access protection control works just fine.
This is a 4.0.235 issue.
Is there any workaround??????

Offline Vlk

  • Global Moderator
  • Serious Graphoman
  • **
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:On-Access protection isn't working!!!!
« Reply #2 on: July 06, 2003, 04:30:01 PM »
What happens if you upgrade again to v. 235 (English)?


It should be working OK. Error 0000A413 means something went really wrong, such as the virus DB file being badly damaged...

Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Geas

  • Newbie
  • *
  • Posts: 3
  • avast! rulez!
Re:On-Access protection isn't working!!!!
« Reply #3 on: July 06, 2003, 09:03:34 PM »
Thanks Vlk for the wquick response.
Tried that  a few minutes ago, didn't work.
Running 4.0.168 I used the Updating->Program Update feature....downloaded everything...restarted...and the On-access protection didn't come up. When I tried to get to the control, I end up getting the same RPC error.
Reinstalled version 4.0.168 and it is running OK.
 ??? ??? ??? :( :( :(

Am I the only one getting this kind of trouble with the new release????

Geas.