Author Topic: Update from Avast 4 to Avast 5 causes massive problems with Mail Shield  (Read 5732 times)

0 Members and 1 Guest are viewing this topic.

Offline EdRandom

  • Newbie
  • *
  • Posts: 2
Dear Avast team,

First of all, thanks for creating and maintaining an excellent and free security product!

Several (mostly elderly) family members that still use Windows, have Avast Free edition running for their antivirus and email protection.

Since their automatic upgrade from Avast 4 to Avast 5, they have all experienced a complete failure of their email functionality. I checked, and there are no warning messages at all. Mail reception fails silently: the status bar shows the normal pop/imap server login messages but no email is ever received.

For them, the only way to regain email was to disable the Mail Shield completely. They then started receiving all their back-logged email that was on the POP/IMAP server. This is of course not a good solution.

They did not, by the way, change email clients during the Avast upgrade. Their email worked before, and stopped working after the Avast 5 upgrade. They run a variety of WinXP, Vista and 7 Home Premium on their PC's. For email, they mostly use Thunderbird and Incredimail.


This appears to be a serious regression in Avast 5.

If the Mail Shield functionality changed this fundamentally, it might have been wise to put a warning message onscreen telling them that certain settings had to be changed/verified for Avast 5. I have not yet found a solution that properly solves this issue in a way that I can explain to these elderly family members ;-)

Thanks for your time,
  Ed.

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37014
Re: Update from Avast 4 to Avast 5 causes massive problems with Mail Shield
« Reply #1 on: September 12, 2010, 04:52:23 PM »
Some info here if they use mail accounts with SSL connection

avast! 5.x: The Mail Shield may not scan some e-mails
http://support.avast.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=458

Offline EdRandom

  • Newbie
  • *
  • Posts: 2
Re: Update from Avast 4 to Avast 5 causes massive problems with Mail Shield
« Reply #2 on: September 24, 2010, 03:02:10 PM »
Hi,

Thanks for the link, it was helpful information.

The main issue remains; that Avast SILENTLY breaks all email functionality after the 4 -> 5 upgrade.

I have already had some requests to uninstall Avast since "their PC is broken" after an automatic Avast upgrade. I cannot imagine that Avast wishes this kind of publicity, especially for their Freemium product...

Kind regards,
  Ed.

Offline Tony53

  • Newbie
  • *
  • Posts: 6
Re: Update from Avast 4 to Avast 5 causes massive problems with Mail Shield
« Reply #3 on: November 11, 2010, 02:22:08 PM »
I have exactly the same problem. I cannot find a resolution. Is there one? Have I missed it? Any help would be greatly appreciated.

Offline Tony53

  • Newbie
  • *
  • Posts: 6
Re: Update from Avast 4 to Avast 5 causes massive problems with Mail Shield
« Reply #4 on: November 11, 2010, 04:21:20 PM »
I found a solution.

To enable incoming mail:

(from http://www.warriorforum.com/main-internet-marketing-discussion-forum/187513-avast-blocking-your-email-heres-fix.html)

Quote
It seems like a lot of people are having trouble with the latest version of Avast, the free virus checking software. Suddenly, Avast is blocking access to POP and IMAP email accounts.

If you're having this problem, here's the fix:

1. Open Avast

2. Click on 'Settings' (upper right corner of page)

3. Click on 'Troubleshooting'

4. Click on 'Redirect Settings'

5. Clear all the port #'s from each field

6. Check 'Ignore Local Communication'

7. Click 'OK'

8. Close Avast

Problem solved!

To enable outgoing mail:


1. Open avast! user interface

2. Click 'Real Time Shields | Mail Shield'

3. Click 'Expert Settings'

4. Click 'SSL Accounts'

5. Click 'Add'

6. Enter your SMTP server name in the 'Host Name' field, select SMTP in the 'Protocol' field, enter the port number (25) in the 'Port' field and select the encryption.

7. Click 'OK'

8. Close avast! user interface



I would have expected that several months after the release of avast! 5 the upgrade process from 4 would not render my email completely unusable and cause me to waste several hours trying to find a fix.  >:(


Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5198
Re: Update from Avast 4 to Avast 5 causes massive problems with Mail Shield
« Reply #5 on: November 12, 2010, 11:43:00 AM »
@ Tony53,

The link Pondus gave you in his post gave you the information you needed plus more.  It could have saved you time of searching, but we are more than happy to answer your questions here if you have more.  Thank you.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline Tony53

  • Newbie
  • *
  • Posts: 6
Re: Update from Avast 4 to Avast 5 causes massive problems with Mail Shield
« Reply #6 on: November 12, 2010, 12:18:37 PM »
@SafeSurf

I did read and apply the information provided by Pondus. It did not solve the problem.

My POP3 accounts do not use encryption but even trying adding them to the SSL Accounts with an encryption method of None did not work.

The only way I found of receiving incoming mail was to clear all the port numbers from the Troubleshooting section as suggested in the warrior forum post.

The only way I found of enabling outgoing mail was to add my SMTP server to the SSL Accounts depsite the fact that it does not use encryption.

Although it took me a couple of hours to find the fix, I am glad I did. Avast! has saved my bacon on many an occassion and I did not want to run without the email shield and did not want to change antivirus program. I would however have expected that something which worked properly under avast! 4 would not break when automatically upgraded to 5.

Offline Tony53

  • Newbie
  • *
  • Posts: 6
Re: Update from Avast 4 to Avast 5 causes massive problems with Mail Shield
« Reply #7 on: November 12, 2010, 12:32:51 PM »
Although the fixes I've detailed above enable me to send and receive emails, I've just discovered that they are not being scanned!

HELP!!!

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5198
Re: Update from Avast 4 to Avast 5 causes massive problems with Mail Shield
« Reply #8 on: November 13, 2010, 10:36:34 AM »
Again I refer you to the same link regarding SSL account and Mail Shieldhttp://support.avast.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=458 - click on the pictures so you can see the settings better.  I also refer you to https://support.avast.com/index.php?_m=knowledgebase&_a=view&parentcategoryid=2&pcid=0&nav=0 - look under Send and Receive Email.

What email server(s) do you use?

Some SSL Email servers use their own internal antivirus and therefore Avast will not scan them.  However if you do not use such an email server, please read the first link I put in this post on how to configure your settings to allow for Avast scanning of mail.  If this does not answer your question, then look at the second link.  Thank you.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.