Author Topic: Avast 5 blocks internet access after upgrading from Avast 4.8  (Read 6319 times)

0 Members and 1 Guest are viewing this topic.

Offline skypilotpete

  • Newbie
  • *
  • Posts: 3
Avast 5 blocks internet access after upgrading from Avast 4.8
« on: September 06, 2010, 10:50:25 AM »
I upgraded from Avast 4.8 to 5.0.594 about a week ago. Since upgrading, I am not able to connect to the internet while Avast is operating. Avast stops Internet Explorer, Firefox and Newsleecher from connecting.

It is not blocking internet access completely, because the utility I use to measure my ISP usage is able to connect, and when I run the "Download test file" function to measure the download speed, it is able to download the test file at my normal maximum speed.

The only way I can access the internet fully is to disable all shields. Just disabling the web shield is not sufficient. With the web shield alone disabled, I can use my web browsers most of the time, but Newsleecher is still blocked.

I had none of these problems with Avast 4.8

I did a full boottime scan with Avast 5 and it found no problems. I also did full scans with Malwarebytes and Superantispyware, and no problems were found.

I have given full permission to Avast in Online Armor and Superantispyware.

I have uninstalled Avast 5, run the Avast removal tool in Safe Mode, and then reinstalled.

I run Online Armor Pro firewall, Superantispyware Pro resident, Windows XP Pro SP3.

I have used Avast for several years, but I am very close to shifting to another product. I hope someone can help with this.

Offline CharleyO

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7085
  • Be alert for error code - ID 10T
Re: Avast 5 blocks internet access after upgrading from Avast 4.8
« Reply #1 on: September 06, 2010, 11:26:14 AM »
***

Welcome to the forums, skypilotpete   :)

Try removing the avast entries from Online Armor Pro FW, restarting your computer, and then try connecting to the internet again. OAFW should ask again to allow avast and, of course, you should allow anything from avast.

If the above does not work, I am sure the users of OAFW here will give farther help.

EDIT :
Thanks David - somehow I read that wrong and have made changes above.


***
« Last Edit: September 07, 2010, 05:39:49 AM by CharleyO »
Self-built desktop (8 years old) - AMD64 3200+_Gigabyte GA-K8NS Ultra-939_4 gb RAM_GeForceFX 5800w/256 ram_XP/SP3_Avast 7_MBAM_ZA Free __and__ Toshiba Satellite Laptop_W7-64bit_ 4 gb Ram_Avast 8_MBAM

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84776
  • No support PMs thanks
Re: Avast 5 blocks internet access after upgrading from Avast 4.8
« Reply #2 on: September 06, 2010, 03:58:33 PM »
CharelyO, skypilotpete is using Online Armor not Outpost FW, but the procedure for skypilotpete is the same remove the entries avast.

e.g. If OA allows avastSvc.exe internet access ?
- delete the entry for it and reconnect to the internet, this should force the firewall to ask permission again.

You could also put OA into learning mode for a time.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline skypilotpete

  • Newbie
  • *
  • Posts: 3
Re: Avast 5 blocks internet access after upgrading from Avast 4.8
« Reply #3 on: September 07, 2010, 03:13:37 AM »
I have deleted all entries for avast in Online Armor - both  in program permission and internet access. I then put Onlin Armor in Learning Mode and restarted my computer. Online Armor starts in Learning mode, but there is difference at all - Avast still blocks browser access to the internet.

I don't understand why you think that it is a firewall problem. Online Armor is not stopping Avast from updating and it is not stopping access to the internet. Full access returns immediately that I turn off the Avast shields.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84776
  • No support PMs thanks
Re: Avast 5 blocks internet access after upgrading from Avast 4.8
« Reply #4 on: September 07, 2010, 03:39:41 AM »
avast (not AIS) doesn't block (it isn't a firewall), it hasn't got that functionality, it scans and alerts to infection, but doesn't block.

If there is an apparent blocking then that is usually a firewall blocking the web shield (avastSvc.exe) or a conflict between security applications (commonly another AV or remnants of one).

Since you previously had avast 4.8 it is unlikely to be that, which doesn't leave much else.

Conflict is a two way thing, remove one element and no conflict, but it doesn't pin down the culprit.

Do you use a proxy to connect to the internet, as that is about the only thing we haven't tried ?
Try the avast settings, Updates, Proxy Settings, change the option to Direct connection (no proxy) if you don't use a proxy, rather than the Auto detect (use Internet Explorer settings).

Whilst these settings are under the Update section, I believe they may well have an impact elsewhere.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline skypilotpete

  • Newbie
  • *
  • Posts: 3
Re: Avast 5 blocks internet access after upgrading from Avast 4.8
« Reply #5 on: September 11, 2010, 02:34:20 PM »
Removed Avast, installed Avira - now no problems at all.

Offline Maxthrust

  • Newbie
  • *
  • Posts: 4
Re: Avast 5 blocks internet access after upgrading from Avast 4.8
« Reply #6 on: September 11, 2010, 05:06:17 PM »
I'm having the exact same issue.  I have Windows 7 64 and only use the Windows Firewall.  To the best of my knowledge Avast has full internet access, yet, when I boot up I can't open Avast and I can't get to the internet.  I've found that svchost is running at 25% and if I kill this process Avast will open and web pages will start opening.  I have to repeat this process a dozen times or so and then I can use the internet normally.  I've used Avast for a very long time and been very happy, but right now I would like to go back to 4.8 until the bugs are out of 5.

Edit: If I completely disable ALL the shields the problem is alleviated, however, each time I boot I have to get Avast to open before I get complete control of the computer.  Once I get it open I can stop the svchost one last time and then I can get to the internet, but not before.
« Last Edit: September 11, 2010, 05:18:29 PM by Maxthrust »

Offline Ballooncaptain

  • Newbie
  • *
  • Posts: 1
Re: Avast 5 blocks internet access after upgrading from Avast 4.8
« Reply #7 on: September 28, 2010, 12:30:54 PM »
I have also had this problem since upgrading to V5... about a week or so ago,

I run
Windows XP professional
Avast! (free)
Online Armor (Free)

Skype works fine but Internet explorer and firefox are both blocked(ie will start but wont load and web pages)

online armor doesnt seem to be blocking anything from avast and its on the safe programs list.

This is all abit too boring for me so i'm going to switch to a new antivirus and check back here in a week or so and see if its been resolved (if i remember). Its a shame because ive been using Avast for 2-3 years no problem.


P.S.
I saw that someone mentioned using "the avast removal tool in safe mode" to get rid of all the program dregs, is this important when switching to a new antivirus, if so how do i do it thank you please...

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84776
  • No support PMs thanks
Re: Avast 5 blocks internet access after upgrading from Avast 4.8
« Reply #8 on: September 28, 2010, 02:42:51 PM »
I suggest that you read my Reply #2 above, in relation to deleting the entry for avast in OA and putting it into learning mode. That is where the problem lies and not with avast, we have seen it before on many occasions.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security