Author Topic: [Resolved] Web Shield problem (Can't connect to the internet)  (Read 4521 times)

0 Members and 1 Guest are viewing this topic.

IYQYQR

  • Guest
----*Resolved*---- ;D


OS: Win XP SP3
Latest versions of Firefox/Crome/IE/Avast
No firewall software other than windows firewall.

Here is the only changes...Microsoft Updates... after reboot I couldn't connect to the internet.

It was only through extensive trial an error was I able to figure out if I turned off the "web shield" I could gain access to the web again.

I've tried several "fixes" such as changing the proxy settings with no avail. I also uninstalled and reinstalled avast with no results. Any help would be appreciated.

Here was the fix:

I FIXED IT!!!! I ran the Windows XP Winsockfix utility and I am good to go! Whoever is having this issue on XP, try this file out - http://majorgeeks.com/WinSock_XP_Fix_d4372.html . Not sure what changed that made avast not work, but this could be something the dev team could look into and see what changes the Winsockfix utility makes and see what matches in those settings on all the users computers that have the same issue. Good night!!!

I have found a couple of utilities that say they work for Vista and Windows 7, can't confirm if they fix the issue but worth a shot!
Vista - http://www.mydigitallife.info/2007/06/18/repair-and-reset-windows-vista-tcpip-winsock-catalog-corruption/
Windows 7 - http://windows7themes.net/winsock-fix-for-windows-7.html

I believe the fix for Vista and 7 are the same, but to be on the safe side I provided two different links for each operating system. Good luck!
 
« Last Edit: October 14, 2010, 11:35:53 AM by IYQYQR »

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86663
  • No support PMs thanks
Re: Web Sheild problem (Can't connect to the internet)
« Reply #1 on: October 14, 2010, 02:23:25 AM »
Have (or did) you another Anti-Virus installed in this system, if so what was it and how did you get rid of it ?

Changing the proxy settings where ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

aviator992

  • Guest
Re: Web Sheild problem (Can't connect to the internet)
« Reply #2 on: October 14, 2010, 03:31:12 AM »
OS: Win XP SP3
Latest versions of Firefox/Crome/IE/Avast
No firewall software other than windows firewall.

Here is the only changes...Microsoft Updates... after reboot I couldn't connect to the internet.

It was only through extensive trial an error was I able to figure out if I turned off the "web shield" I could gain access to the web again.

I've tried several "fixes" such as changing the proxy settings with no avail. I also uninstalled and reinstalled avast with no results. Any help would be appreciated. 

Same problem here, restarted my pc and web shield is blocking my internet. Heres the link to my post: http://forum.avast.com/index.php?topic=65054.0

aviator992

  • Guest
Re: Web Sheild problem (Can't connect to the internet)
« Reply #3 on: October 14, 2010, 06:44:26 AM »
OS: Win XP SP3
Latest versions of Firefox/Crome/IE/Avast
No firewall software other than windows firewall.

Here is the only changes...Microsoft Updates... after reboot I couldn't connect to the internet.

It was only through extensive trial an error was I able to figure out if I turned off the "web shield" I could gain access to the web again.

I've tried several "fixes" such as changing the proxy settings with no avail. I also uninstalled and reinstalled avast with no results. Any help would be appreciated. 

Try my fix, its located here - http://forum.avast.com/index.php?topic=65054.0

IYQYQR

  • Guest
Re: Web Sheild problem (Can't connect to the internet)
« Reply #4 on: October 14, 2010, 08:50:08 AM »
Just wanted to spread all the kudos around that I could for Aviator's solution. I can see this being a problem for more and more folks who have Windows XP and get the latest updates.

Thank you again Aviator.

Dacurly

  • Guest
Re: [Resolved] Web Shield problem (Can't connect to the internet)
« Reply #5 on: January 19, 2011, 01:58:51 AM »
I was having the same problem, ran the winsock fix and problem solved. Thnx