Author Topic: Avast 5 and stuttering foobar2000 playback  (Read 3765 times)

0 Members and 1 Guest are viewing this topic.

Offline Faizi

  • Newbie
  • *
  • Posts: 3
Avast 5 and stuttering foobar2000 playback
« on: October 12, 2010, 08:26:49 PM »

Hi, as a newbie I would like to say hi to all forumers here.

My Avira premium license is expiring soon and I really despise their new version 10 resource hogging, so I'm looking for a new antivirus and I've read great review on Avast.

I've installed Avast with only antivirus and antispyware module checked (I didn't need web and network shield since I'm behind a gateway with dansguardian + clamav active scanning). After I did a custom thorough scan with avast, I'm impressed as it managed to detect several worm and trojan that avira ignored, though they are intentionally kept on my pc for several reason.

The only problem is foobar2000 seems to stutter while I'm surfing the web or when thunderbird is checking emails. Haven't had this problem with avira before. It's weird though as I've monitored the cpu usage, and avast is not using any cpu resource while the playback stuttered. WMP11 does not produce this kind of problem though.

As listening to music while at work is crucial to me, I've uninstall avast and am evaluating norton av 2011 right now. So far I'm impressed as foobar2000 is playing smoothly even when both of norton av process is using more than 50% of cpu resource.

Is this a compability issue with foobar2000?

Thanks

Offline Sammo

  • Full Member
  • ***
  • Posts: 195
Re: Avast 5 and stuttering foobar2000 playback
« Reply #1 on: October 13, 2010, 01:22:26 AM »
I get the same thing with Winamp. I have Process Lasso and set the CPU priority of Winamp to 'Above Normal' and it helps for the most part.
« Last Edit: October 13, 2010, 01:55:24 AM by Sammo »

Offline Faizi

  • Newbie
  • *
  • Posts: 3
Re: Avast 5 and stuttering foobar2000 playback
« Reply #2 on: October 13, 2010, 04:50:33 AM »

I get the same thing with Winamp. I have Process Lasso and set the CPU priority of Winamp to 'Above Normal' and it helps for the most part.

I'm also running Process Lasso and I've exluded foobar2000 from ProBalance restrain. Are you using winamp with any kind of 3rd party plugin?

Offline Sammo

  • Full Member
  • ***
  • Posts: 195
Re: Avast 5 and stuttering foobar2000 playback
« Reply #3 on: October 13, 2010, 05:44:10 AM »

I get the same thing with Winamp. I have Process Lasso and set the CPU priority of Winamp to 'Above Normal' and it helps for the most part.

I'm also running Process Lasso and I've exluded foobar2000 from ProBalance restrain. Are you using winamp with any kind of 3rd party plugin?
I use the DFX plugin. I also set the current priority class and default priority to above normal in Process Lasso.

Offline Faizi

  • Newbie
  • *
  • Posts: 3
Re: Avast 5 and stuttering foobar2000 playback
« Reply #4 on: October 13, 2010, 07:03:53 AM »

I'm using foobar with upsampling and dolby headphone plugin. Weird though as never encountered this kind of problem with previous avira and now norton av 2011.

Offline Sammo

  • Full Member
  • ***
  • Posts: 195
Re: Avast 5 and stuttering foobar2000 playback
« Reply #5 on: October 17, 2010, 03:34:36 AM »
I found out what the culprit appears to be. I turned off heuristics in the Web Shield and the stuttering problems go away with my audio players. I tried all the settings - low, normal and high and only when heuristics are turned off in Web Shield does the problem go away. Maybe the Avast guys should test this out and make improvements.