Author Topic: Avast seems to slow launching applications  (Read 6379 times)

0 Members and 1 Guest are viewing this topic.

Offline pepe2

  • Jr. Member
  • **
  • Posts: 50
    • y8
Avast seems to slow launching applications
« on: October 24, 2010, 03:27:15 PM »
I tried avast lately and really like is, one thing in noticed is that under windows 7 opening windows and applications seems to have slowed down considerably, were talking 3-5 seconds longer.

I installed only the on-demand scanner, no shields at all, tried disabling the graphics option and icon animation which helped a tiny bit but the deference when restoring to a pre avast image is noticeable.

Windows 7 64bit 4GB ram.

Offline Pondus

  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 35951
Re: Avast seems to slow launching applications
« Reply #1 on: October 24, 2010, 04:46:28 PM »
Have you uninstalled the AV you where using before you installed avast! ?
Chief Wiggum: Uh, no, you got the wrong number. This is 9-1…2.


Offline pepe2

  • Jr. Member
  • **
  • Posts: 50
    • y8
Re: Avast seems to slow launching applications
« Reply #2 on: October 24, 2010, 05:39:19 PM »
Yes i did made sure its clear of the system and registry.
BTW i was able to reproduce this on a clean VMware machine.
« Last Edit: October 24, 2010, 05:40:50 PM by pepe2 »

Offline pepe2

  • Jr. Member
  • **
  • Posts: 50
    • y8
Re: Avast seems to slow launching applications
« Reply #3 on: November 17, 2010, 10:46:46 AM »
I did some benchmark, and indeed it seems that with avast installed without any real time shields, here is a slow down of 1-2% in the graphic system.



Offline avoidz

  • Jr. Member
  • **
  • Posts: 54
Re: Avast seems to slow launching applications
« Reply #4 on: March 21, 2011, 10:33:33 AM »
I can also confirm this issue with certain programs on an XP SP3 system. The app affected for me is metpad by Alexander Davidson -- http://liquidninja.com/metapad/

Before avast! 6, this app opened instantly; now it takes many seconds. I have the sandbox feature disabled.

I can maybe try adding an Exclusion R W X for metapad, but what has changed in between version 5 and 6?
« Last Edit: March 21, 2011, 10:41:16 AM by marfaw »
DESKTOP: Intel P4 2.4GHz, 1.5GB RAM, 500GB HDD, GeForce FX 5200, Windows XP Pro, avast! 7 Home, Sygate PF Pro | NOTEBOOK: XPS17 Intel i7-2630QM, 8GB RAM, 2x750GB HDD, GeForce GT 555M, Windows 7 64bit, McAfee IS

doktornotor

  • Guest
Re: Avast seems to slow launching applications
« Reply #5 on: March 21, 2011, 10:51:19 AM »
here is a slow down of 1-2% in the graphic system.

Yeah, that's a huge deal indeed.  :o ;D

Offline danny96

  • Malware Fighter
  • Advanced Poster
  • **
  • Posts: 668
  • No-malware!
Re: Avast seems to slow launching applications
« Reply #6 on: March 21, 2011, 12:16:04 PM »
here is a slow down of 1-2% in the graphic system.

Yeah, that's a huge deal indeed.  :o ;D

oooooh 1% that's so much! My computer is fast with/out avast (i don't know that is in my system  :P)
Real-time protection and Firewall: COMODO Internet Security 12.0.0.6810 -- Additional Protection: Web Of Trust, Ublock, NoScript, Malwarebytes Premium, Avast! Online Security, Hitman Pro -- OS: Windows 10

Offline avoidz

  • Jr. Member
  • **
  • Posts: 54
Re: Avast seems to slow launching applications
« Reply #7 on: March 21, 2011, 12:19:39 PM »
^^ Dudes, that info doesn't really help the topic or answer the issue at hand.
DESKTOP: Intel P4 2.4GHz, 1.5GB RAM, 500GB HDD, GeForce FX 5200, Windows XP Pro, avast! 7 Home, Sygate PF Pro | NOTEBOOK: XPS17 Intel i7-2630QM, 8GB RAM, 2x750GB HDD, GeForce GT 555M, Windows 7 64bit, McAfee IS

Offline danny96

  • Malware Fighter
  • Advanced Poster
  • **
  • Posts: 668
  • No-malware!
Re: Avast seems to slow launching applications
« Reply #8 on: March 21, 2011, 12:22:42 PM »
^^ Dudes, that info doesn't really help the topic or answer the issue at hand.
What to say...1-2%...he can try ccleaner or other cleaning tools to increase speed of computer.
By turning off shields will not increase speed of the computer (i tried)
Real-time protection and Firewall: COMODO Internet Security 12.0.0.6810 -- Additional Protection: Web Of Trust, Ublock, NoScript, Malwarebytes Premium, Avast! Online Security, Hitman Pro -- OS: Windows 10

doktornotor

  • Guest
Re: Avast seems to slow launching applications
« Reply #9 on: March 21, 2011, 01:10:00 PM »
^^ Dudes, that info doesn't really help the topic or answer the issue at hand.

A slow down of 1-2% is not an issue... I've seen a 400% slowdown with unnamed yellow company products.  ::)

Offline danny96

  • Malware Fighter
  • Advanced Poster
  • **
  • Posts: 668
  • No-malware!
Re: Avast seems to slow launching applications
« Reply #10 on: March 21, 2011, 05:04:37 PM »
Right, this is not issue like doktor notor said. But surely can try Ccleaner it's free tool and will clean-up your PC and destroy useless registry keys, that can slow-down your system.
BTW OMG 2%... Don't understand these people...But ICQ or skype these people surely must have right?  ;D (these apps slowdown about 40% - that's huge loss!)
« Last Edit: March 21, 2011, 05:08:37 PM by danny96 »
Real-time protection and Firewall: COMODO Internet Security 12.0.0.6810 -- Additional Protection: Web Of Trust, Ublock, NoScript, Malwarebytes Premium, Avast! Online Security, Hitman Pro -- OS: Windows 10

Offline thisiscool

  • Jr. Member
  • **
  • Posts: 24
Re: Avast seems to slow launching applications
« Reply #11 on: March 21, 2011, 09:49:53 PM »
you do know that every file except a few types (i.e .txt), are being scanned by avast before you gain access to the file (in your case, a software).
i can give u a few tips which might help you with your situation:
  • use defrag in-order to reduce loading-time for files which are being accessed.
  • try to reinstall the software (full uninstall > install).

if nothing helps, i got an idea for you to use both avast full protection and your software..
add the software to the whitelist of avast (this will tell avast not to scan the files being accessed by this specific software.
[/list]
good luck :)

Offline Dch48

  • Massive Poster
  • ****
  • Posts: 3152
Re: Avast seems to slow launching applications
« Reply #12 on: March 21, 2011, 09:50:41 PM »
One thing I have noticed but I think it's always been the case, is that the Avast! icon will spin as soon as you mouse over any .exe file. It's like it's doing a pre-scan before you even try to execute the application.
Avatar FX6327X desktop, FX-6300 CPU, RX 470 GPU, 8GB RAM, Windows 10 Home 64 bit
HP dv6-6140us laptop, A8-3500M APU, 8GB RAM, Windows 7 Home Premium 64 bit
RCA W101 v2 10" tablet, Intel Atom Bay Trail Z3735F processor, 2GB RAM, Windows 10 Home 32 bit

Offline thisiscool

  • Jr. Member
  • **
  • Posts: 24
Re: Avast seems to slow launching applications
« Reply #13 on: March 21, 2011, 09:53:56 PM »
One thing I have noticed but I think it's always been the case, is that the Avast! icon will spin as soon as you mouse over any .exe file. It's like it's doing a pre-scan before you even try to execute the application.
indeed, as i've mentioned on my last reply.. avast real time scanner, as any other real time scanner, scans all the files which weren't mentioned on his white list.
this is why, when you try to run a file which is infected, you won't see any icon/file details - only "access denied".
even the page you watch right now, has been scanned before you gained access to it.
« Last Edit: March 21, 2011, 09:57:11 PM by thisiscool »

Offline thisiscool

  • Jr. Member
  • **
  • Posts: 24
Re: Avast seems to slow launching applications
« Reply #14 on: March 21, 2011, 09:55:03 PM »
sorry, double post bug