Author Topic: Installed avast in July, haven't been able to update anything since then...  (Read 8253 times)

0 Members and 1 Guest are viewing this topic.

evilcreations

  • Guest
So I had avast on my laptop for several years and never had a problem, it's a GREAT program.

I sold my laptop and got a desktop and installed avast on it back in July.

I have had the problem where I can't update the definitions or the program at all, it just keeps giving me an error.

I also can't update Windows(vista) or the Windows Defender.

I have run full system scans, boot scans, and come up empty handed.

I installed and ran spybot S&D and it came up with a bunch of malware that I quarantined, I've restarted several times, but still can't update any of my avast stuff.

PLEASE HELP.....this is getting really annoying.


The other issue I'm running into is when doing a search(google, yahoo, etc.) when I click on a link in the search results, it takes me to some b.s. spam page instead of what I clicked on.

Offline Omid Farhang

  • Frontend Developer
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1660
  • I wish I could write longer personal text!!
    • Homepage
Hi, evilcreations!

Welcome to forum.

What antivirus did you had before install avast? Have you tried to install, update and do a quick-scan with Malwarebytes Antimalware?
http://www.filehippo.com/download_malwarebytes_anti_malware/

These days SpyBot is not effective like before.
Twitter: OmidFarhangEn - OS: Manjaro KDE

evilcreations

  • Guest
Thank you for the welcome and the info.

I bought the computer used, and did a full format back to the partition.  Wiped it completely clean back to just the OS, then installed avast, then all the windows updates.  That's the last time I could update anything.


I will try out that link, should I remove Spybot S&D before I use that program?

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87427
  • No support PMs thanks
First lets get some information on a) what was detected and b) by which program, avast or S&D, etc.

What is the malware name, the infected file name, where was it found e.g. (C:\windows\system32\infected-file-name.xxx) ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.1.6049 (build 23.1.7883.774) UI 1.0.746/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Omid Farhang

  • Frontend Developer
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1660
  • I wish I could write longer personal text!!
    • Homepage
Thank you for the welcome and the info.

I bought the computer used, and did a full format back to the partition.  Wiped it completely clean back to just the OS, then installed avast, then all the windows updates.  That's the last time I could update anything.


I will try out that link, should I remove Spybot S&D before I use that program?

No need to keep SpyBot. it will give you a high-cpu load and slow-down in your computer
Twitter: OmidFarhangEn - OS: Manjaro KDE

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67212
Spybot? For what?
The best things in life are free.

evilcreations

  • Guest
Ok, lemme see if I can get you guys a little more info....Below are the 3 files that avast is finding.


C:\WINDOWS\System32\config\systemprofile\AppData\Local\ipiquqof.dll  Threat: Win32:MalOb-CB[Cryp]

C:\WINDOWS\System32\config\systemprofile\AppData\Local\odapilid.dll  Threat: JS:FakeWarn-E[Trj]

C:\WINDOWS\System32\config\systemprofile\AppData\Local\opipober.dll  Threat: JS:FakeWarn-E[Trj]

I ran the Malwarebytes program and it found several things that it took care of they are now no longer there on any futher scans with that program.

I have also attached a Hijackthis log from my computer if that hopefully helps anything.


Offline Omid Farhang

  • Frontend Developer
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1660
  • I wish I could write longer personal text!!
    • Homepage
Do you mind to post Malwarebytes log too? it can give us a better view what problem you had.
Twitter: OmidFarhangEn - OS: Manjaro KDE

Offline Omid Farhang

  • Frontend Developer
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1660
  • I wish I could write longer personal text!!
    • Homepage
Is this HijackThis log before Malwarebytes remove problems or after? there are some nasty stuff in this log.


Also, please try this:

1. Update avast manually: www.avast.com/download-update
2. Go to avast -> Settings (top-right) -> Updates -> in the bottom, Proxy, Choose Direct Connection and OK. See if it can update now.
« Last Edit: October 26, 2010, 12:58:10 AM by Omid Farhang »
Twitter: OmidFarhangEn - OS: Manjaro KDE

evilcreations

  • Guest
Attached is the Malwarebytes log.


I did the Manual update, and it worked fine....it still says there is a newer version available.

I also changed the update settings to Direct Connect, but still no luck....same error message when trying to update.

Offline Omid Farhang

  • Frontend Developer
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1660
  • I wish I could write longer personal text!!
    • Homepage
Seems malwarebytes solved most of the problems. cool!

What error do you receive exactly? What avast version are you using?

You may try another scanner to see if it detect and remove any problem:
http://www.superantispyware.com/portablescanner.html?tag=SAS_HOMEPAGE [No Installation needed]
http://www.surfright.nl/en/hitmanpro/

Update:
To don't bother you with one link at a time, here is a solution to make sure your computer is clean:
http://sites.google.com/site/boelectronic/computer/security/virus-removing

after make sure your computer is clean, if problem persist (which should not! ;) ), we will look for windows network settings.
« Last Edit: October 26, 2010, 02:19:02 AM by Omid Farhang »
Twitter: OmidFarhangEn - OS: Manjaro KDE

evilcreations

  • Guest
The hijack this log was AFTER malwarebytes "fixed" things....


I'm not very experienced with Hijackthis.....I used the analyze this button to figure out what I could probably delete or fix without any other problems.


Running the hitman scan right now.

Offline Omid Farhang

  • Frontend Developer
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1660
  • I wish I could write longer personal text!!
    • Homepage
Please check my update post above your. I'm sorry you still have problem, I hope we solve it easily.
Twitter: OmidFarhangEn - OS: Manjaro KDE

evilcreations

  • Guest
Alright, I'm gonna go through that process now from your link.....I'll update with the results when it's finished.

Thank you for your help....I hope it works.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67212
evilcreations, please, upload (attach) the avast log: C:\Program Files\Alwil Software\Avast5\Setup\setup.log
(or the shorter C:\Users\All Users\Alwil Software\Avast5\log\Setup.log).

If the file is too big for the forum, post the last 400-500 lines of it.
The best things in life are free.