Author Topic: blocking all sites except https  (Read 2326 times)

0 Members and 1 Guest are viewing this topic.

Memphis

  • Guest
blocking all sites except https
« on: November 01, 2010, 02:00:58 AM »
Recently Avast! (FREE) has started to block all non-secured sites (http). Unless it is an https site, it gets blocked. It is even blocking google.com. When I disable "Web Shield", normal access to sites returns. It has never done this before and I have been an Avast! user for many years.

Is there some setting that has been inadvertently set that is blocking all http sites?

Why is it doing this? Any ideas? Thanks!

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88421
  • No support PMs thanks
Re: blocking all sites except https
« Reply #1 on: November 01, 2010, 03:08:01 AM »
It isn't avast that is blocking rather something that is blocking avast.

What is your firewall ?
Does it allow avastSvc.exe internet access ?
- If it does delete the entry for it and reconnect to the internet, this should force the firewall to ask permission again.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.10.6086 (build 23.10.8563.800) UI 1.0.784/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Memphis

  • Guest
Re: blocking all sites except https
« Reply #2 on: November 01, 2010, 03:17:52 AM »
It isn't avast that is blocking rather something that is blocking avast.

What is your firewall ?
Does it allow avastSvc.exe internet access ?
- If it does delete the entry for it and reconnect to the internet, this should force the firewall to ask permission again.

The only firewall I have is Windows 7's built-in Firewall.

I checked my firewall settings and I really don't see where it lists the permissions for "internet access".  Where is that?  I have never changed any of my firewall configurations before.


Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88421
  • No support PMs thanks
Re: blocking all sites except https
« Reply #3 on: November 01, 2010, 04:49:05 AM »
Well unless you have enabled the outbound protection in the win7 firewall (it is disabled by default), that shouldn't be getting in the way.

I don't use win7 so I can't be a great deal of practical help, so I can't say were the firewall settings are if you have enabled outbound protection. But you say you haven't changed them before, then outbound protection should still be disabled.

Have you installed any other software or made any other changes around the time that this started to happen ?

Unfortunately that's me for the night, almost 4am here, hopefully someone in your time zone with win7 can pick this up.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.10.6086 (build 23.10.8563.800) UI 1.0.784/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security