Author Topic: Avast will not finish install  (Read 5457 times)

0 Members and 1 Guest are viewing this topic.

Offline fredx

  • Newbie
  • *
  • Posts: 3
Avast will not finish install
« on: November 08, 2010, 04:04:08 AM »
I've installed Avast internet security and I kept on getting "Last encounter error: Invalid file signature. Setup will Terminate"

I tried to uninstall a few times and reinstall. I still had the same problem. I did a search on the forum and followed the advice given.
 
uninstalled avast through add/remove, rebooted in safe mode and ran aswclean5, rebooted computer and then reinstalled software. I chose the liscense option during the install. Their was an error with completing the setup process. What is needed to fix this?

Here is the view log

07.11.2010 21:46:24 general: Started: 07.11.2010, 21:46:24
07.11.2010 21:46:24 general: Running setup_ais-2a5 (677)
07.11.2010 21:46:24 system: Operating system: WindowsXP ver 5.1, build 2600, sp 3.0 [Service Pack 3]
07.11.2010 21:46:24 system: Memory: 16% load. Phys:2097151/2097151K free, Page:4194303/4194303K free, Virt:2067340/2097024K free
07.11.2010 21:46:24 system: Computer WinName: FREDDIE-Y95LV3U
07.11.2010 21:46:24 system: Windows Net User: FREDDIE-Y95LV3U\Freddie
07.11.2010 21:46:24 general: Cmdline: /sfx /sfxstorage "C:\DOCUME~1\Freddie\LOCALS~1\Temp\_av_sfx.tm~a02748"  /srcpath "C:\DOCUME~1\Freddie\Desktop" /sfxname "setup_ais"
07.11.2010 21:46:24 general: DldSrc set to sfx
07.11.2010 21:46:24 general: Old version: ffffffff (-1)
07.11.2010 21:46:24 general: Install check: SetupVersion does NOT exist
07.11.2010 21:46:24 general: SGW32AIS::CheckIfInstalled set m_bAlreadyInstalled to 0
07.11.2010 21:46:24 registry: Get registry: Software\Microsoft\Internet Explorer\Version=8.0.6001.18702
07.11.2010 21:46:24 general: Operation set to INST_OP_INSTALL
07.11.2010 21:46:24 general: GUID: 40594b84-b601-49f8-8753-e14f3eae3c67
07.11.2010 21:46:24 general: SelectCurrent: selected server 'tmp sfx storage' from 'sfx'
07.11.2010 21:46:24 internet: SYNCER: Type: use IE settings
07.11.2010 21:46:24 internet: SYNCER: Auth: another authentication, use WinInet
07.11.2010 21:46:24 general: Changed Edition=3
07.11.2010 21:46:24 general: Entered SetupProcessAIS::Do( INST_OP_INSTALL )
07.11.2010 21:46:24 general: Entered SetupProcessWin32Avast::Do( INST_OP_INSTALL )
07.11.2010 21:46:24 general: Entered SetupProcessWin32::Do( INST_OP_INSTALL )
07.11.2010 21:46:24 general: Entered SetupProcess::Do( INST_OP_INSTALL )
07.11.2010 21:46:29 package: LoadProductVpu: C:\DOCUME~1\Freddie\LOCALS~1\Temp\_av_sfx.tm~a02748\prod-ais.vpx
07.11.2010 21:46:29 package: LoadPartInfo: jrog = jrog-a7 returned 00000000
07.11.2010 21:46:29 package: LoadPartInfo: jrog2 = jrog2-36 returned 00000000
07.11.2010 21:46:29 package: LoadPartInfo: program = prg_ais-2a5 returned 00000000
07.11.2010 21:46:29 package: LoadPartInfo: setup = setup_ais-2a5 returned 00000000
07.11.2010 21:46:29 package: LoadPartInfo: vps = vps_win32-10092101 returned 00000000
07.11.2010 21:46:29 package: LoadProductVpu: C:\DOCUME~1\Freddie\LOCALS~1\Temp\_av_sfx.tm~a02748\prod-ais.vpx ended with 00000000
07.11.2010 21:46:29 package: Part prg_ais-2a5 was set to be installed
07.11.2010 21:46:29 package: Part vps_win32-10092101 was set to be installed
07.11.2010 21:46:29 package: Part setup_ais-2a5 was set to be installed
07.11.2010 21:46:29 package: Part jrog-a7 was set to be installed
07.11.2010 21:46:29 package: Part jrog2-36 was set to be installed
07.11.2010 21:48:31 general: progress thread start
07.11.2010 21:48:35 internet: SYNCER: Agent=Syncer/5.00 (ais-677;p)
07.11.2010 21:48:35 package: LoadProductVpu: C:\DOCUME~1\Freddie\LOCALS~1\Temp\_av_sfx.tm~a02748\prod-ais.vpx

Offline fredx

  • Newbie
  • *
  • Posts: 3
Re: Avast will not finish install
« Reply #1 on: November 08, 2010, 04:07:53 AM »
07.11.2010 21:48:36 package: LoadPartInfo: jrog = jrog-a7 returned 00000000
07.11.2010 21:48:36 package: LoadPartInfo: jrog2 = jrog2-36 returned 00000000
07.11.2010 21:48:36 package: LoadPartInfo: program = prg_ais-2a5 returned 00000000
07.11.2010 21:48:36 package: LoadPartInfo: setup = setup_ais-2a5 returned 00000000
07.11.2010 21:48:36 package: LoadPartInfo: vps = vps_win32-10092101 returned 00000000
07.11.2010 21:48:36 package: LoadProductVpu: C:\DOCUME~1\Freddie\LOCALS~1\Temp\_av_sfx.tm~a02748\prod-ais.vpx ended with 00000000
07.11.2010 21:48:37 package: FilterOutExistingFiles: 127 & 0 = 127
07.11.2010 21:48:37 package: IsFullOkay: ais_core-21d.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: ais_core-21d.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package ais_core set to 1
07.11.2010 21:48:37 package: IsFullOkay: ais_dll_eng-21f.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: ais_dll_eng-21f.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package ais_dll_eng set to 1
07.11.2010 21:48:37 package: IsFullOkay: ais_fw-147.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: ais_fw-147.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package ais_fw set to 1
07.11.2010 21:48:37 package: IsFullOkay: ais_pro-266.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: ais_pro-266.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package ais_pro set to 1
07.11.2010 21:48:37 package: IsFullOkay: ais_res-15f.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: ais_res-15f.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package ais_res set to 1
07.11.2010 21:48:37 package: IsFullOkay: ais_spm-1cb.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: ais_spm-1cb.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package ais_spm set to 1
07.11.2010 21:48:37 package: IsFullOkay: winsys-3.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: winsys-3.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package winsys set to 1
07.11.2010 21:48:37 package: IsFullOkay: vps_32-2c8.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: vps_32-2c8.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package vps_32 set to 1
07.11.2010 21:48:37 package: IsFullOkay: vps_win32-2dc.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: vps_win32-2dc.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package vps_win32 set to 1
07.11.2010 21:48:37 package: IsFullOkay: jrog-a7.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: jrog-a7.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package jrog set to 1
07.11.2010 21:48:37 package: IsFullOkay: jrog2-36.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: IsFullOkay: jrog2-36.vpx - not okay (doesn't exist)
07.11.2010 21:48:37 package: SetFullAsMarked: Package jrog2 set to 1
07.11.2010 21:48:37 internet: Used server: C:\DOCUME~1\Freddie\LOCALS~1\Temp\_av_sfx.tm~a02748
07.11.2010 21:48:37 file: GetFileWithRetry: ais_core-21d.vpx downloaded  and verified
07.11.2010 21:48:37 package: DldPackage: C:\Program Files\Alwil Software\Avast5\Setup\ais_core-21d.vpx, returned 0x00000000
07.11.2010 21:48:37 internet: Used server: C:\DOCUME~1\Freddie\LOCALS~1\Temp\_av_sfx.tm~a02748
07.11.2010 21:48:37 file: GetFileWithRetry: ais_dll_eng-21f.vpx downloaded  and verified
07.11.2010 21:48:37 package: DldPackage: C:\Program Files\Alwil Software\Avast5\Setup\ais_dll_eng-21f.vpx, returned 0x00000000
07.11.2010 21:48:37 internet: Used server: C:\DOCUME~1\Freddie\LOCALS~1\Temp\_av_sfx.tm~a02748
07.11.2010 21:48:37 file: GetFileWithRetry:DSA_FileVerify(C:\Program Files\Alwil Software\Avast5\Setup\ais_fw-147.vpx), error: 0x2000000B
07.11.2010 21:48:37 general: InvalidateCurrent: invalidated server 'tmp sfx storage' from 'sfx'
07.11.2010 21:48:37 general: SelectCurrent: unable to find any suitable server in 'sfx'
07.11.2010 21:48:37 internet: while trying to get file 'ais_fw-147.vpx', error 0x2000000B has occured, try 1
07.11.2010 21:48:37 internet: tried 1 servers to get file 'ais_fw-147.vpx', but failed (0x2000000B)
07.11.2010 21:48:37 package: DldPackage: C:\Program Files\Alwil Software\Avast5\Setup\ais_fw-147.vpx, returned 0x2000000b
07.11.2010 21:48:42 system: Uninstalling aswTdi.sys
07.11.2010 21:48:42 system: Stopping service aswTdi
07.11.2010 21:48:42 system: OpenSCManager
07.11.2010 21:48:42 system: OpenService
07.11.2010 21:48:42 system: OpenService, errcode: 0x00000424
07.11.2010 21:48:42 system: Service aswTdi stopped, errcode: 0x00000424
07.11.2010 21:48:42 system: Couldn't uninstall the network component, result: 0x00000001.
07.11.2010 21:48:52 system: Service aswNdis uninstalled
07.11.2010 21:48:52 registry: Cannot open reg. key:Software\Microsoft\Windows\CurrentVersion\App Paths\AvastUI.exe
07.11.2010 21:48:52 registry: RegLoadKey(HKEY_USERS, Av_S-1-5-18, C:\WINDOWS\system32\config\systemprofile\NtUser.dat)
07.11.2010 21:48:52 registry: RegLoadKey(HKEY_USERS, Av_S-1-5-19, C:\Documents and Settings\LocalService\NtUser.dat)
07.11.2010 21:48:52 registry: Load registry hive ERROR_SHARING_VIOLATION
07.11.2010 21:48:52 registry: RegLoadKey(HKEY_USERS, Av_S-1-5-20, C:\Documents and Settings\NetworkService\NtUser.dat)
07.11.2010 21:48:52 registry: Load registry hive ERROR_SHARING_VIOLATION
07.11.2010 21:48:52 registry: RegLoadKey(HKEY_USERS, Av_S-1-5-21-1614895754-1390067357-725345543-1003, C:\Documents and Settings\Freddie\NtUser.dat)
07.11.2010 21:48:52 registry: Load registry hive ERROR_SHARING_VIOLATION
07.11.2010 21:48:52 registry: RegLoadKey(HKEY_USERS, Av_S-1-5-21-1614895754-1390067357-725345543-500, C:\Documents and Settings\Administrator\NtUser.dat)
07.11.2010 21:48:52 registry: RegUnloadKey
07.11.2010 21:48:52 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\ais_core-21d.vpx
07.11.2010 21:48:52 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\ais_dll_eng-21f.vpx
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\part-jrog-a7.vpx
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\part-jrog2-36.vpx
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\part-prg_ais-2a5.vpx
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\part-setup_ais-2a5.vpx
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\part-vps_win32-10092101.vpx
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\prod-ais.vpx
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\servers.def
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\servers.def.vpx
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\setif_ais-2a5.vpx
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\setup.ini
07.11.2010 21:48:53 file: Direct delete of file: C:\Program Files\Alwil Software\Avast5\Setup\setup_ais-2a5.vpx
07.11.2010 21:48:53 file: Direct delete of file: C:\Documents and Settings\All Users\Application Data\Alwil Software\Avast5\log\Chest.log
07.11.2010 21:48:53 file: Direct delete of file: C:\Documents and Settings\All Users\Application Data\Alwil Software\Avast5\log\usntr.log
07.11.2010 21:48:53 package: Transferred: files 0, bytes 0, time 32 ms
07.11.2010 21:48:53 package: Retries: total 1, files 1, servers 1
07.11.2010 21:48:53 general: Customer 31412392
07.11.2010 21:48:53 general: DldSrc set to inet
07.11.2010 21:48:53 general: Server definition(s) loaded for 'main': 371 (maintenance:0)
07.11.2010 21:48:53 general: SelectCurrent: selected server 'Download515 AVAST5 Server' from 'main'
07.11.2010 21:48:53 internet: SYNCER: Type: use IE settings
07.11.2010 21:48:53 internet: SYNCER: Auth: another authentication, use WinInet
07.11.2010 21:48:53 internet: Sending stats 'http://download515.avast.com/cgi-bin/iavs4stats.cgi': 00000000 204
07.11.2010 21:48:53 file: NeedReboot=false
07.11.2010 21:48:53 general: Return code: 0x2000000B [Invalid file signature. Setup will terminate.]
07.11.2010 21:48:53 general: Stopped: 07.11.2010, 21:48:53

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5202
Re: Avast will not finish install
« Reply #2 on: November 08, 2010, 09:21:27 AM »
Welcome to the forum fredx.  Often times when someone is having difficulty with an AV it is due to other things.  First I need to know the following:

1.   What is your OS, 32 or 64-bit? -> XP SP3
2.   What other security software do you currently have or did you have in the past on this machine including antivirus (AV), firewall (FW), previous trial versions, and other security programs?  If they were in the past, how did you remove them (the vendor's uninstaller's tool or another way)?

Sometimes remnants of security software can prevent the installation of AV's.

Also, if the Avast server was extremely busy at the time you were trying to do your install, this may have caused your problem, and you may want to try again tomorrow after uninstalling and doing a clean install.  But I first need to know about your current and past security software.  Thank you.


Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline fredx

  • Newbie
  • *
  • Posts: 3
Re: Avast will not finish install
« Reply #3 on: November 10, 2010, 10:29:27 PM »
My OS is 32 bit XP SP3. In the past I've had Notron & McAfee antivirus. I also had Uniblue software (Power Suite). I believe that I used the vendors removal tool for McAfee but not the others. I just add/removed them.

I think I now hae Avast working. I downloaded the trial version and then added the liscense agreement. But when I first boot up the computer I get a message saying that my system is not fully proteted and then it goes away. How can I check and make sure everything is running correctly?
« Last Edit: November 10, 2010, 10:35:04 PM by fredx »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: Avast will not finish install
« Reply #4 on: November 11, 2010, 12:49:47 AM »
Try, at least, this:
The Norton Removal Tool uninstalls all Norton 2003-2010 products from your computer.

1) (If possible) Remove Symantec products through Add/Remove programs from Control Panel. Boot.
2) Use Norton Removal Tool for Windows 2000/XP/Vista/7 or Norton Removal Tool for Windows 98/Me. Boot.
3) Install avast! (or repair the installation) and boot.

About the log, the important part is the bottom of it, not the top (the last lines, not the first ones).
The best things in life are free.

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5202
Re: Avast will not finish install
« Reply #5 on: November 11, 2010, 09:31:32 AM »
Removing remnants of the security software is important.  Here are other uninistallers if the previous ones do not work.  Remember to do one uninstall at a time, and reboot in between each one.

1. Norton/Symantec: http://service1.symantec.com/support/tsgeninfo.nsf/docid/2005033108162039

2. This article provides the steps to remove McAfee from the Security Center from your computer:
http://ts.mcafeehelp.com/faq3.asp?docid=71525

Also for direct download: http://download.mcafee.com/products/licensed/cust_support_patches/VSCleanupTool.exe and http://download.mcafee.com/products/licensed/cust_support_patches/MCPR.exe

3. Uniblue Power Suite uninstall: http://www.uniblue.com/support/faq/uninstall-uniblue-programs-computer/

4. List of uninstallers: http://uninstallers.blogspot.com/

After you complete all your uninstalls and reboots of these remnants, then you probably need to do an Avast Repair:
- Go to Control Panel > Add/Remove programs > Avast Antivirus.
- Scroll down and choose Repair function in the pop-up window.
- Reboot.

See if your error goes away on Avast.  If not, you may have to uninstall and do a clean install since having the remnants may have caused a corrupt install of Avast....but let's hold off on that for now and see what happens.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.