Author Topic: [RESOLVED] Webshield blocking Internet Access  (Read 5901 times)

0 Members and 1 Guest are viewing this topic.

Offline PureITy

  • Jr. Member
  • **
  • Posts: 22
  • I'm a llama!
[RESOLVED] Webshield blocking Internet Access
« on: November 22, 2010, 10:05:32 AM »
Referring to similar thread http://forum.avast.com/index.php?topic=66393.0 I'm having exactly the same problem on 2 new builds of Windows XP Home. All updates have been applied to Windows. No other security software has been installed. I could happily browse the internet with IE8 prior to downloading and installing Avast Free (5.0.677) Engine and Virus definitions 101121-1.

Done all of the suggested fixes in the original thread, nothing worked. Turning Webshield off allows internet browsing, turning it back on stops access.

Going to try uninstalling IE8 and see if IE7 works.

Any help would be appreciated.
« Last Edit: November 24, 2010, 12:28:37 PM by PureITy »

SafeSurf

  • Guest
Re: Webshield blocking Internet Access
« Reply #1 on: November 22, 2010, 10:12:54 AM »
Thank you for starting the new thread.  :)

1.   What is your OS, 32 or 64-bit?  XP-Home, SP?
3.   What product of Avast did you install?  Free?
4.   What other security software do you currently have or did you have in the past on this machine including antivirus (AV), firewall (FW), and other security programs?  If they were in the past, how did you remove them (the vendor's uninstaller's tool or another way)?

What firewall are you using and is Avast being blocked by anything?

You tried the Winsockfix Utility, Avast Repair, uninstall/clean install -- all without success?

YoKenny

  • Guest
Re: Webshield blocking Internet Access
« Reply #2 on: November 22, 2010, 02:24:49 PM »
How much RAM does the system have ???

WinSockFix 1.2
http://wareseeker.com/free-winsock-fix-utility

Offline PureITy

  • Jr. Member
  • **
  • Posts: 22
  • I'm a llama!
Re: Webshield blocking Internet Access
« Reply #3 on: November 22, 2010, 07:23:09 PM »
Removing IE8 made no difference.

Ran sfc /scannow - still not working

Unistalled Avast Home - Browsing ok.

Reinstalled Avast home - browsing stopped working

Turned off Web Shield - browsing ok.

Unistalled Avast home - browsing ok.

Reinstall IE8 and all updates - browsing ok.

Installed Avast Pro - browsing stopped

Turned off Web Shield - browsing ok.

Tuned on Web Shield - browsing stopped.

Ran sfc /scannow - still no browsing


PC has Windows XP Home SP3 + all updates, 768MB Memory
Tried Winsock repair tool, made no difference.
Using Windows firewall
This was a clean install, hence no legacy AV etc.


roguekiller23231

  • Guest
Re: Webshield blocking Internet Access
« Reply #4 on: November 22, 2010, 09:01:28 PM »
i'm having the exact same problem in vista 64 bit.

internet works in messengers and other programs, but all browsers are blocked.

that's IE8, Firefox, safari, Google Chrome, Opera.

happend a few hours ago, everything was working fine upuntill then. i've uninstalled AVG free edition now though, hopefully can find a fix.

i'm sure that there are many other people who have the same problem, but they don't know what is causing it, or how to ask for help, alot of people panicking out there. like i was and had to use the steam games browser.


SafeSurf

  • Guest
Re: Webshield blocking Internet Access
« Reply #5 on: November 22, 2010, 10:25:44 PM »
@ roguekiller23231,

You have a different OS as well as dealing with 2 AV's in your system.  Please start a New Topic of your own as this will just confuse the current thread and we will happily help you there.  You can cut and paste the information you put in this thread to start your new thread.

Go to this link, http://forum.avast.com/index.php, scroll down to the Avast Free/Pro/Suite forum and click it, click the New Topic button at the top of the list and post there.  Thank you.

SafeSurf

  • Guest
Re: Webshield blocking Internet Access
« Reply #6 on: November 22, 2010, 10:30:08 PM »
@ PureITy,

Do you still have MBAM on your machine?  If so, please run a FULL MBAM scan and post your log in this thread (cut and paste).  If you do not have MBAM, you can download it here free http://www.malwarebytes.org/ (the blue button).  Make sure to update it prior to scanning.  Should any infections come up, click "remove selected” button to quarantine anything found.   I just want to make sure we are not dealing with any malware.  Thank you.

Protech

  • Guest
Re: Webshield blocking Internet Access
« Reply #7 on: November 23, 2010, 03:27:52 AM »
Problem solved (for me anyhow)!  :D

Out of the blue, I had same issue happen today. Ran MBAM update & scan, no malware found. Then I ran a SuperAntiSpyware scan (after updating) and it found a few dozen tracking cookies & quarantined. After that, both IE8 and Firefox started web browsing again WITH Avast WebShield enabled.

SAS is a great free malware scanner, and the paid version is only $10. I use both SAS and MBAM for keeping bugs at bay: http://www.superantispyware.com/

-Steve

SafeSurf

  • Guest
Re: Webshield blocking Internet Access
« Reply #8 on: November 23, 2010, 09:08:43 AM »
Thank you Protech. :)  CCleaner http://www.piriform.com/ccleaner/builds - Slim Version (4th option down) does a better job with cookies and other cleaning, but I need to confirm that the OP does not have malware on their machine causing the issue.

@ PureITy,

After posting your MBAM log, you may also want to take a look at this thread, which helped some others: http://forum.avast.com/index.php?topic=57443.0.  Let me know if this helps.  Thank you.

Offline PureITy

  • Jr. Member
  • **
  • Posts: 22
  • I'm a llama!
Re: Webshield blocking Internet Access
« Reply #9 on: November 23, 2010, 12:58:08 PM »
Ran MBAM and SuperAntiSpyware, both made no difference. However, browsing is now working with WEB Shield enabled, since I created a temp folder in c:\windows. Didn't have to edit the registry, simply create a temp folder in C:\Windows and away you go. Web Shield creates a _avast5_ folder in temp.

Looks like the Avast installation should check for this folder and if it doesn't exist create one.

Thanks for all your help, very much appreciated.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 75394
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Webshield blocking Internet Access
« Reply #10 on: November 23, 2010, 01:32:23 PM »
Thank you for your feedback, PureITy..!
Win 8.1 [x64] - Avast PremSec 22.5.7216.B [UI.702] - Firefox ESR 91.9 [NS/uBO/PB] - Thunderbird 91.9.0
Avast-Tools: Secure Browser 101.0 - Cleanup 22.2 - SecureLine 5.18 - Driver Updater 22.2 - CCleaner 6.0
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

SafeSurf

  • Guest
[RESOLVED] Re: Webshield blocking Internet Access
« Reply #11 on: November 24, 2010, 09:50:29 AM »
Thank you PureITy for your good detective work!  I'm glad things are working for you again and I'm sorry it took longer than expected.

Now that your issue is resolved/fixed, please go back to the first open post in this topic, click the modify button in that Post and change the title/subject, add [Resolved] to the beginning of the title so this thread can be closed. 

Feel free to come back any time you need help, to learn something new, or just to ask questions.  We are here 24/7 for your convenience.  Thank you.  :)