Author Topic: free AVAST 5.0667 problem with newsgroups and SSL connections  (Read 2544 times)

0 Members and 1 Guest are viewing this topic.

Offline Robert Gault

  • Newbie
  • *
  • Posts: 9
free AVAST 5.0667 problem with newsgroups and SSL connections
« on: December 16, 2010, 04:11:10 PM »
This is more a warning than anything else. I use SeaMonkey as a browser and email/newsgroup client. As a test, I tried to see if the newsgroup news.mozilla.org would use SSL. That resulted in me being unable to connect to that news group for about a week until I stumbled over a workaround to what must be an Avast bug.

Avast requires that SSL connections be set within Avast (Real Time Shields/Mail Shield/ Expert settings/ SSL accounts. So that is what I did. Apparently news.mozilla.org does not provide SSL and reported a connection error. Fine, I'll just go back to non-SSL using port 119 by removing the entry in Avast. That did not work and I still got the non-connection error.
For about a week, I tried all possible combinations of the 119, 563 ports and SSL, non-SSL NNTP settings in the email client and Avast but kept getting the non-connection error. Finally and by accident, I tried disabling all Avast newsgroup NNTP scanning. That corrected the problem and I was able to reestablish a connection to the Mozilla newsgroups via port 119 without security.
Not only could I now connect to the Mozilla newsgroup, but I could reengage Avast newsgroup scanning.

I can only guess what had gone wrong but it seems to me that once Avast was told that the newsgroup used SSL, it would not stop using SSL for that newsgroup regardless of the individual SSL Avast setting until all newsgroup scanning was turned off. If true, this is clearly a bug.

==========================
New information

I have finally found exactly what is going on and while not a bug, it is an Avast "feature" that is causing the problem.

The Mozilla newsgroups at news.mozilla.org are being hosted by Giganews. Mozilla does not use SSL and has no intention of using it. However, Giganews does offer SSL and that is the crux of the problem. Apparently there has been some recent changes at Giganews regards SSL which made the service visible to Free Avast 5.0677.

The policy of Avast is to detect SSL and automatically set Mail Shield to SSL. Well Avast now finds Giganews capable of SSL and forces that setting on in Mail Shield. However, Mozilla does not use SSL and the connection fails in the SeaMonkey email client. It was necessary to turn off Avast email screening to access this newsgroup. If this sounds familiar, it should. There are a number of threads on this site where users can't get email or newsgroup access unless Avast screening is turned off.

The solution for me was to explicitly tell Avast not to use SSL for NNTP service with the Giganews account. So I made an entry in the Avast SSL accounts of
 Host         Protocol  Port   Encryption
giganews.com    NNTP    119    none
This keeps SSL turned off for my mozilla newsgroup even though the host Gigagnews can use SSL.
« Last Edit: December 18, 2010, 04:28:00 AM by Robert Gault »