Author Topic: Avast Internet Security 5 Vista startup failure "aswMonFlt"  (Read 10772 times)

0 Members and 1 Guest are viewing this topic.

Offline Ruth Pitts

  • Newbie
  • *
  • Posts: 2
Avast Internet Security 5 Vista startup failure "aswMonFlt"
« on: December 11, 2010, 06:56:45 PM »
Following update to Avast Internet Security 5 the "avast! Antivirus" fails to
start due to "aswMonFlt" service dependency.

Excerpt "eventvwr":

The avast! Antivirus service depends the following service: aswMonFlt. This service might not be installed.

"aswMonFlt" is not visible from "Services" control panel but is list
in the services registry.

All Avast services are running as "Local System".

Any opinions as to root cause and remedy would be most welcome.

Offline YLAP

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2119
Re: Avast Internet Security 5 Vista startup failure "aswMonFlt"
« Reply #1 on: December 11, 2010, 07:08:26 PM »
Have you tried to repair the installation?

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7083
  • When you think you know, Think Again
Re: Avast Internet Security 5 Vista startup failure "aswMonFlt"
« Reply #2 on: December 11, 2010, 08:12:45 PM »
Following update to Avast Internet Security 5 the "avast! Antivirus" fails to
start due to "aswMonFlt" service dependency.

Excerpt "eventvwr":

The avast! Antivirus service depends the following service: aswMonFlt. This service might not be installed.

"aswMonFlt" is not visible from "Services" control panel but is list
in the services registry.

All Avast services are running as "Local System".

Any opinions as to root cause and remedy would be most welcome.

Hello Ruth Pitts: Sometimes a 'clean uninstall and reinstall of your product is required if a 'Repair' of the installation through the 'Add and Remove' option in the Control Panel does not work as suggested by =YLAP=
I'm sure one of the evangelists will walk you through that procedure if necessary.
Thank you. :)
« Last Edit: December 11, 2010, 08:17:05 PM by schmidthouse »
???HP ENVY 15K LT W10 Pro 21H1 64Bit/750GB HD/16GB Ram/Avast Premium 21.9.2493b/Secureline VPN v.5.12.5699b/ADU v.21.3b/ASB v.94.0b/SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 20H2 64Bit/1TB HD/8GB Ram/WD/ADU v.21.3b/SANDBOXIE/MailWasherPRO/HotSpot Shield
     
RIP*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5198
Re: Avast Internet Security 5 Vista startup failure "aswMonFlt"
« Reply #3 on: December 12, 2010, 11:17:08 AM »
As mentioned earlier, please try the Avast Repair first:
- Go to Control Panel > Add/Remove programs > Avast Antivirus.
- Scroll down and choose Repair function in the pop-up window.
- Reboot.

If this fails to fix your problem, then an uninstall and clean install is required:

1. Save a copy of newest version of Avast (5.0.677) for the version you need and save it to your HDD:
AIS –  http://files.avast.com/iavs5x/setup_ais.exe
2. Download the Avast Uninstall Utility, aswClear5.exe http://www.avast.com/uninstall-utility and save it to your HDD (it has uninstall tools for both 4.0 and 5.0).
3. Disconnect from the Internet at this time.
4. Go to Control Panel and uninstall Avast through Add/Remove Programs if possible and reboot.
5. If Step 4 fails, boot into Safe Mode (hit F8 repeatedly) and run the Avast Uninstall Tool.  Uninstall all previous versions of Avast you had on this machine at this time.
6. Reboot.
7. Install the newest version of Avast and reboot.
8. Get Internet access and add the license key for AIS.
9. Update the Avast definitions.

Please let us know if this fixes your problem.  Thank you.

Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline Ruth Pitts

  • Newbie
  • *
  • Posts: 2
Re: Avast Internet Security 5 Vista startup failure "aswMonFlt"
« Reply #4 on: December 31, 2010, 06:22:37 PM »
Thank you the uninstall and safe mode clean up remedied the problems.

Cheers,
Ruth

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7083
  • When you think you know, Think Again
Re: Avast Internet Security 5 Vista startup failure "aswMonFlt"
« Reply #5 on: January 01, 2011, 12:45:18 AM »
Thank you the uninstall and safe mode clean up remedied the problems.

Cheers,
Ruth

Glad to hear it worked well for you and all is right in the world ;) :)
???HP ENVY 15K LT W10 Pro 21H1 64Bit/750GB HD/16GB Ram/Avast Premium 21.9.2493b/Secureline VPN v.5.12.5699b/ADU v.21.3b/ASB v.94.0b/SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 20H2 64Bit/1TB HD/8GB Ram/WD/ADU v.21.3b/SANDBOXIE/MailWasherPRO/HotSpot Shield
     
RIP*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE