Author Topic: Lost internet connection  (Read 8641 times)

0 Members and 1 Guest are viewing this topic.

Offline coolmoe

  • Newbie
  • *
  • Posts: 7
Lost internet connection
« on: December 28, 2010, 05:54:00 PM »
This weekend I picked up a virus or spyware.  It would not allow me to open most of my applications and constantly created pop-up screens, prompting me to buy an antivirus product everytime I tried to click on icon on my desktop.  After doing some research, I found out about Avast and installed the free antivirus software on my PC, then ran it in safe mode.  Avast identified the infection as Win32:gen-rootkit[rtk] and I, promptly, placed it in the virus chest.  But after I logged on again I noticed that I could not connect to the internet through IE or Firefox, although I was connected to my network.  I went back to safe mode and, strangely, I was able to use my browers in safe mode.  Can anyone help me with this dilemma?

Offline Silk0

  • Poster
  • *
  • Posts: 482
  • Octo Live
Re: Lost internet connection
« Reply #1 on: December 28, 2010, 05:58:08 PM »
I suggest you to run a full scam with Malwarebytes to see if something escaped from Avast! ;)

You can download Malwarebytes, here: http://www.malwarebytes.org/mbam.php
Install it, update it and run the scan.

Give a feedback and post the log when it's done.
~ Silk0
Avast! Free 6.0.1367

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7084
  • When you think you know, Think Again
Re: Lost internet connection
« Reply #2 on: December 28, 2010, 06:08:36 PM »
This weekend I picked up a virus or spyware.  It would not allow me to open most of my applications and constantly created pop-up screens, prompting me to buy an antivirus product everytime I tried to click on icon on my desktop.  After doing some research, I found out about Avast and installed the free antivirus software on my PC, then ran it in safe mode.  Avast identified the infection as Win32:gen-rootkit[rtk] and I, promptly, placed it in the virus chest.  But after I logged on again I noticed that I could not connect to the internet through IE or Firefox, although I was connected to my network.  I went back to safe mode and, strangely, I was able to use my browers in safe mode.  Can anyone help me with this dilemma?

Hi coolmoe: Could you please provide further information, it will help in providing pertinent advice.
What OS are you using? Do you have any other security software installed on your machine? Also what version of Avast did you install?
???HP ENVY 15K LT W10 Pro 21H1 64Bit/750GB HD/16GB Ram/Avast Premium 21.9.2493b/Secureline VPN v.5.12.5699b/ADU v.21.3b/ASB v.94.0b/SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 20H2 64Bit/1TB HD/8GB Ram/WD/ADU v.21.4b/SANDBOXIE/MailWasherPRO/HotSpot Shield
     
RIP*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: Lost internet connection
« Reply #3 on: December 28, 2010, 06:34:47 PM »
Hi coolmoe: Could you please provide further information, it will help in providing pertinent advice.
What OS are you using? Do you have any other security software installed on your machine? Also what version of Avast did you install?

and what are you going to tell him once you know that ??? ::)
« Last Edit: December 28, 2010, 06:50:20 PM by Logos »
w7 - ais7

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7084
  • When you think you know, Think Again
Re: Lost internet connection
« Reply #4 on: December 28, 2010, 06:38:00 PM »
Hi coolmoe: Could you please provide further information, it will help in providing pertinent advice.
What OS are you using? Do you have any other security software installed on your machine? Also what version of Avast did you install?

and what are you going to tell him once you know that ??? ;D

Well I'm not sure. ;D
I like to know, before saying anything ;)
???HP ENVY 15K LT W10 Pro 21H1 64Bit/750GB HD/16GB Ram/Avast Premium 21.9.2493b/Secureline VPN v.5.12.5699b/ADU v.21.3b/ASB v.94.0b/SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 20H2 64Bit/1TB HD/8GB Ram/WD/ADU v.21.4b/SANDBOXIE/MailWasherPRO/HotSpot Shield
     
RIP*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: Lost internet connection
« Reply #5 on: December 28, 2010, 06:50:50 PM »
I'll tell you, probably that 2 firewall conflicts, that two AVs conflict etc...etc... I mean there seem to be a couple of noobs on the forums posting the same useless canned answers to increase their post count here. Give us a break okay, enough is enough. Mods stop that, thanks. This forum is slowly becoming an Internet garbage can. Save it before it's too late and all the guys who really help here get so pissed off that they stop coming around. I mean reading all that crap posted, reposted, re-re-posted is absolutely unbearable. Again it's not just the above poster, it's about ten like him who are currently making this place become the a**hole of the internet. Other people on other security forums must have a good laugh I tell you ::)

 @schmidthouse: the OP in this thread has got a computer virus infection, if an mbam scan doesn't help like already suggested,he needs a malware expert, and there's only one that I know here, so just don't interfere if you have nothing to say.
w7 - ais7

Offline coolmoe

  • Newbie
  • *
  • Posts: 7
Re: Lost internet connection
« Reply #6 on: December 28, 2010, 07:12:45 PM »
Thanks for your response.  My operating system is Windows XP.   I also have Norton Internet Security (although it expired) and McAfee (also expired) I don't use either one of them for antivirus protection.  I just recently installed Zone Alarm and Spybot Search and Destroy; both of them are freeware products.  After installing and using them for a couple of days my machine worked fine.  It all went haywire after I picked up that virus.  Avast helped but my only problem is the internet connection.  I'm not sure what version of Avast I installed.  On the website it is listed as the free antivirus.  All free stuff I know.  I was experimenting this weekend LOL!  Thanks again.

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: Lost internet connection
« Reply #7 on: December 28, 2010, 07:20:45 PM »
get rid of all the extra crap, i.e. other expired security software. Drivers are still loading and that's a problem. Use cleaners from Norton and McAfee if necessary. Then reboot. Once there make sure that you got the latest Avast 5 official build and update it. Now you didn't tell us what the mbam scan did? (see the first answer that you got in this thread)

ps: uninstall Zone Alarm too, it does  conflict with most security software. Also remove spybot, it's oudated and useless.
« Last Edit: December 28, 2010, 07:30:03 PM by Logos »
w7 - ais7

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: Lost internet connection
« Reply #8 on: December 28, 2010, 07:37:28 PM »
...just pm'ed essexboy (he's a malware specialist here). He'll help you if you can't get rid of your infection. Just do what he says, follow his instructions okay ;)
w7 - ais7

Offline coolmoe

  • Newbie
  • *
  • Posts: 7
Re: Lost internet connection
« Reply #9 on: December 28, 2010, 07:40:29 PM »
I have to wait until I get home this evening to do mbam scan.  My laptop is at home.  I will post the results then.  I will also get rid of the crap and follow the instructions.  Thanks again.

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11143
  • No support PM's thanks
Re: Lost internet connection
« Reply #10 on: December 28, 2010, 07:50:25 PM »
You can find most of the uninstaller's here http://uninstallers.blogspot.com/, delet the program's that Logos has mentioned from add remove program's first then run the uninstaller tool's from the link i supplied in safe mode.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85965
  • No support PMs thanks
Re: Lost internet connection
« Reply #11 on: December 28, 2010, 07:51:06 PM »
- A link worth looking at, which is a program removal tool that can remove the remnants of a number of different Norton Programs:
Removing your Norton program using SymNRT
Or ftp://ftp.symantec.com/public/english_us_canada/removal_tools/Norton_Removal_Tool.exe

- You didn't say which McAfee version, so here are the various tools:
- McAfee has an uninstall tool that you could run to ensure any possible remnants are removed.
http://download.mcafee.com/products/licensed/cust_support_patches/VSCleanupTool.exe

Or http://majorgeeks.com/McAfee_Consumer_Product_Removal_Tool_d5420.html
 
2007 version - http://download.mcafee.com/products/licensed/cust_support_patches/MCPR.exe
 
Also see - How do I uninstall SecurityCenter? http://ts.mcafeehelp.com/faq3.asp?docid=71525
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40610
  • Dragons by Sasha
    • Malware fixes
Re: Lost internet connection
« Reply #12 on: December 28, 2010, 09:11:37 PM »
Yep remove the old AV's as all they do is use resources

Download OTL  to your Desktop
  • Double click on the icon to run it. Make sure all other windows are closed and to let it run uninterrupted.
  • Select All Users
  • Under the Custom Scan box paste this in
netsvcs
%SYSTEMDRIVE%\*.exe
/md5start
explorer.exe
winlogon.exe
Userinit.exe
svchost.exe
/md5stop
%systemroot%\*. /mp /s
CREATERESTOREPOINT




  • Click the Quick Scan button. Do not change any settings unless otherwise told to do so. The scan wont take long.
    • When the scan completes, it will open two notepad windows. OTL.Txt and Extras.Txt. These are saved in the same location as OTL.
    • Attach both logs please

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7084
  • When you think you know, Think Again
Re: Lost internet connection
« Reply #13 on: December 29, 2010, 01:08:48 AM »
I'll tell you, probably that 2 firewall conflicts, that two AVs conflict etc...etc... I mean there seem to be a couple of noobs on the forums posting the same useless canned answers to increase their post count here. Give us a break okay, enough is enough. Mods stop that, thanks. This forum is slowly becoming an Internet garbage can. Save it before it's too late and all the guys who really help here get so pissed off that they stop coming around. I mean reading all that crap posted, reposted, re-re-posted is absolutely unbearable. Again it's not just the above poster, it's about ten like him who are currently making this place become the a**hole of the internet. Other people on other security forums must have a good laugh I tell you ::)

 @schmidthouse: the OP in this thread has got a computer virus infection, if an mbam scan doesn't help like already suggested,he needs a malware expert, and there's only one that I know here, so just don't interfere if you have nothing to say.

I may not be an expert like you, but I've helped in the past, and I will continue to help in the future.
My appologies if I have spoiled your day :)
???HP ENVY 15K LT W10 Pro 21H1 64Bit/750GB HD/16GB Ram/Avast Premium 21.9.2493b/Secureline VPN v.5.12.5699b/ADU v.21.3b/ASB v.94.0b/SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 20H2 64Bit/1TB HD/8GB Ram/WD/ADU v.21.4b/SANDBOXIE/MailWasherPRO/HotSpot Shield
     
RIP*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE

Offline coolmoe

  • Newbie
  • *
  • Posts: 7
Re: Lost internet connection
« Reply #14 on: December 29, 2010, 05:06:21 AM »
Here are the results of my mbam scan (attached). Now I am about to remove Norton, McAfee, Zone Alarm... and run OTL.