Author Topic: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything  (Read 30544 times)

0 Members and 2 Guests are viewing this topic.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #15 on: January 01, 2011, 09:50:07 AM »
Hmm.. Indeed this was reported by RejZoR in one of the beta builds but we could never simulate it here. The upgrade path from v4.8 to 5.1 was tested on a number of different systems and we couldn't find a single problem.

Now, it would be really useful to find out what's different about your systems.
To help us analyze the problem, please ZIP the following directories

C:\Program Files\ALWIL Software\Avast5
C:\ProgramData\ALWIL Software\Avast5

and upload to ftp://ftp.avast.com/incoming

Also, please add the files C:\Windows\System32\Drivers\asw*.sys and an export of the registry key HKLM\Software\ALWIL Software


We will analyze the files here and hopefully find out what makes your install different from a clean install.


Many thanks
Vlk
« Last Edit: January 01, 2011, 12:04:23 PM by Vlk »
If at first you don't succeed, then skydiving's not for you.

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3349
  • Avast shall conquer the whole world
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #16 on: January 01, 2011, 09:54:19 AM »
Vlk I can't give you what you need because I went back to v5.0.677 :'(
ASUS G75VX-T4153H | Avast Premium v21.9.2493 | Avast SecureLine VPN | Avast Secure Browser | Avast Driver Updater | Avast BreachGuard | W8.1 64bit | Firefox 64bit | Thunderbird 64bit | MBAM Premium | Adguard Premium | CryptoPrevent Premium | CCleaner Portable | MCShield | Macrium Reflect | 7-Zip

ross

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #17 on: January 01, 2011, 11:25:30 AM »
The upgrade path from v4.8 to 5.1 was tested on a number of different systems and we couldn't find a single problem.

In my case I was upgrading from the previous stable build (5.0.677) to the last version of the 5.1 beta that was released. Unfortunately I did a clean install so can't provide a zipped copy of the install dir.

Silent Assassin

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #18 on: January 01, 2011, 11:42:09 AM »
Hi
I'm also having this problem on my 64bit Vista PC. Avast is practically dead - only the web shield seems to be active :-[.

Vlk, I cannot find the alwil software folder inside Program Files ???, although there is one under ProgramData.

Also, do you need all of the drivers in C:\Windows\System32\drivers?

Thanks

Offline Jekku

  • Jr. Member
  • **
  • Posts: 42
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #19 on: January 01, 2011, 12:03:10 PM »
I'm also having this problem with Windows 7 x64 systems. Every one of them were completely "silent" after GUI update from build 5.0.677. x86 XPs updated ok. Fortunately Avast is so easy to re-install, so I ended up doing that.

Quite serious bug though, if people don't check their AV after update.
1) Intel C2Q Q8400 2.66GHz@3.2GHz, Asus P5Q Pro, 8GB RAM, ATI Radeon HD 4850, OCZ Agility 3 60GB SSD, Win 7 Home Premium x64, avast Free 7.0.1426
2) AMD Phenom II X2 555 BE 3.2GHz (4 cores enabled), Asus M4A785-M, 4GB RAM, ATI Radeon HD 5670, 320GB HDD, Win 7 Home Premium x64, avast Free 7.0.1426

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #20 on: January 01, 2011, 12:06:49 PM »
I'm also having this problem on my 64bit Vista PC. Avast is practically dead - only the web shield seems to be active :-[.

Vlk, I cannot find the alwil software folder inside Program Files ???, although there is one under ProgramData.

It depends where you installed the program to.

C:\Program Files\ALWIL Software\Avast5

is the default location, unless you changed it in the setup wizard.


Also, do you need all of the drivers in C:\Windows\System32\drivers?

No, sorry, I edited my post, we only need asw*.sys files (all of our drivers are named like this).

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Silent Assassin

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #21 on: January 01, 2011, 12:19:21 PM »
I'm also having this problem on my 64bit Vista PC. Avast is practically dead - only the web shield seems to be active :-[.

Vlk, I cannot find the alwil software folder inside Program Files ???, although there is one under ProgramData.

It depends where you installed the program to.

C:\Program Files\ALWIL Software\Avast5

is the default location, unless you changed it in the setup wizard.
Silly me - I could have thought of that :P
I've already sent you 3 files (I hope you've got them):
[ProgramData]Avast5 (Silent Assassin).zip
avast (Silent Assassin).reg
drivers (Silent Assassin).zip

I'm also sending you avast! Free Antivirus (Silent Assassin).zip which is the folder to which I installed avast.

Thanks

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #22 on: January 01, 2011, 12:43:18 PM »
Thanks. One little thing: the registry export is from HKCU, not from HKLM. Could you please also do one from HKLM?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Silent Assassin

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #23 on: January 01, 2011, 12:53:46 PM »
I'm also sending you avast! Free Antivirus (Silent Assassin).zip which is the folder to which I installed avast.
Done

Thanks. One little thing: the registry export is from HKCU, not from HKLM. Could you please also do one from HKLM?

Thanks
Vlk
You mean HKEY_LOCAL_MACHINE\SOFTWARE\ALWIL Software? I don't have such an entry there ??? (see screenshot).

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #24 on: January 01, 2011, 01:00:41 PM »
Oh you have 64-bit Windows, right?
Then it's HKLM\Software\WOW6432Node\ALWIL Software.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Silent Assassin

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #25 on: January 01, 2011, 01:03:37 PM »
Oh you have 64-bit Windows, right?
Then it's HKLM\Software\WOW6432Node\ALWIL Software.

Thanks
Vlk
OK, I've sent it. Look for avast (Silent Assassin) [new].reg

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #26 on: January 01, 2011, 01:11:41 PM »
Thanks much. It looks like the driver files haven't updated (are still version 677).
Please try doing the following: copy the *.sys from

D:\PROGRAMY\avast! Free Antivirus\Setup\INF\x64

to

C:\Windows\System32\Drivers

(actually, you don't have to copy aswFW.sys, aswNdis.sys and aswNdis2.sys as these belong to the AIS firewall - but even if you do copy them, it will do no harm...).


After copying the files, reboot the computer. Does that solve the problem?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Silent Assassin

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #27 on: January 01, 2011, 01:21:48 PM »
Thanks much. It looks like the driver files haven't updated (are still version 677).
Please try doing the following: copy the *.sys from

D:\PROGRAMY\avast! Free Antivirus\Setup\INF\x64

to

C:\Windows\System32\Drivers

(actually, you don't have to copy aswFW.sys, aswNdis.sys and aswNdis2.sys as these belong to the AIS firewall - but even if you do copy them, it will do no harm...).


After copying the files, reboot the computer. Does that solve the problem?

Thanks
Vlk
When copying I get a message saying that I don't have the permission to do that (LOL - I'm the administrator ???).

I've disabled avast's self-defense module and it worked. I will reboot the computer now.
« Last Edit: January 01, 2011, 01:25:11 PM by Silent Assassin »

Silent Assassin

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #28 on: January 01, 2011, 01:30:37 PM »
Hooray! Avast is working now :D!

However, there's still one thing - the behaviour shield isn't showing any activity ???. What's wrong?
« Last Edit: January 01, 2011, 01:32:11 PM by Silent Assassin »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #29 on: January 01, 2011, 01:32:50 PM »
There's one registry value missing.  Namely, in

HKLM\System\CurrentControlSet\Services\aswSP\Parameters,

create a REG_DWORD value called BehavShield and set it to 1.

Then reboot and see what happens.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.