Author Topic: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything  (Read 30542 times)

0 Members and 2 Guests are viewing this topic.

Silent Assassin

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #30 on: January 01, 2011, 01:39:06 PM »
There's one registry value missing.  Namely, in

HKLM\System\CurrentControlSet\Services\aswSP\Parameters,

create a REG_DWORD value called BehavShield and set it to 1.

Then reboot and see what happens.

Thanks
Vlk
Yeap - it's working :D.
Thanks Vlk!

EagleGhost

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #31 on: January 01, 2011, 05:55:38 PM »
When this (the behaviour shield issue) will be fixed? I don't want to edit the registry, because I hate doing that. Because of that issue I haven't updated to 5.1.864 and I'm still sticking with 5.0.677.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #32 on: January 01, 2011, 06:07:10 PM »
When this (the behaviour shield issue) will be fixed? I don't want to edit the registry, because I hate doing that. Because of that issue I haven't updated to 5.1.864 and I'm still sticking with 5.0.677.

Probably tomorrow evening.

BTW if install from scratch (i.e. uninstall 5.0.677 and install 5.1.864) you shoudln't be impacted by any of the issues.
If at first you don't succeed, then skydiving's not for you.

Offline danny96

  • Malware Fighter
  • Advanced Poster
  • **
  • Posts: 668
  • No-malware!
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #33 on: January 01, 2011, 06:33:14 PM »
same thing here  :-X
Real-time protection and Firewall: COMODO Internet Security 12.0.0.6810 -- Additional Protection: Web Of Trust, Ublock, NoScript, Malwarebytes Premium, Avast! Online Security, Hitman Pro -- OS: Windows 10

EagleGhost

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #34 on: January 01, 2011, 07:14:38 PM »
When this (the behaviour shield issue) will be fixed? I don't want to edit the registry, because I hate doing that. Because of that issue I haven't updated to 5.1.864 and I'm still sticking with 5.0.677.

Probably tomorrow evening.

BTW if install from scratch (i.e. uninstall 5.0.677 and install 5.1.864) you shoudln't be impacted by any of the issues.

Ok. Do I need to only run the Avast removal tool to have a clean installation or do I have to delete manually Avast files or registry entries?
« Last Edit: January 01, 2011, 07:30:42 PM by EagleGhost »

AdrianH

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #35 on: January 01, 2011, 07:17:39 PM »
I have updated 3 machines, 1x32bit and 2x64bit Win7 , I have seen only one issue  and that is IE9 64bit will not run virtualised everything else is fine so far.

BRANDONN2008

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #36 on: January 01, 2011, 08:02:05 PM »
Hello. My shields except for web aren't scanning either. So do I need to uninstall Avast! and reinstall?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #37 on: January 01, 2011, 08:09:37 PM »
Hello. My shields except for web aren't scanning either. So do I need to uninstall Avast! and reinstall?
Most probably :)
The best things in life are free.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86142
  • No support PMs thanks
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #38 on: January 01, 2011, 08:14:13 PM »
Hello. My shields except for web aren't scanning either. So do I need to uninstall Avast! and reinstall?

I think this is related to your other issue in the topic you created, so follow the suggestions given there. http://forum.avast.com/index.php?topic=68623.0
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.11.2500 (build 21.11.6809.528) UI 1.0.683/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

burleymr07

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #39 on: January 01, 2011, 08:21:55 PM »
will this be fixed via VPS update or a new build?

Silent Assassin

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #40 on: January 01, 2011, 08:35:52 PM »
will this be fixed via VPS update or a new build?
New build

fnukyguy

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #41 on: January 01, 2011, 09:07:45 PM »
I was able to reproduce this bug on a fresh installation of windows 7 ultimate 64-bit (no programs installed except avast) running on virtualbox (default settings)

all I did was first install  Avast! Free Antivirus 5.0.677 (custom installation with system field shield, network shield and webshield). Reboot.   Then update to 5.1.864 through the gui.
Reboot.    System shield and network shield are not doing anything, except webshield.

looks like this affects everyone that is running windows 7 64-bit


EDIT : I tried to do a non-custom installation of avast 5.0.677 , and then update to  5.1.864 ...everything works normally-
looks like a custom-installation of 5.0.677 (with some shields disabled) does not update to 5.1.864 properly in win7 64-bit!
« Last Edit: January 01, 2011, 09:35:43 PM by fnukyguy »

Offline MikeBCda

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2248
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #42 on: January 01, 2011, 09:29:53 PM »
This seems to be one more of those things that for whatever reason is only (or mostly) a problem for certain systems (in this case, it sounds like 64 bit Win 7 is particularly vulnerable).  On my XP system, I went the update route rather than a clean uninstall/install, and all shields seem to be showing normal behavior on the first try.
Intel Atom D2700, 2 gig RAM, Win 7 x64 SP1 & IE-11, Firefox 51.0
(default). 320 gig HD, 15Mb DSL, Win firewall, Avast 12.3.2280 free, SpywareBlaster, MBAM Prem., Crypto-Prevent

Offline essexboy

  • Malware removal instructor
  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 40610
  • Dragons by Sasha
    • Malware fixes
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #43 on: January 01, 2011, 09:45:52 PM »
Now this is intriguing as my win 7 64 bit - with an update from the gui worked perfectly.  I wonder if there is a common programme running on the other systems that could be interfering.  My only running security software is AIS and windows defender.  I have little activity now on my behaviour shield but I have my trusted programmes allready inserted and have not use any new ones recently

fnukyguy

  • Guest
Re: WARNING, DANGEROUS BUG !! 5.1.864 is not scanning anything
« Reply #44 on: January 01, 2011, 09:48:47 PM »
essexboy : did u do a custom installation of 5.0.677 or did you have all shields running?

I think the bug is caused by trying to update a 5.0.677 with some shields disabled to 5.1.864 on win7 64bit