Author Topic: How to solve your system hang after the awful 5.1.864 update :)  (Read 2533 times)

0 Members and 1 Guest are viewing this topic.

Offline avparn

  • Newbie
  • *
  • Posts: 4
How to solve your system hang after the awful 5.1.864 update :)
« on: January 03, 2011, 01:40:38 PM »
Short answer : simply uninstall Avast by any mean, then reinstall the latest setup available on-line.
If you think you cannot, persevere trying.


Avast QA Team, please read on in details. The experience I describe here, is simply NOT acceptable, since this software is dedicated to non-technical, home users. I sincerely hope this will help you.


Hi there,

First, dear Avast Team, thanks a lot for your work during all these years, and happy new one !

This is a basic feedback of an ever-happy user, after his first very disappointing, but now solved, experience. I don't need any help at this point, I just hope this little feedback will help you people to fix your problems, as well as other users, who may be in the same situation as I was yesterday.

Just like Zephyr89, I have been installing and using, for myself, and for tens and tens of various relations's home computers, Avast Home/Free edition "ever since the blue icon(s) appeared", as Zephyr89 was saying in this previous post here http://forum.avast.com/index.php?topic=68660.0. Hi folk, that's me who was filling every registration form with "thanks again and again :-)"

Despite the word "Newbie" printed aside, I am definitely not :) As an ex-network and system administrator, a lot of people have been referring to me (I'm still an IT pro today, but dedicated to some niche technology, I left pro maintenance 15 years ago).

From my end, Avast has been one of the perfect tools for years. It has helped me to recover then protect many Windoz systems and data for friends or family, I can testify this. Since I proved, at work, multiple security flaws in both McAfee's and Norton's (was it 10 years ago ?), I have used and recommended Avast only, and never needed to look back -- until now.

Today, I stress thinking of the number of PCs which I have configured with Avast and auto-updates. How many of their users, will call their good old IT friend / brother / relation for help over the next few days or weeks ?


So -- Just like Zephyr89, I had my first bad experience with Avast ??? yesterday, while upgrading from 5.1.677 to 5.1.854. And it was amongst the worse experience a Windoz user can have. Even worse than a BSOD : strictly not a start of a clue, no error message.


PC is a Lenovo Thinkpad X200 Tablet model 7449-FWG, 2 GB RAM.
System is Windoz XP Tablet PC Edition version 2005 with SP3.

All fully up to date but WITHOUT any auto-update process (all disabled by default). Yes I use Microsoft Update, Lenovo Thinkvantage System Update and others, but on-demand and step-by-step only.

It's a light and optimized installation of Windoz. There isn't a single service or software running on that PC, or running at system or user startup, unless needed and without my prior knowledge. It's running "as fine as Windoz can run" :D for a couple of years.

Unlike Zephyr89

  • restore points have always been DISABLED just like on any Windoz system I install and take care. Instead, I do regular per-partition backups using CloneZilla, a way more reliable method I think.
  • I "only" use on top of Avast : frequent scans of Sysinternal's RootKit revealer, SpyBot S&D monitoring MSIE (which I merely use anyway) but NOT its resident program, and Windoz'default firewall. So, Avast is the sole third-party security resident program install here


All this may seem like too much efforts, but unfortunately I do not know any other way to maintain any version of Windoz alive without reinstalling every once in a while (which I never need for any of the system I have set up this way, therefore it's a massive time saving over the years).

This is to say that the environment is "under control", and the cause of the issue has now been clearly identified : it is Avast's latest upgrade.

So, yesterday I "switched to maintenance mode" (that's a figure of speech), checked for Avast updates using its built-in procedure. I noticed the available software upgrade, and I applied it.

HOWEVER, I DON'T REMEMBER THAT AVAST WOULD HAVE NOTIFIED ME ABOUT THE SOFTWARE UPDATE COMPLETION, NEITHER DID IT ADVISE ME TO REBOOT THE SYSTEM.

Instead, I remember seeing that the "current" version displayed still did not match with the last available one, after the upgrade attempt. (therefore, I now suspect that the upgraded was only partiallyapplied, leading to the system hang).

I then rebooted by precaution, and I was planning to re-instantiate the update process after the reboot.

But that's when the nightmare started : system hanged in "Normal" boot, right after user login and password. I could note that :

  • the wireless connection was not established (it is normally configured to be run BEFORE user login, an integrated application pops up to monitor the connection during login screen)
  • at this time, the mouse seemed to still respond
  • Ctrl+Alt+Sup once brought successfully the little dialogue offering basic choices, but my attempt to open the task manager lead to some hole in space or time

Maybe 10 minutes later (I thought I had been patient enough), I turned off the equipment (pressed 4 seconds on the power button).

I still didn't want to loose my system's and user env. evolutions since its last backup, so I decided to persevere like an idiot. AND I SUGGEST THAT YOU DO THAT ALSO, IF YOU ARE FACING THE SAME ISSUE : IT HAS REWARDED ME THIS TIME AGAIN.

After a series of retries, including always-succesful boots of my Fedora 14 partition (which was of course, still working like a charm), in order to make sure I had no memory or hardware / partition issue on this equipment, I eventually achieved to boot XP in "Fail-safe" mode.

Of course :

  • I could not find any system log entry, even just showing the start of a shadow of the faults the system had experienced, so it sounds like what happened completely prevented the OS to log, or even detect any fault.
  • I have no clue why I could boot this time, but neither before, nor later, even in "Fail-safe" mode

So in this first "fail-safe" mode session, only thing I did was to search the logs, then program both a partition check, and an Avast anti-virus scan, for the next boot time. Then, I rebooted.

Surprisingly :
  • The partition check returned no error at all (I was expecting some, since I had forced the system to power off). That's important since it shows how inactive the system was, at the time I turned it off like a barbarian.
  • The anti-virus scan, simply did not happen - like if it was just ignored
.

At this point, I was already strongly suspecting the Avast upgrade, and decided to try a complete uninstall then reinstinstall -- as soon as I would have a chance to do so....

But once again, I could not boot XP, in any mode.

Bonus : every time I tried booting in "normal" mode again, the partition check was showing on screen (just like if it had never been confirmed to be complete, which I suppose, is normally due to happen during the first successful boot). That XP bug feature was, actually, quite welcome in my situation :)

Then, after logging in "Normal" mode, the hang was a little more "radical" : while Ctrl+Alt seemed to remain responsive (keys were blinking in the on-screen keyboard, remember it's a tablet) but the +Sup key wouldn't bring any dialogue. Mouse wouldn't react either, but seemed frozen (while it remained responsive until the login screen).

And when I tried booting in "fail-safe" mode again, the partition check also seemed to be launched (but then, all I could see was a blinking cursor in black screen -- be patient).

Dear Avast team, you're just NOT allowed to create such a situation. At this point, most "normally constituted" users I know of, would have definitely thrown their PC by the window and called anyone for help.

Eventually (and I don't know why, either) I ended up to log on successfully in "fail-safe" mode.

Within a minute, I had kicked Avast out.
Then I could, immediately, log in the "Normal" mode.
A few minutes more, I had checked the system partition once again, reinstalled a freshly downloaded copy of Avast, latest version, and "of course" it rocked.
Then I completed a boot-time virus scan over night.
Problem solved.

I would add that after re-installation, reregistering was not welcome, since it should not be required. Instead, uninstall software should offer an option not to loose the registration information, so it can be used by subsequent installation. This also screw your statistics : I could not choose "I am not a new user" during the reregistration process.

Happy new year everyone !