Author Topic: Avast 5 behavior shield issue  (Read 3304 times)

0 Members and 1 Guest are viewing this topic.

brstma

  • Guest
Avast 5 behavior shield issue
« on: October 26, 2010, 12:14:06 AM »
I just updated to ver 5 (free) and the new behavior shield prevents my soundcard software and drivers from loading at startup. I enabled the "Load avast services after system services" option but it didn't help.  For now I have the behavior shield disabled so I can use my soundcard.  I tried reinstalling both as well. It's an EMU soundcard (Creative Professional) and all drivers/ software is current.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Avast 5 behavior shield issue
« Reply #1 on: October 26, 2010, 01:38:35 AM »
Are you sure that it was a behavior shield blocking?
Can you post a screenshot of the avast alert?
The best things in life are free.

brstma

  • Guest
Re: Avast 5 behavior shield issue
« Reply #2 on: October 27, 2010, 11:00:05 PM »
I deduced that it is because simply disabling only the behavior shield eliminates the problem.  It doesn't give any warning messages, but the splash screen for the soundcard app just hangs and the soundcard won't work until I disable the behavior shield.  Once the soundcard app/ drivers load I can enable the behavior shield and it all works;  the issue is only during startup/ logon if the behavior shield is enabled.

guitarguru

  • Guest
Re: Avast 5 behavior shield issue
« Reply #3 on: January 03, 2011, 07:54:20 PM »
Well......what's the solution?! I have exact the same problem. Also a E-MU soundcard. I also disabled the Behavior Shield. Only way to get my card talking...

guitarguru

  • Guest
Re: Avast 5 behavior shield issue
« Reply #4 on: January 03, 2011, 08:19:13 PM »
Actually it is working, but it takes a lot of time. The Behavior Shield is analyzing, over here, 237 files (drivers etc.), than it's fine...... So disable-ing the Shield is faster.

brstma

  • Guest
Re: Avast 5 behavior shield issue
« Reply #5 on: January 03, 2011, 11:40:28 PM »
I reinstalled Avast without the behavior shield