Author Topic: [Resolved] 0xC0000005 error when app (EBP) starts (using avast 5.1.864)  (Read 13578 times)

0 Members and 1 Guest are viewing this topic.

Tibodo

  • Guest
Hello and happy new year to everybody.

I just bought and install avast 5.1.864
Then I launch "EBP paye" software, and I get the error 0xC0000005.
I uninstall avast then launch "EBP paye" software and it works fine.
I reinstall avast 5.1.864, then I launch "EBP paye" software, and I got the error 0xC0000005.

So I think the there is a problem with avast 5.1.864.

Does anyone have the same probleme ?

Does anyone have a solution.

regards
« Last Edit: January 12, 2011, 12:13:12 PM by Tibodo »

SafeSurf

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #1 on: January 04, 2011, 10:02:26 AM »
Did Avast work fine PRIOR to you installing "EBP paye" software?

Tibodo

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #2 on: January 04, 2011, 10:22:53 AM »
Hello

I may have been unclear ?
I install avast on a computer (win XP sp3) on which "EBP Paye" software is already installed.
Then I launch EBP, and then I get an error from "EBP Paye" software while lauching "EBP Paye"
If I uninstall avast, EBP works fine again.

Avast works fine, the problem is I can't launch EBP after avast have been installed.

I can uninstall EBP, and install avast, avast will propably works fine, but I need to use "EBP paye"

It seems a similar problem occurs before (- the 0xC0000005 error while trying to execute certain applications (e.g. those compiled with some versions of Borland C++) :
http://forum.avast.com/index.php?topic=68267.0
http://forum.avast.com/index.php?topic=67985.0

SafeSurf

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #3 on: January 04, 2011, 10:29:23 AM »
The links you refer to are for older beta builds, and not the current one.

What I am wondering is if there is a conflict with Avast and "EBP Paye" software.  Could you do the following:

A. Uninstall "EBP Paye" software by the vendor's instructions, then reboot your machine.

B. Do an Avast Repair:
- Go to Control Panel > Add/Remove programs > Avast Antivirus.
- Scroll down and choose Repair function in the pop-up window.
- Reboot.

See if this fixes your problem and report back.  Thank you.

EBPDev

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #4 on: January 04, 2011, 01:27:11 PM »
EBP Paye is an unmanaged exe statically linked to a managed dll. The problem can be reproduced with any exe in this configuration.

To reproduce the bug, a software developer can do the following steps :
* using Visual Studio 2008, create a C++ managed dll using /clr compilation option (managed means linked to .Net Framework v2.0 CLR)
* in the dll, create an unmanaged test function and export it
* then, create a C++ exe, not managed (don't use /clr option)
* statically link the managed dll to the exe and call the test function from the test exe
-> the resulting exe can't be launched on a machine where the version 5.1.864 of Avast is installed: Windows reports a configuration issue with 0xC0000005 error code (this is not an access violation from the exe, Windows loader refuses to load it).

Tibodo

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #5 on: January 04, 2011, 02:44:46 PM »
Hello

Thanks "SafeSurf" for your advise, but infortunately it didn't works.
I've just uninstalled EBP paye, then I repaired avast then I re-installed EBP paye, then I get the same problem while launching EBP paye :
0xC0000005 error.

Thanks "EBPDev" for your informations.



Tibodo

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #6 on: January 05, 2011, 10:07:17 AM »
Hello

I installed Avast 4 and the problem is solved.

regards

SafeSurf

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #7 on: January 05, 2011, 12:53:02 PM »
I installed Avast 4 and the problem is solved.
The support for Avast 4.0 will stop shortly, therefore you need to have Avast 5.0 in your machine or you will not get the virus definitions updated and be protected.

Since this was a conflict with the other software and Avast, you need to do a clean uninstall and install of Avast, but you now have an old version of Avast on your machine.

Please do the following:

Uninstall Avast and do a CLEAN install:

1. Save a copy of newest version of Avast (5.0.864) for the product you need and save it to your HDD:
Free –  http://files.avast.com/iavs5x/setup_av_free.exe
2. Download the Avast Uninstall Utility, aswClear5.exe http://www.avast.com/uninstall-utility and save it to your HDD (it has uninstall tools for both 4.0 and 5.0).
3. Disconnect from the Internet at this time.
4. Go to Control Panel and uninstall Avast through Add/Remove Programs if possible and reboot.
5. If Step 4 fails, boot into Safe Mode (hit F8 repeatedly) and run the Avast Uninstall Tool.  You will need to uninstall Avast 4.0 and 5.0 and 5.1 at this time.
6. Reboot.
7. Install the newest version of Avast and reboot.
8. Get Internet access and register your copy for Free.
    Free – http://www.avast.com/registration-free-antivirus.php
9. Update the Avast definitions.

I also suggest if you do not have this software on your machine already to download it to clean your machine.  Install it now and clean your machine prior to performing the above instructions, then do it again afterwards.  CCleaner, freeware system optimization, privacy and cleaning tool.  There is a Slim version available as well at http://www.piriform.com/ccleaner/builds – 4th option down.  It removes unused files (cache, temporary Internet files, etc.) from your system, allowing Windows to run faster and freeing up valuable hard disk space.  It also cleans traces of your online activities such as your Internet history.  Additionally it contains a fully featured registry cleaner (but make a backup in My Documents just in case). 

Let me know how this works for you.  Thank you.


EBPDev

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #8 on: January 05, 2011, 03:11:46 PM »
I doubt a clean install will change anything for Tibodo. I already have reproduced this Avast bug on a clean freshly installed machine.

The temporary fix is the same as with Dell hardware problem seen in http://forum.avast.com/index.php?topic=68625.30. When uninstalling the Behavior Shield, the error disappear.

Let's hope a new Avast version will fix this quickly...

Tibodo

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #9 on: January 05, 2011, 04:14:08 PM »
Hello

I've just tried a clean install and when I launch "EBP paye" software, I still get the error 0xC0000005.. But Thanks to try helping me SafeSurf

Thanks EBPDev for the information, I hope too that a new Avast version will fix this quickly.

regards
« Last Edit: January 05, 2011, 04:16:26 PM by Tibodo »

EBPDev

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #10 on: January 06, 2011, 07:26:41 PM »
Build 874 doesn't fix this issue

Tibodo

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #11 on: January 07, 2011, 11:38:08 AM »
maybe next one...

SafeSurf

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #12 on: January 07, 2011, 12:11:39 PM »
You may want to uninstall and install the Avast beta version 5.1.874, which many users are finding is fixing problems.  Here are the download files:

Free: http://files.avast.com/files/beta/5.0.874/setup_av_free.exe
Pro:   http://files.avast.com/files/beta/5.0.874/setup_av_pro.exe
AIS:   http://files.avast.com/files/beta/5.0.874/setup_ais.exe

Let me know if this helps you out.  Thanks.

EBPDev

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #13 on: January 07, 2011, 04:57:50 PM »
As previously written, Avast beta version 5.1.874 doesn't fix this issue.

I've tried to uninstall previous version before installing this one but I notice no bug change on my side.

EBPDev

  • Guest
Re: 0xC0000005 error when app (EBP) starts (using avast 5.1.864)
« Reply #14 on: January 10, 2011, 05:30:12 PM »
Pre-release update 5.1.884 fixed this issue for me.

Does it for you Tibodo ?

Thanks