Author Topic: Avast Free Antivirus 5.1.864 and Windows 7 Firewall  (Read 6262 times)

0 Members and 1 Guest are viewing this topic.

Offline dbaryl

  • Newbie
  • *
  • Posts: 5
Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« on: January 09, 2011, 06:56:32 AM »
I just installed Avast Free Antivirus and it's blocking my web traffic. Works with the web shield down. I am using Windows 7 firewall.

I don't know if it's the avast settings that need to be changed, or something in the firewall settings.

Offline Mi Ka El

  • Jr. Member
  • **
  • Posts: 54
Re: Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« Reply #1 on: January 09, 2011, 10:38:10 AM »
Try repairing. Go to Control Panel > Add or remove programs and click on avast, it will show you the option to repair. If you don't get any posotive results the try reinstalling. Uninstall avast and reinstall. Last solution would be to try a new build, this is a new pre-release build. Uninstall the old avast and install this one
Free AV: http://files.avast.com/files/beta/5.0.874/setup_av_free.exe
Pro AV: http://files.avast.com/files/beta/5.0.874/setup_av_pro.exe
Internet Security: http://files.avast.com/files/beta/5.0.874/setup_ais.exe
Windows XP SP3 Pro x86: Avast Free Antivirus 8.0.1489, Private Firewall 7.0.29.1, Malwarebytes Free 1.75(on-demand), Opera 12.15.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85114
  • No support PMs thanks
Re: Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« Reply #2 on: January 09, 2011, 03:20:03 PM »
Lets not jump the gun here and first look at the most common causes of this.

The avast settings shouldn't need to be changed to be able to browse. Do you have the outbound protection enabled in the windows 7 firewall (off by default) ?

Have (or did) you another Anti-Virus installed in this system, if so what was it and how did you get rid of it ?

Do you use a proxy to connect to the Internet ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.5.2470 (build 21.5.6354.675) UI 1.0.646/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Abdul Hasib

  • Avast Reseller
  • Newbie
  • *
  • Posts: 16
Re: Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« Reply #3 on: January 09, 2011, 08:29:08 PM »
Make sure that you have not activated network-Lock

I dont realy support any kind of windows security softs personally. If you want free firewalls, u can try pc-tools, zonealarme f.w etc


Regards
« Last Edit: January 09, 2011, 08:31:47 PM by Abdul Hasib »

Offline dbaryl

  • Newbie
  • *
  • Posts: 5
Re: Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« Reply #4 on: January 10, 2011, 07:10:04 AM »
My Windows firewall settings are on default policy.

I was using TrendMicro Internet Security that came installed with this laptop, the trial period expired so i installed Avast. Have not been able to get it to work since the install - also tried version 4.8, same thing.

I connect thru my wireless router to a dsl modem. With the web shield up I can't get access anything a browser - other programs that require internet access, such as Google, do work.


If i can't get this to work with windows firewall i'll probably use Comodo.

Offline Gargamel360

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2346
  • Memento Mori
Re: Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« Reply #5 on: January 10, 2011, 07:18:40 AM »
Did Trend-Micro IS have a firewall?  Remnants sometimes get left behind on uninstalls, especially AV products.  So you may wish to find the appropriate removal tool from Trend-Micro, see here>>http://esupport.trendmicro.com.au/1/How-do-I-remove-old-or-new-versions-of-Trend-Micro-products-in-my-comp.aspx, in case remnats are conflicting with Avast.
Signature?  But I gots no pen....

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85114
  • No support PMs thanks
Re: Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« Reply #6 on: January 10, 2011, 03:26:01 PM »
My Windows firewall settings are on default policy.

I was using TrendMicro Internet Security that came installed with this laptop, the trial period expired so i installed Avast. Have not been able to get it to work since the install - also tried version 4.8, same thing.

I connect thru my wireless router to a dsl modem. With the web shield up I can't get access anything a browser - other programs that require internet access, such as Google, do work.


If i can't get this to work with windows firewall i'll probably use Comodo.

Most Internet Security (IS) products include a firewall.

I suspect you either have Trend still installed, unless you specifically uninstalled it and then there is a possibility remnants let behind, so you should run the Trend removal instructions Gargamel360 gave the link for.

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.5.2470 (build 21.5.6354.675) UI 1.0.646/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline dbaryl

  • Newbie
  • *
  • Posts: 5
Re: Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« Reply #7 on: January 11, 2011, 02:06:58 AM »
I just ran the Trend Micro uninstaller, followed by Avast removal tool to get rid of any traces of an old install. I also disabled Windows Firewall to see if that might be the problem. After a fresh install of Avast, the Web Shield still blocks my browser. The internal updater does work, however...

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85114
  • No support PMs thanks
Re: Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« Reply #8 on: January 11, 2011, 02:57:20 AM »
What is your browser ?

Do you happen to use a proxy to connect to the internet ?
Or use a web accelerator or anonymous proxy, etc. ? 
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.5.2470 (build 21.5.6354.675) UI 1.0.646/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline dbaryl

  • Newbie
  • *
  • Posts: 5
Re: Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« Reply #9 on: January 11, 2011, 03:37:27 AM »
I connect to my wireless router which is hooked up to a DSL modem. The browsers are IE and Chrome - it affects both. No proxy, afaik.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85114
  • No support PMs thanks
Re: Avast Free Antivirus 5.1.864 and Windows 7 Firewall
« Reply #10 on: January 11, 2011, 04:25:58 AM »
Sorry I'm at a loss as to what else to suggest as your system setup should work.

You could try setting IE to use the avast web shield proxy, Tools, Internet Options, LAN Settings, Proxy server, Address: Localhost Port: 12080

-  also see Cause for apparent Web Shield blocking internet connection, http://forum.avast.com/index.php?topic=57443.0.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.5.2470 (build 21.5.6354.675) UI 1.0.646/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security