Author Topic: avast HDD space reservation? (lost over 1 GB on fresh formatted drive)  (Read 3184 times)

0 Members and 1 Guest are viewing this topic.

neutrik

  • Guest
Hi,
this is my first post on the forum.

First of all I've been using avast free for 2 or 3 years and I've been always very satisfied with it. But couple of days ago one thing showed up and it bugs me a lot. I'm using version 5.1.889, Windows XP SP3, COMODO firewall, motherboard chipset from nVidia with SATA drivers.

I wonder If any of you noticed similar phenomenon:

I bought an USB portable hard drive 1 TB (931 MB) size. Formatted it to NTFS (default cluster size - 4KB). Under disk properties window there's 931 MB free space and about 94 MB used. Scanned in Space Sniffer it is showed as "unknown space". I know it is used for some partition data, MFT, whatever. When I use chkdsk.exe from command it shows the same.

And now it begins: when I copy a file, let's say 2 MB jpg and delete it, there's suddenly 1,25 GB used. I'm not using trash can and the system restore option is turned off. Space Sniffer shows 1,25 GB "unknown space". When i use chkdsk.exe i shows all the disk info correctly: 94 MB used, 931 GB free. Now I'm really confused.

Now, what it all got in common with avast?
When I turn avast shields off this "problem" does not exist. Whatever I do to my disk it shows used space correctly.

When avast is on - 1,25 GB is lost (used) on fresh, clean formatted drive. It's not right after formating, I have to do something involving disk activity (copy/delete, avast scan from context menu, restart windows, etc.)

I've noticed that 2 shields triggers this "effect" during copy/delete: P2P and IM shield. When I turn them off 1,25 GB used space (there's still no data on the disk - it's clean) shows after restarting windows. When I turn all shields off I can copy/delete, restart windows without this effect, but when I run scan from context menu - 1,25 GB used.

I must say that before every test I'm quick formatting my disk to bring default 94 MB used back. So in short the procedure looks like:

- quick format
- disk properties -> 94 MB used
- copy/delete
- disk properties -> 1,25 GB used
- quick format
- 94 MB used
- turn shields off
- copy/delete or system restart
- 94 MB used
- context scan
- 1,25 GB used

and so on... I've tested many combinations of shields, many quick formats passed...

Is it some kind of space reserved by avast for backup, virus chest? I know that over 1 GB on 1 TB HDD is not much, but what is happening? I would feel much more comfortable if I knew that this is intended and normal avast background work. And why does chkdsk.exe shows correct values. I've tested my drive for rootkits, mbr, bad sectors - everything is OK. I've checked on another computers at work: one with avast 4.8, and 2 with latest avast 5 version. On 4.8 this problem does not exist, on the other two it does except on one it's not triggered by copy/delete (scan and restart will do). Also asked my friend (he bought 1,5 TB SATA HDD) to check his drive. Same situation - using avast caused him to lost over 1,5 GB of space (bigger disk - bigger loss).

This problem concerns all my drives but due to the size of my USB I've been able to notice it easily. For example on one 100 GB partition after format is about 60 MB used, after disk activity involving avast - almost 200 MB used. When I divide my 1 TB HDD into 2 or 3 partitions the size used is proportional smaller but when added it all sums up to 1,25 GB.

Have anyone seen something like this?