Author Topic: XP hangs at shutdown after upgrading to 6.0  (Read 20645 times)

0 Members and 1 Guest are viewing this topic.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
XP hangs at shutdown after upgrading to 6.0
« on: March 06, 2011, 08:32:04 PM »
After upgrading to 6.0 my XP system hangs at shutdown.
It's at there very last stage of the shutdown.
All dialogs are closed and I'm just waiting for the power-off.
Instead nothing happends (left the system on for 12 hours :-)

Anyone know what could be causing this problem, and how get fix it?
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #1 on: March 06, 2011, 08:50:45 PM »
I suggest an installation from scratch:

1. Download the latest version of avast! Uninstall Utility and save it.
2. Download the latest avast! version and save it.
3. Uninstall avast from Control Panel (if possible). If, for any reason, you can't run it, try booting in Safe Mode and doing it from there. Anyway, boot after that.
4. Run the avast! Uninstall Utility saved on 1. If, for any reason, you can't run it, try booting in Safe Mode and doing it from there. Anyway, boot after you've run it.
5. Install avast! using the setup saved on 2. Boot.
6. Register your free copy or add the license key for Pro.
7. Check and post the results. If, for any reason, you did not solve, try doing the step 3 in Safe Mode anyway.
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84607
  • No support PMs thanks
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #2 on: March 06, 2011, 09:15:24 PM »
Isn't there a display pop-up on shutdown, as there is a delay set in and that should show the stalled program, etc.

If no display - Try and find UHPclean User Hive Profile clean. Basically this Microsoft program (run at startup) closes user hive profiles that haven't closed, so this may help. However, it doesn't identify the process as far as I'm aware, you could try checking the windows event viewer for any associated entries.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

doktornotor

  • Guest
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #3 on: March 06, 2011, 09:27:28 PM »

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #4 on: March 06, 2011, 09:37:47 PM »
I suggest an installation from scratch:

What would that change? Apart from beeing a lot of work?
I remember this happening on some other upgade too.
I we have to uninstall and reinstall everytime there is an upgrade, well :-)

To bad I can't see what process is hanging (can't open Process Explorer when XP is closing)
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #5 on: March 06, 2011, 09:44:42 PM »
I'm trying to troubleshoot.
It's not normal that the internal upgrade fails.
The best things in life are free.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #6 on: March 07, 2011, 01:01:32 AM »
I did a uninstall, then clean up registry (both manually and with Registry Mechanic).
After reboot without avast! everything works OK at shutdown.
Then I reinstalled avast!.
First shutdown went normal.
Next shutdown hanged as earlier :-(
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

doktornotor

  • Guest
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #7 on: March 07, 2011, 01:06:05 AM »
First shutdown went normal.
Next shutdown hanged as earlier :-(

Install UPHClean (link above) and use event viewer to find out what's the problem. Guessing what's wrong doesn't work.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #8 on: March 07, 2011, 01:12:07 AM »
What does UPHClean do?
I have removed all traces of avast! on the system before reinstalling.
Is there any debugging function I can use to check what is happening?
Nothing unnormal in the logs :-(
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

doktornotor

  • Guest
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #9 on: March 07, 2011, 01:17:09 AM »
What does UPHClean do?

It's described in the article I have linked.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #10 on: March 07, 2011, 01:25:34 AM »
OK, I'll try it and see if the system shuts down and what the event log says.
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline wesright

  • Newbie
  • *
  • Posts: 4
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #11 on: March 07, 2011, 03:49:03 AM »
I suggest an installation from scratch:

What would that change? Apart from beeing a lot of work?
I remember this happening on some other upgade too.
I we have to uninstall and reinstall everytime there is an upgrade, well :-)

To bad I can't see what process is hanging (can't open Process Explorer when XP is closing)

Hello, just a thought but you might be able to get an idea from checking the system Event Logs. Right click on My Computer and select Manage, then select the Event Viewer.  You can go through the System and Application logs and by looking at the timestamps, maybe you can find the offending process.

--Wesley

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #12 on: March 07, 2011, 10:33:03 AM »
OK, I'll try it and see if the system shuts down and what the event log says.

Now I have tried all suggestions. Found nothing. Almost...
What I have found is that this only happends when both avast! and ZoneAlarm is running.
If I shut down one of them it does not hang.

And.... It doesn't always hang...  I depends what applications I use between startup and shutdown.

I'll try to stop different avast! modules before shutdown and see if one special is causing the hang...

PS!  In the back of my head I can remember this occuring with a older version of avast! as well...
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Zyndstoff (aka Steven Gail)

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2610
  • I can resist anything except temptation.
    • tex62
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #13 on: March 07, 2011, 10:54:10 AM »
As far as I know, the combination of XP, ZA and Avast is not the best solution. There seem to be issues with ZA and Avast running under XP together.

Can't you try another FW like PCTools Firewall maybe?
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear

Offline Mayflower

  • Full Member
  • ***
  • Posts: 100
Re: XP hangs at shutdown after upgrading to 6.0
« Reply #14 on: March 07, 2011, 11:10:01 AM »
Want just to confirm that ZA and Avast is not a god combination on XP. 
Core i3-2350M, 4GB, Win 8, Avast! Free Antivirus, Malwarebytes Anti-Malware Free, Mozilla Firefox, Piriform CCleaner