Author Topic: Stupid firewall.  (Read 8421 times)

0 Members and 1 Guest are viewing this topic.

Twinkle

  • Guest
Stupid firewall.
« on: March 21, 2011, 07:14:09 AM »
What ever I try I cannot get my avast firewall to allow my home network in windows xp.  Even the free firewalls do this without a problem, so what is wrong with Avast's firewall and why are other Xp owners not finding this a problem.

I know it's the firewall that's blocking my home network because if I switch it off, my home network works perfectly.  It really is a stupid firewall.  :(

Daris

  • Guest
Re: Stupid firewall.
« Reply #1 on: March 21, 2011, 09:44:17 PM »
What security software are you using if any alonside Avast? When you installed AIS was it from a previous Avast installation, and did you completely remove the previous installation using Avast Uninstal Tool...Also Are you using a Proxy...How are you connecting to the internet?....

Twinkle

  • Guest
Re: Stupid firewall.
« Reply #2 on: March 22, 2011, 09:50:20 AM »
I am using avast internet security bundle version 6.0.1000, no other security software.
It was a fresh install of avast on freshly installed windows xp.
I am not using a proxy and I am connected to the net by a broadband O2 router.

Surfing the internet is fine, it's just our home network that the firewall will not allow.

Do you think it may help if I reinstall my avast on all computers?

doktornotor

  • Guest
Re: Stupid firewall.
« Reply #3 on: March 22, 2011, 09:59:50 AM »
Surfing the internet is fine, it's just our home network that the firewall will not allow.

You need to allow file/printer sharing on the firewall. Also note that avast! does NOT disable the Windows firewall, so you need to allow that there as well.

yongsua

  • Guest
Re: Stupid firewall.
« Reply #4 on: March 22, 2011, 10:06:31 AM »
May you try to set the avast's firewall to low risk zone instead of medium risk zone?
« Last Edit: March 22, 2011, 10:14:31 AM by yongsua »

Twinkle

  • Guest
Re: Stupid firewall.
« Reply #5 on: March 22, 2011, 10:18:40 AM »
Surfing the internet is fine, it's just our home network that the firewall will not allow.

You need to allow file/printer sharing on the firewall. Also note that avast! does NOT disable the Windows firewall, so you need to allow that there as well.

I can find no "allow file/printer sharing" option in the Avast firewall settings.

doktornotor

  • Guest
Re: Stupid firewall.
« Reply #6 on: March 22, 2011, 10:24:55 AM »

Twinkle

  • Guest
Re: Stupid firewall.
« Reply #7 on: March 22, 2011, 11:11:42 AM »
Okay, thank you.
I have the windows networking but not the windows file sharing, so it looks that this may be the problem.
The question is, how on earth do I give it this option?  :)

doktornotor

  • Guest
Re: Stupid firewall.
« Reply #8 on: March 22, 2011, 11:19:08 AM »
Noticed the Add button?

Twinkle

  • Guest
Re: Stupid firewall.
« Reply #9 on: March 22, 2011, 11:35:52 AM »
Noticed the Add button?

Haha, yes, but it gives me nothing to choose from.  Do I just write in "windows file sharing" and Avast will know what it is I am after?  :)

doktornotor

  • Guest
Re: Stupid firewall.
« Reply #10 on: March 22, 2011, 11:41:42 AM »
Well, dunno but the sceenshot show exactly what ports need to be opened etc. I would also suggest reading the help file.

Twinkle

  • Guest
Re: Stupid firewall.
« Reply #11 on: March 22, 2011, 12:22:31 PM »
I copied those settings to all computers, but no luck, it is still blocked.  :(

I think I will have to switch Avast firewall off and find another to replace it. Avast's firewall doesn't seem to be all that good, maybe in time they will get it working properly and I can switch it back on.

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 76039
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Stupid firewall.
« Reply #12 on: March 22, 2011, 12:30:49 PM »
It was a fresh install of avast on freshly installed windows xp.

Which service pack..??
AIS needs at least XP SP2..!!
W8.1 [x64] - Avast Free AV 23.3.8047.BC [UI.757] - Firefox ESR 102.9 [NS/uBO/PB] - Thunderbird 102.9.1
Avast-Tools: Secure Browser 109.0 - Cleanup 23.1 - SecureLine 5.18 - DriverUpdater 23.1 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

ArtemisF0wl

  • Guest
Re: Stupid firewall.
« Reply #13 on: March 22, 2011, 02:18:22 PM »
Noticed the Add button?

Haha, yes, but it gives me nothing to choose from.  Do I just write in "windows file sharing" and Avast will know what it is I am after?  :)

no i dont think so. youll have to create a rule.. one to copy /mimic exactly the one in that screenshot. it should be fairly straightforward. the main thing is you need to allow inbound connections on those ports designated for file sharing on a home network.. just copy the screenshot and youll be fine ;)

REDACTED

  • Guest
Re: Stupid firewall.
« Reply #14 on: March 22, 2011, 02:25:36 PM »
I have the same problem
Can`t use the web browser AT all, while avast web protection is running.
Thew only way i found is to disable completely the web protection.  ??? ???
« Last Edit: March 22, 2011, 02:27:55 PM by pedro@dfonet.com »