Author Topic: avast mail proxy didn't cause the open relay, after all  (Read 2357 times)

0 Members and 1 Guest are viewing this topic.

Offline zelani

  • Newbie
  • *
  • Posts: 13
avast mail proxy didn't cause the open relay, after all
« on: September 21, 2004, 09:42:53 AM »
A while back I posted about an issue with Winmail Server while using the avast mail proxy, I thought that avast was creating an open relay.

The real problem is that Winmail's relay security is dependent on the IP address of the sender.  And if the sender was MY antivirus proxy, then Winmail "sees" ME as the sender and allows the relay.  Winmail doesn't care if I have a username & password or not.  Everything depends on that sending IP.

I replaced Winmail with MailEnable mail server -- MailEnable has less features than Winmail, but MailEnable supports SMTP authentication.  This means that even though the message is actually sent to the server by my IP - the relay is only allowed for authenticated users, which is actually much better than Winmail's IP method.  
When I put the avast proxy in front of the MailEnable Server -- avast hands off my user name and password just perfectly.  I've been trying to relay off my server all day today and can't.  

So I'm pretty comfortable saying the problem is much more with Winmail than with avast!.

I should also note that, that I wrote to avast! support about this, and they wrote back, and were very helpful.  I have no doubt they would have fixed avast if it had been avast that needed fixed.  Fact is without their help I wouldn't have figured out why it was happening.

Writing to the winmail people was a waste of time.  They simply ignored me.  They've got a great product if they ever finish it.    Ignore=Uninstall.  I'm glad I hadn't bought a license yet.

MailEnable Standard is a very full feature email server, considering it's free.
by bill
bbzz@zelani.net


My favorite question is WHY.  My second favorite is WHY NOT.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 83347
  • No support PMs thanks
Re:avast mail proxy didn't cause the open relay, after all
« Reply #1 on: September 21, 2004, 01:52:03 PM »
Hi zelani,

Thanks for taking the time to get back to us and letting us know you have resolved the problem and how. You never know it could be of help to others following behind you.

David
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.5.2415 (build 20.5.5410.561) UI-1.0.532/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re:avast mail proxy didn't cause the open relay, after all
« Reply #2 on: September 21, 2004, 02:40:31 PM »
After all, I'm glad about avast! support help you received!  :)
The best things in life are free.