Author Topic: No activity in script shield with ie9  (Read 14069 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: No activity in script shield with ie9
« Reply #15 on: March 25, 2011, 10:25:03 PM »
The best things in life are free.

Offline DBone

  • Sr. Member
  • ****
  • Posts: 283
Re: No activity in script shield with ie9
« Reply #16 on: March 25, 2011, 10:45:00 PM »
What about us Chrome guys? :P
Windows 7 Home Premium x64 ~ Clean Install ~ Router NAT Firewall ~ Windows 7 Firewall ~ Bitdefender Antivirus Free ~ Chrome ~ Ghostery ~ Windows 7 System Image

doktornotor

  • Guest
Re: No activity in script shield with ie9
« Reply #17 on: March 25, 2011, 10:51:42 PM »
What about us Chrome guys? :P

I am afraid that people really do not have the correct idea about Script Shield. http://forum.avast.com/index.php?topic=74448.msg616766#msg616766

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8784
Re: No activity in script shield with ie9
« Reply #18 on: March 25, 2011, 10:55:55 PM »
Im starting to think kenny was pulling my leg ?
I'm not pulling your leg.
This is the current Script Shield on my Windows 7 system and I am using IE9 64bit.
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11797
    • AVAST Software
Re: No activity in script shield with ie9
« Reply #19 on: March 25, 2011, 10:59:56 PM »
The Script Shield will, most likely, be extended to some other browsers, and improved even for IE. But - it will take some time (probably won't happen this year).

Offline danny96

  • Malware Fighter
  • Advanced Poster
  • **
  • Posts: 668
  • No-malware!
Re: No activity in script shield with ie9
« Reply #20 on: March 25, 2011, 11:05:04 PM »
Im starting to think kenny was pulling my leg ?
I'm not pulling your leg.
This is the current Script Shield on my Windows 7 system and I am using IE9 64bit.
I have 0/0. On version 6,0,1000 I had about 600/0
Real-time protection and Firewall: COMODO Internet Security 12.0.0.6810 -- Additional Protection: Web Of Trust, Ublock, NoScript, Malwarebytes Premium, Avast! Online Security, Hitman Pro -- OS: Windows 10

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85088
  • No support PMs thanks
Re: No activity in script shield with ie9
« Reply #21 on: March 25, 2011, 11:10:36 PM »
Im starting to think kenny was pulling my leg ?
I'm not pulling your leg.
This is the current Script Shield on my Windows 7 system and I am using IE9 64bit.
The problem is that image is proof of nothing as it doesn't show what is being scanned.

Only the actual script shield UI would show what was actually scanned. So unless you actually have that UI open and watch it like a hawk and see that it is scanning web based scripts whilst browsing with IE9 that image doesn't provide proof.

Even when it shows a web based script being scanned, it isn't necessarily as a result of IE9, see my image and I use firefox which isn't supported. So that occurrence is a a non-browser http connection (when I reinstalled winamp today).

So for me other than when I ran either WMP 11 (now completely uninstalled) or winamp the total daily activity for the script shield was 0/0. Yes on earlier versions of 6.0.x I had a much greater script shield activity in 1044 virtually nothing.
« Last Edit: March 25, 2011, 11:12:22 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.4.2464 (build 21.4.6266.561) UI 1.0.639/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8784
Re: No activity in script shield with ie9
« Reply #22 on: March 25, 2011, 11:21:01 PM »
So for me other than when I ran either WMP 11 (now completely uninstalled) or winamp the total daily activity for the script shield was 0/0. Yes on earlier versions of 6.0.x I had a much greater script shield activity in 1044 virtually nothing.
I'm not sure what you are trying to say but I don't have WMP 11 as I have WMP 12:
http://windows.microsoft.com/en-US/windows7/products/features/windows-media-player-12
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85088
  • No support PMs thanks
Re: No activity in script shield with ie9
« Reply #23 on: March 25, 2011, 11:39:47 PM »
The main point of my post was:
a) to make it clear your imaged didn't prove IE9 was being covered by the script shield, but obviously that wasn't what you wanted so omitted it.

b) that the script shield is doing (or rather not doing) some freaky things. In previous builds there would be daily activity for it. However in both 6.0.1027 and this build 1044 the daily activity for the script shield is 0/0, none, nada, nil, zero, no activity unless you launch an application which runs many scripts (commonly media players).

So it is the inconsistency between builds for the script shield which works in one but not in another build unless you specifically launch a media player, which I wasn't having to do previously to see activity during my normal computer use.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.4.2464 (build 21.4.6266.561) UI 1.0.639/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8784
Re: No activity in script shield with ie9
« Reply #24 on: March 25, 2011, 11:57:29 PM »
b) that the script shield is doing (or rather not doing) some freaky things. In previous builds there would be daily activity for it. However in both 6.0.1027 and this build 1044 the daily activity for the script shield is 0/0, none, nada, nil, zero, no activity unless you launch an application which runs many scripts (commonly media players).
I did not have any media player active only IE9.
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline DBone

  • Sr. Member
  • ****
  • Posts: 283
Re: No activity in script shield with ie9
« Reply #25 on: March 26, 2011, 12:47:42 AM »
What about us Chrome guys? :P

I am afraid that people really do not have the correct idea about Script Shield. http://forum.avast.com/index.php?topic=74448.msg616766#msg616766

I have been using 6.0 since beta, and the script shield has never, and I mean ever, scanned so much as one script while browsing 100% with Chrome. On my XP test rig, as soon as I fire up IE8, the script shield goes crazy. However, if I use Chrome on that same XP machine...........Nothing, nada, zip for hours and hours of browsing......................... Sure seems browser dependent to me???
Windows 7 Home Premium x64 ~ Clean Install ~ Router NAT Firewall ~ Windows 7 Firewall ~ Bitdefender Antivirus Free ~ Chrome ~ Ghostery ~ Windows 7 System Image

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2098
Re: No activity in script shield with ie9
« Reply #26 on: March 26, 2011, 01:09:55 AM »
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: Avast Premium Security 19.7.2388, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68.0.2, MBam Free, CCleaner

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85088
  • No support PMs thanks
Re: No activity in script shield with ie9
« Reply #27 on: March 26, 2011, 01:42:52 AM »
b) that the script shield is doing (or rather not doing) some freaky things. In previous builds there would be daily activity for it. However in both 6.0.1027 and this build 1044 the daily activity for the script shield is 0/0, none, nada, nil, zero, no activity unless you launch an application which runs many scripts (commonly media players).
I did not have any media player active only IE9.

You don't need to have a media player active, the whole point of using it was to confirm that the script shield wasn't completely dead.

The script shield scans more than Internet Scripts, that is why it is important to actually confirm that it is scanning IE9 script traffic and you simply can't do that with the statistics image that you posted.

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.4.2464 (build 21.4.6266.561) UI 1.0.639/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8784
Re: No activity in script shield with ie9
« Reply #28 on: March 26, 2011, 01:14:32 PM »
See this http://forum.avast.com/index.php?topic=74149.msg614956#msg614956 by Vlk. 
That's talking about PRE-RELEASE REFRESH 6.0.1035 not the current 6.0.1044 PRE-RELEASE!
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2098
Re: No activity in script shield with ie9
« Reply #29 on: March 26, 2011, 01:42:04 PM »
See this http://forum.avast.com/index.php?topic=74149.msg614956#msg614956 by Vlk. 
That's talking about PRE-RELEASE REFRESH 6.0.1035 not the current 6.0.1044 PRE-RELEASE!

Right.  But nothing in any of the release notes for 6.0.1044 indicates any change in Script Shield at all. http://forum.avast.com/index.php?topic=74515.msg617340#msg617340

Quote
And new in v6.0.1044:
- solved a memory leak in the avast gadget
- solved a few things in WebRep
- autosandbox-related fixes
- WinXP: File System Shield not doing repetitive scans anymore
- improvements in SafeZone isolation
- improvements in the avast! sandbox (better TDL shielding etc)
- localization updates

Of course, Vlk can confirm Script Shield's capability if he wishes. ::)
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: Avast Premium Security 19.7.2388, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68.0.2, MBam Free, CCleaner