Author Topic: [6.0.1044] Avast Running a Full System scan automatically and loops  (Read 8414 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71741
  • No support PMs thanks
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #30 on: March 30, 2011, 01:58:37 AM »
Well that was a very short test, as soon as I rescheduled the scan, boom it was off and running on my XP Pro system avast 6.0.1044.

Off to modify my avast5.ini again and change the SchedulerEnabled=1 back to SchedulerEnabled=0 as I can't get back into the settings after I stop it, to quick to restart the scan within a couple of seconds.
« Last Edit: March 30, 2011, 02:00:29 AM by DavidR »
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2015 10.2.2218 R2-SP2/ Outpost Firewall Pro9.1/ Firefox 37.0.2, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.1.4/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline jeb54321

  • Newbie
  • *
  • Posts: 7
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #31 on: March 30, 2011, 02:10:57 AM »
Add me to the list.  I've been trying all day to get this scan to stop, but as with previous posters, I've been unsuccessful.

As far as I know, this just started last night.  The only ray of light I might be able to shed is that I left the computer on over night, and when I went to use it this morning, the infinite scan was running.  In my case though, there was a dialog box that said "FULL / Running" (I think my scan was titled "Full") and it had a stop and a pause button.  But when I click stop, it restarts immediately.

Also unrelated - I found the Avast sidebar gadget annoying, so I went through the Control Panel process to uninstall it recently, but that was well before the infinite scan started.

Off to try the INI edit.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11407
    • AVAST Software
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #32 on: March 30, 2011, 02:13:46 AM »
I was finally able to simulate the behavior somehow (even though I am unsure about the necessary conditions) - and noticed a strange behavior on one line of code...
I'll pass it to other developers for now, I'm mostly sleeping already.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71741
  • No support PMs thanks
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #33 on: March 30, 2011, 02:15:34 AM »
Thanks, much like I was at 4:45am yesterday morning when I was fighting this and trying to gather as much info as possible ;D
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2015 10.2.2218 R2-SP2/ Outpost Firewall Pro9.1/ Firefox 37.0.2, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.1.4/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline beachdog

  • Newbie
  • *
  • Posts: 4
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #34 on: March 30, 2011, 04:08:51 AM »
Boy, I am sort of glad that I found this posting.  Glad at least that I am not the only one experiencing this issue.  Mine starting the endless looping of full system scan at 9:30 AM when the system was waken (from hibernation) by the server for a daily incremental backup.  I don't use this computer during the daytime so didn't really pick up on the issue until later this afternoon.  I should have checked the forum but instead called for support which was a futile, exasperating waste of time.  All that they could think of doing was to uninstall and then re-install.  And they had the audacity to think that it was fixed when upon rebooting there was Avast in all its glory running a full scan that no one had called for.

I will do the manual edit to the ini file as was identified earlier in this posting (THANK-YOU!).

For those of you keeping score on this matter, this is a dual core Athlon running Vista SP2.  Paid version of Avast Security Suite running without prior issues since 12/25/2010.  Current version is 6.0.1000 with engine and definitions 110329-1.


1.all were "monthly" schedules for the 1st day of the month, or some were different?  YES - first of the month at 12:00 PM
2.was it always the full system scan? (even though I don't think this is relevant)YES
3.was your computer turned on during the DST change? was it turned off ever since that?
Hibernated at the time of the DST change but has been rebooted since that time without negative affect on Avast until today.
4.- all were avast! 6? YES

Offline beachdog

  • Newbie
  • *
  • Posts: 4
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #35 on: March 30, 2011, 04:32:41 AM »

You could also try booting into safe mode, avast doesn't run in safe mode, so you should be able to start avast manually, to do a scan, that should allow you to access the Scan Computer interface and open the Full System scan, more details, Scheduling and uncheck the 'Schedule this scan.' OK those changes, but don't complete the scan.

Boot into normal mode and see if that has resolved the scheduled scanning and looping, this is safer than modifying the avast5.ini file.

Quick update - I just tried this route, unfortunately, it was not successful.  Opened Avast UI while in Safe Mode, got to the settings, unchecked the "schedule this scan", ok'd the change and then rebooted normally.  Avast full scan was happily cranking along.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71741
  • No support PMs thanks
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #36 on: March 30, 2011, 05:13:06 AM »
If you aren't quick enough to stop the scan and open the scan settings before the next scan starts to cancel the Schedule, you are going to have to try modifying the avast5.ini file.

As I mentioned in my Reply #30 above.

If you did an update from avast 5 to avast 6 - avast5.ini file locations, Windows 2000, Windows XP - C:\Documents and Settings\All Users\Application Data\Alwil Software\Avast5\avast5.ini
- Vista, Win7 - C:\ProgramData\Alwil Software\Avast5\avast5.ini

If you did a clean install to avast 6 - avast5.ini file locations C:\Documents And Settings\All Users\Application Data\Avast Software\Avast\avast5.ini(Windows 2000, Windows XP). Or C:\ProgramData\Avast Software\Avast\avast5.ini(windows Vista, windows 7).

Before you can edit the avast5.ini file you have to disable the avast self-defence module, avastUI, Settings, Troubleshooting. You should only use notepad to edit avast5.ini. You will need to reboot after editing the avast5.ini file for the changes to come into effect.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2015 10.2.2218 R2-SP2/ Outpost Firewall Pro9.1/ Firefox 37.0.2, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.1.4/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline beachdog

  • Newbie
  • *
  • Posts: 4
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #37 on: March 30, 2011, 05:13:18 AM »
Last update for the day... did the manual edit to the avast.ini file as DavidR prescribed.  Actually had to do this in Protected Mode too since Avast wouldn't let me shut down the process that was holding onto the ini file.  Finally, I can get some work done on here since Avast isn't hogging 60% of CPU anymore.

I'll just call this a temporary workaround until the developers get to the bottom of this.

Thanks again to DavidR and the other contributors.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71741
  • No support PMs thanks
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #38 on: March 30, 2011, 05:18:41 AM »
You're welcome.

You should be able to disable the self-defence module as I mentioned, if you can't then notepad is the one exception to the self-defence module. When you complete the edit, on saving it, the self-defence module should ask for confirmation about the edit.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2015 10.2.2218 R2-SP2/ Outpost Firewall Pro9.1/ Firefox 37.0.2, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.1.4/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline chris2925

  • Newbie
  • *
  • Posts: 4
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #39 on: March 30, 2011, 11:51:28 AM »
Hi total technophobe here - I have had the same problem since 29.03.11 - 9.42 am - so no apparent connection to BST.
I am running paid version 5.1.889 - all help appreciated.
Remember advice to be given in numpty terms.  :'(

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11407
    • AVAST Software
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #40 on: March 30, 2011, 12:34:15 PM »

Offline chris2925

  • Newbie
  • *
  • Posts: 4
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #41 on: March 30, 2011, 01:40:36 PM »
The only scheduling I have is for the quick scan - nothing for the full scan & there is no settings button to change any scheduling on the full scan.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71741
  • No support PMs thanks
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #42 on: March 30, 2011, 03:14:23 PM »
You don't see a settings button until you a) click the More details and b) hover over the word Settings.

I suspect the Quick scan scheduling would also be effected if it was scheduled monthly for the 1st of the month. I think that it is the monthly scheduled scan routine (as Igor mentions above) that is throwing up this anomaly.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2015 10.2.2218 R2-SP2/ Outpost Firewall Pro9.1/ Firefox 37.0.2, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.1.4/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline chrisaroz

  • Avast reseller
  • Newbie
  • *
  • Posts: 17
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #43 on: March 30, 2011, 04:04:41 PM »
1 Year ago today I posted about this EXACT same issue. I think someone may be onto something regarding Feb and a bug with the shortened day.

http://forum.avast.com/index.php?topic=57857.msg487683#msg487683

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71741
  • No support PMs thanks
Re: [6.0.1044] Avast Running a Full System scan automatically and loops
« Reply #44 on: March 30, 2011, 04:18:58 PM »
Well a year ago avast 6 wasn't out and the avast Home (free) version didn't have this scheduling option within avast. So this wouldn't have been so noticeable as it currently is. So this additional spike in people experiencing the problem has pushed it into the spotlight. Unfortunately that didn't seem to happen in the topic you started.

Which in effect has found the likely problem and given the workaround in Igor's link above. Hopefully this can now be resolved so we don't have a recurrence next year.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2015 10.2.2218 R2-SP2/ Outpost Firewall Pro9.1/ Firefox 37.0.2, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.1.4/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security