Author Topic: Avast 5 Prevents Eclipse from Startup  (Read 3238 times)

0 Members and 1 Guest are viewing this topic.

Avator

  • Guest
Avast 5 Prevents Eclipse from Startup
« on: March 30, 2011, 08:48:23 AM »
Hello. I don't know how to post bug. So I'm writing it hear.
Avast 5 Free Edition with disabled active protection prevents starting an Eclipse. I've tried Eclipse (x64) versions 3.6 and 3.7M5 with JDK 6u24 (x64), 6u22 (x64), 5.0.22(x64).  Operating system is Windows 7 Pro Russian x64. I can'not write the version of Avast, because I had to delete it to understand that it was the cause of the problem.  But Avast was updating every day so I gues it was the last version.

PS Sorry for my awful english.
PPS I hope this information would be useful for making Avast better.

Offline nmb

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3054
Re: Avast 5 Prevents Eclipse from Startup
« Reply #1 on: March 30, 2011, 08:52:17 AM »
I don't understand -
Quote
Avast 5 Free Edition with disabled active protection prevents starting an Eclipse.

You mean you have disabled avast and using an other resident antivirus with it?

doktornotor

  • Guest
Re: Avast 5 Prevents Eclipse from Startup
« Reply #2 on: March 30, 2011, 09:15:00 AM »
On another note, we are @ 6.0.1000 (official) and 6.0.1044 (pre-release). Unless you can reproduce with the above at least, no action I'm afraid.

Avator

  • Guest
Re: Avast 5 Prevents Eclipse from Startup
« Reply #3 on: March 30, 2011, 03:45:53 PM »
I don't understand -
Quote
Avast 5 Free Edition with disabled active protection prevents starting an Eclipse.

You mean you have disabled avast and using an other resident antivirus with it?

No... I've only one antivirus installed - Avast. All scanners (resident protection) is turned off. (I'm using Avast only when I need to check new downloaded files). But when I'm trying to start Eclipse I get Error from JVM EXCEPTION_ACCESS_VIOLATION (0xc0000005). The only way to start Eclipse is to uninstall Avast. And... if current version of Avast is 6.0.1000 I guess I've got it. I've installed Avast on this machine less then month ago.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67198
Re: Avast 5 Prevents Eclipse from Startup
« Reply #4 on: March 30, 2011, 04:02:24 PM »
JVM is Java Virtual Machine... Nothing related to avast.
Maybe googling JVM EXCEPTION_ACCESS_VIOLATION (0xc0000005).
The best things in life are free.

Offline nmb

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3054
Re: Avast 5 Prevents Eclipse from Startup
« Reply #5 on: March 30, 2011, 04:40:00 PM »
Can you try uninstalling(disabling is different than uninstalling) one shield at a time and see the problem persists? Start with the behavior shield.