Author Topic: WebRep, IE8 & GMail  (Read 7258 times)

0 Members and 1 Guest are viewing this topic.

Jack 1000

  • Guest
Re: WebRep, IE8 & GMail
« Reply #15 on: May 10, 2011, 06:06:36 AM »
The message that the OP gets is one of the biggest little PITA's for IE 8.  It's not really a warning. The wording is strange in this regard.  Sometimes web-developers will use mixed security on a page, where part of a page is secure and part of a page is not.  Competing browsers just display the content appropriately.  But IE's little https: mixed warning message is more of an annoyance than a help.

To fix this without compromising security of your computer, you should keep your G-Mail https at secure.  However, tell IE 8 in it's settings to display mixed security content without the warning message.  Here's how to do that: Open IE 8 and follow the steps below:

Turn off https prompt in IE 8 (If you would like to disable this security warning forever:)

1. Go to Tools -> Internet Options
2. Select the Security tab. (Make sure the “Internet” zone is selected)
3. Click the “Custom Level” button. Scroll-down the list of options
4. Set the “Display mixed content” setting from “Prompt” to “Enable.”
5. Apply the changes.  It's done!

Taken from:

http://www.labnol.org/software/ie-security-warning-for-https-websites/13388/

Jack

PS. You might need to close IE and all Windows, than restart IE, before the setting will take effect.

« Last Edit: May 10, 2011, 06:19:31 AM by Jack 1000 »

Offline C69

  • Jr. Member
  • **
  • Posts: 29
Re: WebRep, IE8 & GMail
« Reply #16 on: May 10, 2011, 07:05:09 PM »
Jack,
By changing "Display mixed content" from Prompt to Enable will just stop the warning message & NOT have any bearing on my security protection?

Jack 1000

  • Guest
Re: WebRep, IE8 & GMail
« Reply #17 on: May 10, 2011, 08:36:24 PM »
Jack,
By changing "Display mixed content" from Prompt to Enable will just stop the warning message & NOT have any bearing on my security protection?

Correct,

All that will do is stop the message prompt that says, "Do you want to view only the content on this page that was delivered securely?"  It will not compromise your computer's security.  By changing that setting, you won't see that annoying message anymore.  If there was a simple way to have IE 8 say, "Don't Show This Warning Again," when the prompt first pops up, you could check that, and have IE 8 remember the setting. IE 8 has no "Don't Show This Message again" for that prompt.  This is something that I hope IE 9 has or gets in an update, because it needs it.

The only way to stop the message from appearing for good, is to do the steps above.  You might want to print and save those instructions, if you need to apply them to another computer.

Jack

PS.  I used to get the message in G-Mail all the time, and before I knew how to disable the "Mixed Content" message, I had to turn off the https thing in G-Mail to get it to stop.  But you don't want to do that, leave your secure htts: in G-Mail turned on, and do the steps in my post above.  That should take care of it.  Before I disabled this setting, I was also getting that message sometimes on Google Docs, especially when they changed the layout, AND on Windows Live Sky Drive when MS changed the site!  When that show mixed content prompt is on, and web-developers change their sites, that message may come back.  You put the Display Mixed Content on "Enable." and the message goes away.

You could leave the prompt on as the default and wait for a Web Rep update through a new Avast version.  But this might also be a Google issue as well. I recommend to people to just set IE to always show the mixed content as outlined above if they get that message too much, especially on multiple sites, and the problem goes away after those steps are applied.
« Last Edit: May 10, 2011, 08:51:11 PM by Jack 1000 »