Author Topic: Running executables from network shares  (Read 1532 times)

0 Members and 1 Guest are viewing this topic.

cmac

  • Guest
Running executables from network shares
« on: April 20, 2011, 05:53:51 PM »
Today I set out to track down a problem that I've been seeing from time to time recently, and the root of the problem seems to be Avast.

My PC runs Windows 7 and is attached to a network with another machine on it.  The other machine is a Windows XP machine with various shared folders.  On one of those shares I have a few executables that I run directly from the fileserver in the form of \\server\path\to\tools\program.exe.

One of those applications displays reports on screen using the Microsoft ReportViewer control.  This is a VB application built on .Net 4.  When a report is on screen, clicking on the Print button should bring up the printer selection dialog, but instead nothing would appear and the application would be frozen.  From that point on it was impossible to do anything else on the machine - the mouse cursor would move for a while, but even that would freeze after 30 seconds or so.  The only option thereafter was to reset the computer.

I knew this seemed to be network related because I could run the same application locally on my Windows 7 PC with no problems.

I tried changing the driver and settings for the network adapter, but it made no difference.  Clearly the problem was related to something that was very deeply integrated into Windows, so I tried disabling all the real-time shields in Avast and suddenly the application worked every time.

Thinking that I was making progress, I decided to re-enable the shields one at a time.  I started with those that were least likely to cause problems in this context - IM, P2P and Mail - and the application continued to work.  So far so good.  I turned on the Behaviour shield and from that moment the application wouldn't start at all.  I could launch it - the Windows process viewer showed about 100K of the application was in memory - but the opening form would not appear.  The machine didn't freeze as before, but it would not show any new windows for any applications.  If I tried to launch anything else it would appear in the process viewer but Windows was clearly stalled somewhere in the 'creating new windows on screen' department.

I turned off all the real-time shields but this behaviour - the system stalling when the application launched - continued.  I have since uninstalled Avast, and the application now works fine.

This was done with a new installation of the current Avast, but I had seen the same issue with the previous version so it doesn't appear to be something that has just been introduced.

I would like to be able to re-install Avast at some point, so I'm posting this in the hope that one of the developers might be able to do some testing to try to replicate, and maybe fix, the problem.