Author Topic: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On  (Read 16507 times)

0 Members and 1 Guest are viewing this topic.

RB123

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #15 on: April 22, 2011, 10:18:35 AM »
Turning Web Shield off, only blocks web protection.
Try not to make that a first recommendation, that should be a last resort only.

What I did was I kept 'Web Shield' On, but I unchecked 'Scan web (HTTP)traffic' from the 'Web Shield' and now my speed is back to around 18.0 Will that still protect me from the web?
No, you more or less turned it off by doing this.  Try what I told you....or don't, I guess ::) ;D

I agree.
Download e.g. the AIS installer file from my signature (click on the blue AIS) and take the time the download took.
Turn of WebShield and do the same again.

Any significant time-difference?

With 'Web Shield' on, it was about 56sec

With 'Web Shield' off, it was about 1min 40sec

But my web pages still load slower with 'Web Shield' on

Gargamel360

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #16 on: April 22, 2011, 10:28:12 AM »
Ehhh, a little better than the speed test result in terms of loss but still a decent chunk.  What kind of page load time differences?  Changed any WebShield settings?  How long have you had the problem, like would it coincide with any recent updates?


Hermite15

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #17 on: April 22, 2011, 10:34:57 AM »
doesn't affect video streaming either, as first, the frames are either downloaded as you see them, either cached progressively. And second, the web shield doesn't scan videos (by default) anyway so...

Gargamel360

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #18 on: April 22, 2011, 10:37:51 AM »
Yeah, changed any settings at all?

RB123

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #19 on: April 22, 2011, 10:41:07 AM »
Ehhh, a little better than the speed test result in terms of loss but still a decent chunk.  What kind of page load time differences?  Changed any WebShield settings?  How long have you had the problem, like would it coincide with any recent updates?



With 'Web Shield' on, it was about 56sec

With 'Web Shield' off, it was about 1min 40sec

I had this problem when Avast started with 6.0 actually. No problem with recent updates. After I tried Avast 6.0  and had this problem, I tried Panda Cloud on this laptop with this problem and I didn't have any problems with my speed. But, I like Avast better.




Gargamel360

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #20 on: April 22, 2011, 10:53:50 AM »
Well, bottom line is it should not have noticeable impact on things you are mentioning.  Might be you should try a clean re-install if this happened when you updated to ver. 6.

edit; Where's Safesurf, we need one of those fancy canned re-install instructions ;D
« Last Edit: April 22, 2011, 10:56:26 AM by Gargamel360 »

RB123

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #21 on: April 22, 2011, 11:01:43 AM »
Well, bottom line is it should not have noticeable impact on things you are mentioning.  Might be you should try a clean re-install if this happened when you updated to ver. 6.

edit; Where's Safesurf, we need one of those fancy canned re-install instructions ;D

It has happened with other 6.0 versions. Like other people have said here, looks like it's a known issue. It's very simple actually, with 'Web Shield' off no problem, with 'Web Shield' on, problem.

Gargamel360

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #22 on: April 22, 2011, 11:07:15 AM »
It has happened with other 6.0 versions. Like other people have said here, looks like it's a known issue. It's very simple actually, with 'Web Shield' off no problem, with 'Web Shield' on, problem.
Oh, its far too late/early for me to debate this with you ;D

Just know, if you turn it off, its at your own risk.  Avast!'s parts are meant to work together, so turning off the WebShield might be akin to making it try to run the
Anti-malware Marathon with its hands tied behind its back. ;)

RB123

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #23 on: April 22, 2011, 11:09:04 AM »
It has happened with other 6.0 versions. Like other people have said here, looks like it's a known issue. It's very simple actually, with 'Web Shield' off no problem, with 'Web Shield' on, problem.
Oh, its far too late/early for me to debate this with you ;D

Just know, if you turn it off, its at your own risk.  Avast!'s parts are meant to work together, so turning off the WebShield might be akin to making it try to run the
Anti-malware Marathon with its hands tied behind its back. ;)

Thanks for your help.

Hermite15

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #24 on: April 22, 2011, 11:12:22 AM »
@Gargamel360 the web shield is a major and quite advanced feature, but it's not the main resident component in Avast. The core resident protection is the file shield, and having just it activated still protects your system pretty well, i.e. the FS doesn't need the web shield to run well ;)

Gargamel360

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #25 on: April 22, 2011, 11:16:16 AM »
@Gargamel360 the web shield is a major and quite advanced feature, but it's not the main resident component in Avast. The core resident protection is the file shield, and having just it activated still protects your system pretty well, i.e. the FS doesn't need the web shield to run well ;)
Oh, I don't mean to say he is naked without it.  Just shirtless. ;D

Just seems the too easy solution for a problem that shouldn't even be there, plus it isn't the safest option, so I hesitate to recommend it.

Hermite15

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #26 on: April 22, 2011, 11:22:48 AM »
I don't recommend it, I'm just saying that a system still benefits from the main resident protection in Avast when the web shield is off ;)

Hermite15

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #27 on: April 22, 2011, 03:59:06 PM »
I forgot to mention, another option that may help to speed up things while downloading (using a browser native downloader), is to deactivate "stream scanning" from the web shield advanced settings. This will prevent the shield from scanning just downloads, while these will still be scanned at disk level by the file shield.

jwall

  • Guest
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #28 on: April 22, 2011, 04:35:01 PM »
I forgot to mention, another option that may help to speed up things while downloading (using a browser native downloader), is to deactivate "stream scanning" from the web shield advanced settings. This will prevent the shield from scanning just downloads, while these will still be scanned at disk level by the file shield.

I can vouch that this works, no slow down that I can see, FYI.
That's "intelligent" stream scanning I untick.
« Last Edit: April 22, 2011, 04:39:03 PM by jwall »

Offline Zyndstoff (aka Steven Gail)

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2610
  • I can resist anything except temptation.
    • tex62
Re: Avast 6.0.1091 Cuts my internet speed in half with Web Shield On
« Reply #29 on: April 22, 2011, 09:50:51 PM »
When use speedtest.net, here are the results of the official jury:
with WS  on: 75 MB/s
with WS off: 75 MB/s

Known issue? Where?
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear