Author Topic: Network Shield Wont Turn On  (Read 8508 times)

0 Members and 1 Guest are viewing this topic.

Offline maburnside

  • Newbie
  • *
  • Posts: 2
Network Shield Wont Turn On
« on: May 02, 2011, 07:19:08 PM »
I am using Avast! free version -- it is updated to 6.0.1091 -- on Windows 7 64.

(Seemingly) At random, Avast noted me that the shield wasn't working. This was not upon an update. Fixing, Uninstall/Reinstall do not work. The button to "Fix it" and "Turn on" are enabled, as if I should be able to click them, but they do nothing. Note that only the Network Shield is not working.

When I try to turn them on I get a message dialog that assures me, "The following components could not be started: Network Shield."

I am at the end of my list of ideas of what to do or what could be wrong. Any help?

Offline Gargamel360

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2353
  • Memento Mori
Re: Network Shield Wont Turn On
« Reply #1 on: May 03, 2011, 02:44:21 AM »
Do you have any other security software installed on this pc?
Signature?  But I gots no pen....

Offline Rednose

  • Pirate
  • Avast √úberevangelist
  • Super Poster
  • *****
  • Posts: 1877
    • Nederlandstalig Avast! forum
Re: Network Shield Wont Turn On
« Reply #2 on: May 03, 2011, 02:49:24 AM »
Or, was there another AV installed before ??? And if so, how did you remove it ???

Greetz, Red.
OS: Win 7 x64 SP1 / Vista x32 SP2 / Ubuntu 14.04.1 / iOS 8.1.3  Real TimeAIS  MBAM Premium  WinPatrol Plus  CryptoPrevent  On Demand: HitmanPro  Secunia PSI  FileHippo Update Checker  Backup: Win 7 Image / Acronis True Image Home  Proxy: ASL  Other VPN's  Socks 5  Tor.

Offline maburnside

  • Newbie
  • *
  • Posts: 2
Re: Network Shield Wont Turn On
« Reply #3 on: May 04, 2011, 09:44:27 PM »
I figured it out and if anyone else gets a similar problem, this is how it was fixed:

Left over registry keys from uninstalling Avast corrupted the fresh install. To avoid this, I used "Fix Issues" with CCleaner to clean my registry after uninstalling and before reinstalling. I don't know what caused Avast to stop working in the first place, but if an uninstall is necessary, don't forget to clean the registry! Everything is fine now.

Thanks for trying to help.

Offline Gargamel360

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2353
  • Memento Mori
Re: Network Shield Wont Turn On
« Reply #4 on: May 04, 2011, 09:54:51 PM »
Ok, thanks for posting back.
Signature?  But I gots no pen....

Offline CareyV

  • Newbie
  • *
  • Posts: 1
Re: Network Shield Wont Turn On
« Reply #5 on: December 29, 2012, 06:54:30 PM »
I had this problem when I updated to Windows 8.  Simply run the uninstall utility in Windows and "repair".  That fixed mine (in Windows 8 you right click on the Avast app and click uninstall.  That will take you to the uninstall program section).

Offline CraigB

  • Avast √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 9001
Re: Network Shield Wont Turn On
« Reply #6 on: December 29, 2012, 07:01:18 PM »
I had this problem when I updated to Windows 8.  Simply run the uninstall utility in Windows and "repair".  That fixed mine (in Windows 8 you right click on the Avast app and click uninstall.  That will take you to the uninstall program section).
As the original OP was on Win7 then that would be a different problem to your win8 plus this topic is a year and a half old and Win 8 wasn't even around then ;)

Please take note of the date of threads before posting.