Author Topic: Automatic updating with avast pro  (Read 3012 times)

0 Members and 1 Guest are viewing this topic.

bassmadrigal

  • Guest
Automatic updating with avast pro
« on: October 12, 2004, 08:59:04 AM »
I have a high-speed connection and have not recieved an update for avast since 10-6-04. It has worked in the past. I do have zonealarm and content control in Internet Explorer enabled but have disabled both to no avail.

I have tried manually updating the database through the program, but the screen will just sit there. I have had errors saying it cannot connect to the server (can't remember the exact error).

I am really lost by this. I have tried everything I can think of but to no avail.

Just in case... Windows XP Pro SP1a, and I do have NAV 2003 bundled with Systemworks installed but all instances of resident protection are turned off. (I use other features of Systemworks and have been too lazy to remove NAV) Liveupdate works with no problems. I do not have any entries in my HOSTS file and I only have websites in my deny in IE that Spybot put there through immunizations. Adaware and Spybot have both been run along with Hijack This all up to date and all updaters working properly.

I cannot seem to find any reason why this would not work but it is not, so I hope I can get some help from the forum members here.

Thanks in advance.

PS If you need any more info on my system just ask

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87085
  • No support PMs thanks
Re:Automatic updating with avast pro
« Reply #1 on: October 12, 2004, 05:35:04 PM »
Even with the NAV resident protection switched off, the entries in registry, etc. still exist and avast doesn't know if at some point after avast is loaded NAV is also loaded. So to avoid any possible conflict with two AV resident scanners avast, usually doesn't load.

Is the avast icon on your system tray and in the task manager?

Norton's NAV doesn't co-exist well with other AVs and is deeply embedded in your system, I think that you will have to bit the bullet and get rid of it properly.

This however, seems a surprise since you have at one point been able to receive auto updates or was this just your initial update?

Have you checked the firewall logs and avast's logs to see if there is anything there that might help identify the cause? Do a manual update and then check the logs to see what is happening. Zonealarm needs to allow avast.setup in order to update (see my outpost firewall entry for the latest update).

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

bassmadrigal

  • Guest
Re:Automatic updating with avast pro
« Reply #2 on: October 12, 2004, 06:59:46 PM »
I originally installed avast on 9-20 and recieved updates through 10-06. As far as I am aware there were no added programs or any taken off.

Zonealarm did have the correct configuration but just in case I shutdown the firewall to test it. I also have Internet Explorers content advisor setup but just in case I disabled that too.

Yes the Avast Icon is in the system tray and in the taskmanager.

Current Avast processes:
ashDisp.exe
ashMaiSv.exe
aswUpdSv.exe
ashServ.exe

I do have some errors in the log files of Avast under the warning section. They read:
1. Function setifaceUpdatePackages() has failed. Return code is 0x000004C7, dwRes is 000004C7.
2. Function setifaceUpdatePackages() has failed. Return code is 0x20000006, dwRes is 20000006.
3. An error has occured while attempting to update. Please check the logs.

I have tried manual updates but that did not work either. To me it seems like the program is not able to connect to the server but I see no reason it should not be able to connect.

I tried uninstalling Norton Systemworks along with removing C:\Program Files\Common Files\Symantec Shared; C:\Program Files\Norton Systemworks; C:\Program Files\Symantec

I also ran two registry doctors to cleanup any orphaned keys.

I am out of solutions. I even removed and reinstalled avast with doing registry cleaners. ???

Again anyhelp would be great.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31196
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:Automatic updating with avast pro
« Reply #3 on: October 12, 2004, 07:13:22 PM »
From kubecj:
Quote
0x20000006 is HTTP_ERROR. So either
1) your proxy is misconfigured (can you use web browser or wget or anything from the machine)?

2) you were unlucky to use iavs.cz mirror at the moment it was down

And for the other one have a look HERE or HERE

Just a little searching can do a lot ;)
« Last Edit: October 12, 2004, 07:17:23 PM by Eddy »

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87085
  • No support PMs thanks
Re:Automatic updating with avast pro
« Reply #4 on: October 12, 2004, 07:27:35 PM »
All though it would appear that you may be experiencing connection problems, to be unlucky for 6 days seems strange.

As a temporary measure, you can download a manual vps update file from here

Hopefully your connection problems will get resolved with the help of Eddy's search of the forums and the links he posted.

There is a wealth of information available to all, it just takes a little finding.
« Last Edit: October 12, 2004, 07:31:19 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security