Author Topic: Problem Updating Avast  (Read 5311 times)

0 Members and 1 Guest are viewing this topic.

Offline YamiAtomsk

  • Newbie
  • *
  • Posts: 6
Problem Updating Avast
« on: May 08, 2011, 10:28:00 PM »
Can someone please help me!?

My Avast won't let me update!  It keeps saying that the "package is broken" and it wont update.

The version I have is 110508-0

Can someone please tell me what wrong!?  I'm scared I might have a virus or something. 

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: Problem Updating Avast
« Reply #1 on: May 08, 2011, 10:31:15 PM »
Please, upload (attach) the avast log:
C:\ProgramData\AVAST Software\Avast\log\Setup.log
or C:\Program Files\Alwil Software\Avast5\Setup\setup.log

If the file is too big for the forum, post the last 400-500 lines of it.
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83925
  • No support PMs thanks
Re: Problem Updating Avast
« Reply #2 on: May 08, 2011, 10:40:15 PM »
My Avast won't let me update!  It keeps saying that the "package is broken" and it wont update.

The version I have is 110508-0

- Try a repair of avast. Add Remove programs, select 'avast! Anti-Virus,' click the Change/Remove button and scroll down to Repair, click next and follow.

Vista, win7 - Repair of avast. Control Panel, Programs & Features, uninstall a program, select 'avast! Anti-Virus,' click the Change/Remove button and scroll down to Repair, click next and follow.

You may need to reboot after the repair.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline YamiAtomsk

  • Newbie
  • *
  • Posts: 6
Re: Problem Updating Avast
« Reply #3 on: May 08, 2011, 10:47:19 PM »
It wouldn't let me repair it and it said I should get the "full update"

Here is the last part of the log

15:28:23 min/gen  Started: 08.05.2011, 15:28:23
15:28:23 min/gen  Running setup_ais-443 (1091)
15:28:23 nrm/sys  Operating system: Windows 7 ver 6.1, build 7600, sp 0.0
15:28:23 nrm/sys  Memory: 49% load. Phys:927104/1833392K free, Page:2590436/3666784K free, Virt:2058212/2097024K free
15:28:23 vrb/sys  Computer WinName: DALTON-PC
15:28:23 min/sys  Windows Net User: SYSTEM
15:28:23 min/gen  Cmdline: /downloadpkgs /noreboot /silent /session "9" 
15:28:23 vrb/gen  DldSrc set to inet
15:28:23 vrb/gen  Operation set to INST_OP_UPDATE_GET_PACKAGES
15:28:23 min/gen  Old version: 443 (1091)
15:28:23 vrb/reg  Deleted registry: Software\AVAST Software\Avast\UpdateReady
15:28:23 nrm/sys  Using temp: C:\windows\TEMP\_asw_aisI.tm~a04228 (147071M free)
15:28:23 nrm/gen  SGW32AIS::CheckIfInstalled set m_bAlreadyInstalled to 1
15:28:23 nrm/int  SYNCER: Agent=Syncer/5.00 (ais-1091;p)
15:28:23 vrb/sys  Computer DnsName: Dalton-PC
15:28:23 vrb/sys  Computer Ip Addr: 192.168.1.40
15:28:23 nrm/sys  Installed in: C:\Program Files\Alwil Software\Avast5 (147071M free)
15:28:23 nrm/int  SYNCER: Type: use IE settings
15:28:23 nrm/int  SYNCER: Auth: another authentication, use WinInet
15:28:23 vrb/pkg  Part prg_ais-443 is installed
15:28:24 vrb/pkg  Part vps_win32-11050800 is installed
15:28:24 vrb/pkg  Part setup_ais-443 is installed
15:28:24 vrb/pkg  Part jrog-a7 is installed
15:28:24 vrb/pkg  Part jrog2-1f1 is installed
15:28:24 vrb/gen  LoadState: Edition=1
15:28:24 min/gen  Old version: 443 (1091)
15:28:24 vrb/fil  SetExistingFilesBitmap: 890->384->384
15:28:24 min/gen  GUID: 479da54c-699f-42de-a8c6-b0fe46d020b6
15:28:24 nrm/gen  Server definition(s) loaded for 'main': 297 (maintenance:0)
15:28:24 nrm/gen  SelectCurrent: selected server 'Download336 AVAST5 Server' from 'main'
15:28:24 nrm/int  SYNCER: Type: use IE settings
15:28:24 nrm/int  SYNCER: Auth: another authentication, use WinInet
15:28:24 dbg/gen  Entered SetupProcessAIS::Do( INST_OP_UPDATE_GET_PACKAGES )
15:28:24 dbg/gen  Entered SetupProcessWin32Avast::Do( INST_OP_UPDATE_GET_PACKAGES )
15:28:24 dbg/gen  Entered SetupProcessWin32::Do( INST_OP_UPDATE_GET_PACKAGES )
15:28:24 dbg/gen  Entered SetupProcess::Do( INST_OP_UPDATE_GET_PACKAGES )
15:28:24 nrm/int  SYNCER: Agent=Syncer/5.00 (ais-1091;p)
15:28:25 nrm/int  Used server: http://109.123.114.58/iavs5x
15:28:25 min/fil  GetFileWithRetry: servers.def.vpx downloaded .
15:28:25 min/fil  servers.def.vpx not changed, 1302794162
15:28:25 nrm/gen  Server definition(s) loaded for 'main': 297 (maintenance:0)
15:28:25 nrm/gen  SelectCurrent: selected server 'Limelight 002 AVAST5 Server' from 'main'
15:28:25 nrm/int  SYNCER: Type: use IE settings
15:28:25 nrm/int  SYNCER: Auth: another authentication, use WinInet
15:28:25 nrm/int  Used server: http://ll002.avast.com/iavs5x
15:28:25 min/fil  GetFileWithRetry: prod-ais.vpx downloaded .
15:28:25 min/fil  prod-ais.vpx not changed, 1304880697
15:28:25 min/pkg  LoadProductVpu: C:\Program Files\Alwil Software\Avast5\Setup\prod-ais.vpx
15:28:25 min/pkg  ERROR: Unable to verify prod-ais.vpx, error 0x2000000B
15:28:25 min/pkg  LoadAllDefs failed 0x20000011
15:28:25 vrb/pkg  FilterOutExistingFiles: 384 & 384 = 0
15:28:25 vrb/pkg  FilterOutExistingFiles: 384 & 384 = 0
15:28:25 min/gen  m_bOperationDidSomething 384/384/0

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83925
  • No support PMs thanks
Re: Problem Updating Avast
« Reply #4 on: May 08, 2011, 10:48:47 PM »
Use this option then - Avast! Manual Virus Definitions Update Download - avast! Virus Definitions Update - Manual Download VPS Update (virus definitions, vpsupd.exe, approx 39.5MB). - Save the file to your hard disk, locate where you saved it and double click it and that should carry out the virus definitions update.

Note: Ignore the file name in the images of the page that is displayed after clicking the download link, they are for the main program, not for vpsupd.exe which will be downloaded.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline YamiAtomsk

  • Newbie
  • *
  • Posts: 6
Re: Problem Updating Avast
« Reply #5 on: May 08, 2011, 10:53:43 PM »
Okay I did that but it said that VPS is already up to date.  But when I check avast it still says that it hasn't updated. 

Offline YamiAtomsk

  • Newbie
  • *
  • Posts: 6
Re: Problem Updating Avast
« Reply #6 on: May 08, 2011, 11:00:26 PM »
Wait.  Was I supposed to download the one for 5 & 6 or the one for 4?

Offline Nesivos

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1352
  • Artists Rendering of New Pauley Pavilion @ UCLA
Re: Problem Updating Avast
« Reply #7 on: May 08, 2011, 11:02:12 PM »
Can someone please help me!?

My Avast won't let me update!  It keeps saying that the "package is broken" and it wont update.

The version I have is 110508-0

Can someone please tell me what wrong!?  I'm scared I might have a virus or something. 

Strange post by the OP

It seems to be that the current vd is 110508-0

So why would it update this?
OS: W7-SP1, Security: AIS 7, SAS Pro, WinPatrol Plus Network:2 Dell 570MT x64 1 Dell 660 Desktop with 8GB RAM Default Browser & Email: Firefox & Thunderbird latest Betas

Offline YamiAtomsk

  • Newbie
  • *
  • Posts: 6
Re: Problem Updating Avast
« Reply #8 on: May 08, 2011, 11:07:02 PM »
Can someone please help me!?

My Avast won't let me update!  It keeps saying that the "package is broken" and it wont update.

The version I have is 110508-0

Can someone please tell me what wrong!?  I'm scared I might have a virus or something. 

Strange post by the OP

It seems to be that the current vd is 110508-0

So why would it update this?


It is?  Then why am I getting notifications that Avast did not update successfully?


Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83925
  • No support PMs thanks
Re: Problem Updating Avast
« Reply #9 on: May 08, 2011, 11:43:47 PM »
Wait.  Was I supposed to download the one for 5 & 6 or the one for 4?

You are using avast6 so it should be the one for 5/6.

If that doesn't resolve it you are looking at a reinstall.

From your attached image it is a sync problem and that is what the repair has resolved in the past, so first try a reboot and see if that resolves it. If not then try the repair again and reboot, other wise the reinstall.
« Last Edit: May 08, 2011, 11:46:51 PM by DavidR »
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline YamiAtomsk

  • Newbie
  • *
  • Posts: 6
Re: Problem Updating Avast
« Reply #10 on: May 09, 2011, 01:01:33 AM »
Okay I've re-installed it and everything.

Only now the program won't work at all.  It doesn't seem to be turned on.

Every time I try to register it, it says that there is an error.

And every time I click Fix Now nothing happens





Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83925
  • No support PMs thanks
Re: Problem Updating Avast
« Reply #11 on: May 09, 2011, 01:06:28 AM »
Did you have another AV installed before avast, if so what was it and how was it removed ?

I think you are probably going to have to try a clean reinstall (this assumes you are using the avast free version:
- Download the latest version of avast, 6.0.1091 http://www.avast.com/free-antivirus-download and save it to your HDD, somewhere you can find it again (if you didn't save your last download). Use that when you reinstall.

- Download the avast! Uninstall Utility, aswClear.exe find it here and save it to your HDD (it has uninstall tools for both 5.x and 6.0.x).
  • 1. Now uninstall avast! (using add remove programs, if you can't do that start from the next step), reboot.
  • 2. run the avast! Uninstall Utility from safe mode, first for 5.x if previously installed and then for 6.0, once complete reboot into normal mode.
  • 3. install the latest version, reboot.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security