Author Topic: Having Trouble Updating Definitions Today  (Read 10274 times)

0 Members and 1 Guest are viewing this topic.

AtlantaGal

  • Guest
Re: Having Trouble Updating Definitions Today
« Reply #15 on: May 21, 2011, 05:30:52 PM »
Oh my gosh. That was easy. Thank you.

Can I keep that file and use it again if I get that error? 

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76037
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Having Trouble Updating Definitions Today
« Reply #16 on: May 21, 2011, 06:10:12 PM »
1. Oh my gosh. That was easy. Thank you.
2. Can I keep that file and use it again if I get that error? 

1. You're welcome..!
2. No, you will have to download it again, as it changes every day. But the link will stay the same, so you can bookmark it, if you should ever need it again.
W8.1 [x64] - Avast Free AV 23.3.8047.BC [UI.757] - Firefox ESR 102.9 [NS/uBO/PB] - Thunderbird 102.9.1
Avast-Tools: Secure Browser 109.0 - Cleanup 23.1 - SecureLine 5.18 - DriverUpdater 23.1 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89033
  • No support PMs thanks
Re: Having Trouble Updating Definitions Today
« Reply #17 on: May 21, 2011, 06:12:49 PM »
It isn't a tool to fix as such but the complete virus database, which would be likely to resolve any update issue you might have (corrupt database element possibly).

So it is best if having followed the first steps, manual update, avast repair and that doesn't work, hen download the latest full virus database.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

AtlantaGal

  • Guest
Re: Having Trouble Updating Definitions Today
« Reply #18 on: May 21, 2011, 09:35:26 PM »
But David, since this is a fresh install of only several hours how would I continue to get a corrupt database?  I think it's unreasonable to have to uninstall and reinstall monthly (which is pretty much what's been going on as of late). Don't you agree?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89033
  • No support PMs thanks
Re: Having Trouble Updating Definitions Today
« Reply #19 on: May 21, 2011, 09:54:30 PM »
You shouldn't have to what you have experienced is far from normal.

I really have no idea why it has happened (or if it were database corruption, that has to be an educated guess), if it were a regular occurrence/bug then there would be much more activity on the forums.

I have no idea what you mean by this "I keep getting 3S, 4S, etc. messages" What is 3S and 4S ?

Getting this invalid signature message means that when avast tries to validate the downloaded incremental virus database update it is failing validation. So something is messing with the actual download as it isn't all being received and I have no idea why that is (poor internet connection). But I don't have any way of testing that.

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

AtlantaGal

  • Guest
Re: Having Trouble Updating Definitions Today
« Reply #20 on: May 22, 2011, 01:12:21 AM »
Sometimes when I manually update after getting a "database can't be updated" red popup, I click update to run the download and it begins to. After a few seconds it quits and the status message becomes 3s or 4s or 6s, etc. The download doesn't work. I'm assuming the "s" means seconds and the download is timing out for some reason.  I'm sorry I can't be more specific, but I'm really at a loss as to what is happening. Also I'm perplexed as to why I have so much trouble when 4.0 and 5.0 Avast worked pretty flawlessly for me on two different machines with two different OS for years.

My other random issues are invalid signature when trying to update definitions. And sometimes upon start-up Avast gets stuck and won't start (it has the red x in the system tray icon).  The latter happened in fact just after I used the vpsupd.exe and restarted a little while later.

I have cable internet connection through Time Warner. There doesn't seem to be issues with it. It's better than my old Bell South DSL.


Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89033
  • No support PMs thanks
Re: Having Trouble Updating Definitions Today
« Reply #21 on: May 22, 2011, 01:47:15 AM »
For some reason you aren't able to connect to the update servers and it normally cycles through a number of them trying to update.

Is this the image/pop-up you get and if so what happens if you click the Update now link in the popup ?

This is usually failed internet connection or something blocking the update. Now the topic appears to have gone through the normal culprits:

Firewall, you say you haven't got one, at the very least you have the OS firewall and the XP firewall has zero outbound protection so shouldn't be getting in the way.

Security programs, MalwareBytes AntiMalware also shouldn't get in the way and isn't something that I heard of in the forums. Have you ever had another anti-virus installed on this system ?

Since you have reinstalled you should check the avastUI, Settings, Updates and ensure that they are set to match your connection method and also that You don't use a proxy. See image2 as these are what you should have as they reflect your connection method (and aren't the default settings). Unless of course you do use a proxy to connect to the internet ?

I would like hope that now you have things working that it should remain that way.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

SafeSurf

  • Guest
Re: Having Trouble Updating Definitions Today
« Reply #22 on: May 22, 2011, 10:34:22 AM »
@ David, I've already done that troubleshooting with the OP, that is why I suggested that the OP submit a mini-dump file as there may be something else in the machine conflicting since this has been ongoing for several versions on an intermittent (more on than off).  I was trying to get to the root core of the problem.

AtlantaGal

  • Guest
Re: Having Trouble Updating Definitions Today
« Reply #23 on: May 22, 2011, 12:04:01 PM »
Yes, that's the red pop up I sometimes get when the definitions won't auto update either at start up or during an update attempt during the day.

Your second image, I don't have anything checked under "update parameters," but I do have Direct Connection No Proxy selected.  Is that ok?

You're right, the standard Windows Firewall is running and it would be whatever standard settings are present during original OS install.  I meant that I don't have anything additional installed or running nor have I tampered with what's in Windows.

This XP machine has only ever had Avast. I'm not positive, but I believe the release was on some middle version of 5.0 when this machine was built.  Again, I am not positive of that since it was awhile ago.  Malwarebytes was added less than a year ago when Avast didn't catch a virus that was in a banner advertisement.  (I was already having some difficulties with Avast before that virus, btw.  And Malwarebytes got rid of it easily)

Could a graphics card driver conflict be causing or at least perpetuating some of this?  I did start having an issue with my graphics card after a driver update (my computer will restart itself sometimes if I have too many browser tabs or too many graphic programs open editing photography).  Please note that I was already having problems with Avast PRIOR to that graphics driver update though (it's one of the reasons I did update the driver in the first place).  I've been trying to fix the graphics driver issue, but so far have not been able to.

Everything with Avast did update fine this morning upon start-up.


AtlantaGal

  • Guest
Re: Having Trouble Updating Definitions Today
« Reply #24 on: May 22, 2011, 12:12:16 PM »
@ David, I've already done that troubleshooting with the OP, that is why I suggested that the OP submit a mini-dump file as there may be something else in the machine conflicting since this has been ongoing for several versions on an intermittent (more on than off).  I was trying to get to the root core of the problem.


The mini dump thing was a little too much for me to consider yesterday since my stress level was bordering on high.  I'll look into your instructions again this week and see if I can figure out how to do that.  I would like to identify and fix the problem without having to wipe my hard drive and reinstall everything fresh.

SafeSurf

  • Guest
Re: Having Trouble Updating Definitions Today
« Reply #25 on: May 22, 2011, 12:28:50 PM »
Your second image, I don't have anything checked under "update parameters," but I do have Direct Connection No Proxy selected.  Is that ok?
Yes...see my Post #4 as to how you connect to the Internet.  You need to check off based on how you connect to the Internet if it is not the default setting.

You may want to consider at some point a 2-way firewall for better protection since the XP firewall offers very little protection if any.

If you are having a problem with the graphics card, this will show up in the mini-dump for analysis.  You do not need to do the full uninstall/install at this time.  If you want to find out if this is the problem, then just follow the instructions I gave you for the mini-dump.  If this is stressing you out too much right now, then just keep this in the back of your mind.

I'm glad you were able to get your update this morning.  :)

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76037
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Having Trouble Updating Definitions Today
« Reply #26 on: May 22, 2011, 01:17:20 PM »
Everything with Avast did update fine this morning upon start-up.

Good. :)
W8.1 [x64] - Avast Free AV 23.3.8047.BC [UI.757] - Firefox ESR 102.9 [NS/uBO/PB] - Thunderbird 102.9.1
Avast-Tools: Secure Browser 109.0 - Cleanup 23.1 - SecureLine 5.18 - DriverUpdater 23.1 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89033
  • No support PMs thanks
Re: Having Trouble Updating Definitions Today
« Reply #27 on: May 22, 2011, 03:23:17 PM »
Everything with Avast did update fine this morning upon start-up.

Hopefully it will remain that way  8)
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

AtlantaGal

  • Guest
Re: Having Trouble Updating Definitions Today
« Reply #28 on: May 22, 2011, 03:34:11 PM »
Everything with Avast did update fine this morning upon start-up.

Hopefully it will remain that way  8)

LOL, I'm not going to hold my breath.

Appreciate all the help everyone!

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76037
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Having Trouble Updating Definitions Today
« Reply #29 on: May 22, 2011, 10:03:35 PM »
Appreciate all the help everyone!

NP, AtlantaGal..! :)
W8.1 [x64] - Avast Free AV 23.3.8047.BC [UI.757] - Firefox ESR 102.9 [NS/uBO/PB] - Thunderbird 102.9.1
Avast-Tools: Secure Browser 109.0 - Cleanup 23.1 - SecureLine 5.18 - DriverUpdater 23.1 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0