Author Topic: Problems installing avast! server  (Read 8593 times)

0 Members and 1 Guest are viewing this topic.

rjhat3

  • Guest
Problems installing avast! server
« on: October 15, 2004, 06:33:30 PM »
I uninstalled norton today and installed avast! 4 sbs. An error occured while starting avast- virus chest server is not running. RPC communication failed. I havent found anything yet in help section to setup a chest, if thats even what I need to do. Anyone know what should be done?

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Problems installing avast! server
« Reply #1 on: October 15, 2004, 06:35:06 PM »
Check Control Panel ->Administrative Tools -> Services.
Is the avast antivirus service running? If not, can it be started?

BTW this is the NT4 server?
Haven't you considered updating it to (at least) Win2K?


Thanks
vlk
If at first you don't succeed, then skydiving's not for you.

rjhat3

  • Guest
Re:Problems installing avast! server
« Reply #2 on: October 15, 2004, 06:41:11 PM »
Yes, this is the windows nt 4 system. When i go to services and try to start avast, it say avast could not be started-logon failure. any ideas?

rjhat3

  • Guest
Re:Problems installing avast! server
« Reply #3 on: October 15, 2004, 06:46:01 PM »
By the way, just incase it helps, when starting service, that error number is 1069

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Problems installing avast! server
« Reply #4 on: October 15, 2004, 10:13:01 PM »
Well that means the password for the account you were specifying during the avast setup was probably not correct.

Change the log on details (user name/password) on the Log On tab of the service's properties.


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

rjhat3

  • Guest
Re:Problems installing avast! server
« Reply #5 on: October 16, 2004, 01:36:00 AM »
Im confused. The password that i entered in the setup is used where? I havent got avast services to start yet. the only thing i have gotten to work is the advanced user interface. From there I can scan any drive, but i cant update the antivirus definitions. It just sits there with both percentages at zero. Im guessing that this is because the service isnt actually running. A single left click on avast icon results in a failure saying it cant be started.  I have viewed the log and all errors refer to the chest saying that the chest server is not running (also due to a failed service?) There are three entries in the services tab under control panel related to avast that I can see. Two are running but avast server is not. Does any of this help?

thanks,
Rodney

rjhat3

  • Guest
Re:Problems installing avast! server
« Reply #6 on: October 16, 2004, 01:38:15 AM »

just to clarify, a single click on the avast icon in the quick start menu results in a failure

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Problems installing avast! server
« Reply #7 on: October 16, 2004, 03:16:39 PM »
Quote
Im confused. The password that i entered in the setup is used where?

It is used for the service. Each service in Windows runs under an account. It is either the LocalSystem account -- a special account that has unlimited local rights but no access to the network - or a regular (local or domain) account.

The avast service should ideally run under an account that has both local administrative rights and reasonable access to network resources (to enable on-access scanning of network shares).

The account under which a service runs can be configured in the service's properties. That's why I wanted you to review the properties of the "avast antivirus" service and make sure the username/password pair is specified correctly there.

Quote
just to clarify, a single click on the avast icon in the quick start menu results in a failure


So you get an error message? Can you post what is says, exactly? (or a screen shot)?

Thanks
Vlk

If at first you don't succeed, then skydiving's not for you.

rjhat3

  • Guest
Re:Problems installing avast! server
« Reply #8 on: October 18, 2004, 08:05:10 PM »
The error simply says "The operation cannot be completed"

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Problems installing avast! server
« Reply #9 on: October 18, 2004, 09:38:51 PM »
After clicking the avast tray icon, you get this error message?? I'm sorry to say that but this sounds quite unlikely to me...

Or not the tray icon?


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.