Author Topic: opendns incoming connection blocked  (Read 11734 times)

0 Members and 1 Guest are viewing this topic.

scrub

  • Guest
opendns incoming connection blocked
« on: June 15, 2011, 08:54:30 PM »
firewall is set to public/high risk zone since i am connected to a broadband/cable modem. upon looking to the logs, firewall blocked opendns incoming connection.

is there any way i could allow the said connection? if none, what are the problems i may encounter?

thanks

scrub

  • Guest
Re: opendns incoming connection blocked
« Reply #1 on: June 16, 2011, 01:05:12 PM »
hellloooo????????? anybody there?  ??? ??? ???

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: opendns incoming connection blocked
« Reply #2 on: June 16, 2011, 02:38:58 PM »
Does it change if you set the level to "Home"?
The best things in life are free.

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: opendns incoming connection blocked
« Reply #3 on: June 16, 2011, 05:40:54 PM »
Don't know why there is an "incoming" connection from OpenDNS to your computer, it should be outbound only I would think.

However, it's usually best to setup your DNS server on your gateway (your router) instead of on individual computers.  It's easier to manage that way, and you'll still have access to local resources (shared printers, folders, etc.).

Here's some information to setup OpenDNS on a router (hopefully you have one, otherwise I guess I'm wasting my breath): https://store.opendns.com/setup/device/router

More specific instructions might be available for your particular router here (if needed): https://store.opendns.com/setup/router/
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

scrub

  • Guest
Re: opendns incoming connection blocked
« Reply #4 on: June 16, 2011, 05:54:06 PM »
Does it change if you set the level to "Home"?

it's used to set to "work" and everything is fine, no blockings.

scrub

  • Guest
Re: opendns incoming connection blocked
« Reply #5 on: June 16, 2011, 05:57:10 PM »
Don't know why there is an "incoming" connection from OpenDNS to your computer, it should be outbound only I would think.

However, it's usually best to setup your DNS server on your gateway (your router) instead of on individual computers.  It's easier to manage that way, and you'll still have access to local resources (shared printers, folders, etc.).

Here's some information to setup OpenDNS on a router (hopefully you have one, otherwise I guess I'm wasting my breath): https://store.opendns.com/setup/device/router

More specific instructions might be available for your particular router here (if needed): https://store.opendns.com/setup/router/

sorry but i do not have a router. but i've read it somewhere here that it is best to set the firewall to PUBLIC if you are directly connected to the internet through a cable modem/broadband.

I guess the outbound connection is for the opendns updater.

beck

  • Guest
Re: opendns incoming connection blocked
« Reply #6 on: June 16, 2011, 06:11:40 PM »
I have DNS set to 4.2.2.1 and4.2.2.2 I get inbound from them on port 53 that are blocked. Too weird.

scrub

  • Guest
Re: opendns incoming connection blocked
« Reply #7 on: June 16, 2011, 06:19:46 PM »
I have DNS set to 4.2.2.1 and4.2.2.2 I get inbound from them on port 53 that are blocked. Too weird.

yup. and the remote addresses 208.67.222.222 and 208.67.220.220 inbound connections are blocked too!

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: opendns incoming connection blocked
« Reply #8 on: June 16, 2011, 06:25:09 PM »
Does it work if you put an exception for the two OpenDNS IP addresses in the Avast firewall?

For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

scrub

  • Guest
Re: opendns incoming connection blocked
« Reply #9 on: June 16, 2011, 06:29:26 PM »
where can i find that?

anyway, here's a screen cap of my firewall log:


scrub

  • Guest
Re: opendns incoming connection blocked
« Reply #10 on: June 16, 2011, 06:31:45 PM »

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: opendns incoming connection blocked
« Reply #11 on: June 16, 2011, 06:49:33 PM »
Don't know where it is, as I don't use AIS but someone will surely be around to help you.  It might be in the settings menu. Just poke around, the new GUI is pretty easy to navigate.

Otherwise, I'll google "Avast add firewall exception" and probably be able to find the answer for you.
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87300
  • No support PMs thanks
Re: opendns incoming connection blocked
« Reply #13 on: June 16, 2011, 07:05:12 PM »
I'm not sure that will work as there isn't a process as such for OpenDNS just the changes to the browser DNS server.

Just had a look at the avast Help Center, Firewall, Expert settings, Friends and that appears to mention the magic word networks, so I don't know if that would allow you to enter the network IP address (the ones required for OpenDNS) in the Friends Internet In and Out.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.12.6044 (build 22.12.7758.768) UI 1.0.741/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: opendns incoming connection blocked
« Reply #14 on: June 16, 2011, 07:35:49 PM »
I'm not sure that will work as there isn't a process as such for OpenDNS just the changes to the browser DNS server.

Huh?  What do you mean by that? The "just the changes to the browser DNS server" part.

I don't see why he couldn't add an entry to the two static IP's of OpenDNS.  It's not just for the internet browser, I think the OP has the DNS entries hardcoded on his network adapter > TCP/IP properties.

Maybe I'm missing something here?
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum