Author Topic: Avast Version 4.5 problem  (Read 14978 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:Avast Version 4.5 problem
« Reply #15 on: October 28, 2004, 10:31:45 PM »
Eddy has suggested to him to put MailWasher into avast! exclude list, just because petrus2 doesn't want avast! to checks his mails while they are still in MailWasher...

Reading whole thread would help Technical, hehe  ;)

No, this is not the solution... I read that but I did not understand  ;)
To avoid scanning into MailWasher avast must be 'by-passed' and I don't think adding it to exclusion list will do that. It's a matter of configuration. On 4.1 version we could handle with email account settings and I'm quite sure avast! does not scan before MailWasher. Now, the email detection changed. The traffic of pop3/smtp/imap will be scanned by avast. Maybe MailWasher should be at another port than your email account  ;)
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87071
  • No support PMs thanks
Re:Avast Version 4.5 problem
« Reply #16 on: October 28, 2004, 11:11:17 PM »
Not sure if that is going to work, as a test I set one of my accounts in MW pro to use port 111 instead of the 110 and it came up with a connection error.
« Last Edit: October 28, 2004, 11:12:12 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

petrus2

  • Guest
Re:Avast Version 4.5 problem
« Reply #17 on: October 28, 2004, 11:13:35 PM »
I seem to be having trouble getting the exclusion of Mailwasher to work.  I tried entering the path of Mailwasher to the exclude list but that did not work. If anyone has any suggestions, please advise.   :)

What do you mean by 'did not work'?
Why should you add it to avast! exclusion list?

Because Mailwasher only retrieves a text preview of each email, no attachments, no scripts etc., so it should not be neccessary to scan these previews.  I receive a lot of email and it seems to me to be an unnecessay use of system resources and Avast to scan these previews.  Mailwasher cannot execute any malicious code or attachments.  Why WOULD I want Avast to scan these previews?

S.Z.Craftec

  • Guest
Re:Avast Version 4.5 problem
« Reply #18 on: October 28, 2004, 11:35:51 PM »
Exactly ! Very good point Petrus2... and also, same thing is happening with PopTray (wonderful freeware e-mail notification program). I switched from Mailwasher to PopTray. PopTray have message preview option (plain text only, not HTML... at least not yet), but it won't open any attachment... I really don't need avast! to spend some more additional time to check each message when I want to preview them...

Question for Alwil team:

Is it possible somehow to avoid avast! checking in our e-mail notification programs ? I really think that checking in my OE is more than enough. PopTray won't execute anything anyway...

Cheers !
« Last Edit: October 28, 2004, 11:36:40 PM by S.Z.C »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87071
  • No support PMs thanks
Re:Avast Version 4.5 problem
« Reply #19 on: October 29, 2004, 12:30:03 AM »
I too hope there is some way around this double virus checking (spam filter progs plus email client) if you use some form of spam checker (and it would appear that it will effect them all).

One of my email accounts attracts 60-100 spam emails per day and all I want to do is delete them from the server without intervention/virus check as they will never be downloaded to my OE inbox
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1885
    • AVAST Software
Re:Avast Version 4.5 problem
« Reply #20 on: October 29, 2004, 01:12:47 AM »
Currently guys you have no other option than to switch off automatic mail scanning in the avast4.ini file and configure your accounts in the same way as in previous versions.

Well, this feature (automatic mail scanning) is here to make the configuration process easier. In fact, when you do nothing but install it, all your mail trafic will be protected. There shoud be no double scan, we just scan connections leaving you PC to the internet. Localhost connections are NOT scanned (like those between Outlook and MailWasher or K9) - unless explicitly configured (127.0.0.1 : 110, username#pop3.myisp.net)

And there are no guarantees that those 'safe' anti spam solutions are not exploitable with viruses as well. For example displaying images was for long considered safe but today we have exploits for JPG images too. You never know what is waiting in the 'RichText' component used by antispam to display plain text.  :P

Anyway, when you have certain clients (eg. anti spam) which shouldn't be scanned and others which should it's better to stick with manual settings per mail account.

To switch off automatic mail scan, edit your avast4.ini file as follows:

[MailScanner]
AutoRedirect=0

Cheers
Lukas

S.Z.Craftec

  • Guest
Re:Avast Version 4.5 problem
« Reply #21 on: October 29, 2004, 01:20:20 AM »
No I won't do that... your explanation perfectly makes sense. Anyway, it doesn't take so much time to wait while avast! checks mails in my PopTray.

another thing - Lukor - we wanna see your face  ;D  ;D  ;D

We want the face, we want the face, we want the face !!!  ;D  ;D  ;D

We pretty much know all other Alwil members, so we would like to see you as well... I'm sure other would like the same thing...  ;) Right Technical ?
« Last Edit: October 29, 2004, 01:21:36 AM by S.Z.C »

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1885
    • AVAST Software
Re:Avast Version 4.5 problem
« Reply #22 on: October 29, 2004, 01:24:41 AM »
We want the face, we want the face, we want the face !!!  ;D  ;D  ;D

 :D ;D Ohh thats nice, well, let me have a look if I found some face of mine...
« Last Edit: October 29, 2004, 01:29:44 AM by lukor »

S.Z.Craftec

  • Guest
Re:Avast Version 4.5 problem
« Reply #23 on: October 29, 2004, 01:34:13 AM »
Great !!! It's much easier to talk to people when we can see the exact faces... we all pretty much already posted our ugly faces in some thread in Off-topic forums (there is a thread where everybody can post their pictures, can't recall the name...)

These forums are best that could ever happen to us... also, those new and not-well-virus informed users have the greatest place in the world where they can ask for, and what's even better, actually get help.

Long live Alwil team and avast!

Cheers !
« Last Edit: October 29, 2004, 01:34:52 AM by S.Z.C »

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1885
    • AVAST Software
Re:Avast Version 4.5 problem
« Reply #24 on: October 29, 2004, 01:47:35 AM »
Thanks Craftec! You always prove why "avast! Evangelist" stands right under your name!  :-*

Good night for now.
Lukas.

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 47555
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re:Avast Version 4.5 problem
« Reply #25 on: October 29, 2004, 01:48:20 AM »
Thanks lukor
I'll also leave things simple. Played with the girations long enough in 4.1.
My ISP should be happy that the e-mail on their server is being scanned. ;D
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

S.Z.Craftec

  • Guest
Re:Avast Version 4.5 problem
« Reply #26 on: October 29, 2004, 01:52:17 AM »
Heheheh Bob... no one complained because that huge (in physical size) avatar yet ? I'm glad you like it...


Cheers !

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:Avast Version 4.5 problem
« Reply #27 on: October 29, 2004, 04:04:42 AM »
Lukor, sometimes we envy the ones who can work for Alwil  :D
Can you take a look into the avast4.ini file thread (Settings in my signature) and see if I posted it correct there into [MailScanner] section the value AutoRedirect=0?
Thanks, wellcome to the forum family  ;)

Great !!! It's much easier to talk to people when we can see the exact faces... we all pretty much already posted our ugly faces in some thread in Off-topic forums (there is a thread where everybody can post their pictures, can't recall the name...)

Brave post your picture here!  ;)

We pretty much know all other Alwil members, so we would like to see you as well... I'm sure other would like the same thing...  ;) Right Technical ?

Sure  8)
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87071
  • No support PMs thanks
Re:Avast Version 4.5 problem
« Reply #28 on: October 29, 2004, 02:54:05 PM »
Currently guys you have no other option than to switch off automatic mail scanning in the avast4.ini file and configure your accounts in the same way as in previous versions.

Well, this feature (automatic mail scanning) is here to make the configuration process easier. In fact, when you do nothing but install it, all your mail trafic will be protected. There shoud be no double scan, we just scan connections leaving you PC to the internet. Localhost connections are NOT scanned (like those between Outlook and MailWasher or K9) - unless explicitly configured (127.0.0.1 : 110, username#pop3.myisp.net)

And there are no guarantees that those 'safe' anti spam solutions are not exploitable with viruses as well. For example displaying images was for long considered safe but today we have exploits for JPG images too. You never know what is waiting in the 'RichText' component used by antispam to display plain text.  :P

Anyway, when you have certain clients (eg. anti spam) which shouldn't be scanned and others which should it's better to stick with manual settings per mail account.

To switch off automatic mail scan, edit your avast4.ini file as follows:

[MailScanner]
AutoRedirect=0

Cheers
Lukas

I realise the the automatic mail scanning is a great feature for the average user, who has difficulty with manual settings (you only have to see the amount of posts relating to this).

But I thought that the Internet Mail provider no longer worked or wasn't required with XP (in 4.5 beta), so how would manually setting email accounts work if Internet Mail provider isn't running to intercept email or you didn't run Mail Protection Wizard?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1885
    • AVAST Software
Re:Avast Version 4.5 problem
« Reply #29 on: October 29, 2004, 03:12:18 PM »
But I thought that the Internet Mail provider no longer worked or wasn't required with XP (in 4.5 beta), so how would manually setting email accounts work if Internet Mail provider isn't running to intercept email or you didn't run Mail Protection Wizard?

I've just replied in the other thread - http://forum.avast.com/index.php?board=11;action=display;threadid=8057;start=60#lastPost. Internet Mail provider will be still running. We only have a new way of leting it catch your mails.

Have a nice day,
Lukas