Author Topic: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)  (Read 13304 times)

0 Members and 1 Guest are viewing this topic.

Offline Pumpernikiel

  • Newbie
  • *
  • Posts: 3
This is actual repost of my post on Agnitum's Support Forum. I was going to rewrite this post but there isn't much sens to do it and I'm too lazy  ;). Here it goes, I hope that someone will help me with this  :)
-----
I'm using Outpost Firewall Pro since version 6.7 came out and I'm happy say that I haven't experienced any major problems with this software. Than came versions 7, 7.1 and finally 7.5. I must say that 7.5 release is real improvement in terms of performance especially for "Web Control" component (BTW Pop-up windows ware batter in previous releases ;-). As most users of OFP I run some AV software to complement OS security. The AV of my choice is... or was Avira's free anti virus. Few day ago they decided to release SP2 for their product with bundled toolbar form ASK.com... to make things short it was time to change AV to something else. After removal of Avira's AV I decided to install Avast! 6. Installation process went smoothly it was time to reboot. And then the horror begun... :-(. OFP (7.5) was busted by Avast installation. System tray shield icon for OFP was gray with "service not available..." or something similar. Avast worked fine. After an hour of searching in the internet i have found info that could solve this problem. It was a compability issue (at least i thought so back then) and all i needed to do is to add OFP to Avast exception's list + disable some option in behavior shield of Avast. After reboot there was no change. This time I've launched Process Explorer and found that acs.exe was consuming 50% o CPU all the time. This time i decided to boot into safe mode and use clean.exe for OFP, boot again (safe mode) use avast uninstall utility, boot again (safe mode) and use Avira registry cleaner utility. After another reboot to normal mode i ran avast installation before clean installation of OFP 7.5. Avast installed OK (reboot) but OFP didn't install process was faulty. Installation process went smoothly until it got to the point where ACS service was started and again acs.exe was 50% all the time and i have to kill whole OFP installation process tree. After reboot it was the same thing. Tray icon gray, acs.exe at 50%. After few hours of rebooting, uninstalling, cleaning etc. I came to last available option that could succeed and that was installing OFP in safe mode. To my surprise installation process stalled in exactly same way as in normal mode (starting acs.exe and 50% CPU usage). This time i have made a screen shot of the process installation tree and saved log files of OFP after killing whole process tree and after first reboot into normal mode. At that point I gave up and tried to downgrade to 7.1. There was no problems, installation went OK, and avast in running in background without problems (only file system shield is installed). I'm using Windows XP SP3.
-----

Offline Ashish Singh

  • Poster
  • *
  • Posts: 437
  • Proud to be an Indian
    • Quick Heal
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #1 on: July 06, 2011, 07:20:31 AM »
First install Outpost Firewall without spyware (do custom installation untick spyware only) then reboot and install avast.
Its that simple
Windows 7 Ultimate(32 bit), avast! free (always latest released or beta), Intel Core2Duo, 2GB RAM, Outpost Firewall Pro 7.5,IE 9,TuneUp Utilities 2011,Diskeeper 2011

http://www.incredibleindia.org 

Caution! Online world is full of man made Aliens

Offline nnoa110

  • Sr. Member
  • ****
  • Posts: 290
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #2 on: July 06, 2011, 07:43:33 AM »
You might also want to untick "Web Control" feature in addition to anti-spyware, as it is known to interfere with avast!'s Webshield.
Win 7 Home Premium SP1 64Bit/ Core i7 2630QM 2.0-2.9GHz/ 4GB RAM/ avast! Free AV 7.0.1474/ Outpost Firewall Pro 8.0/ MBAM PRO 1.70/ Sandboxie 3.76 Free

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11077
  • No support PM's thanks
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #3 on: July 06, 2011, 07:48:19 AM »
First install Outpost Firewall without spyware (do custom installation untick spyware only) then reboot and install avast.
Its that simple
I would say its better to install avast first then outpost, also untick web control and spyware.
Once outpost is installed and before rebooting add C:\Program Files\Agnitum\Outpost Firewall Pro\wl_hook.dll to the exclusions in avast file system shield, easyest to copy from here and paste straight to the exclusions, then reboot and make sure that all the avast processes in the application list are set to allow all.
No need to disable or add anything to the avast behaviour shield.
« Last Edit: July 06, 2011, 07:50:43 AM by craigb »

Offline Ashish Singh

  • Poster
  • *
  • Posts: 437
  • Proud to be an Indian
    • Quick Heal
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #4 on: July 06, 2011, 10:02:36 AM »
Well web control is an important feature and I myself is using it with avast free with no conflict at all since 2 year.
And if avast is first installed then this feature will not be there.
Web Control blocks referrer, ActiveX,Java Script,VB Script,ADS, + Many many more and that without conflicting with avast. I am using it and that's why recommending it. It also blocks private data going out of your PC to internet in any way by any application.

add Outpost Firewall Pro folder to exclusion or only wl_hook.dll file in the avast realtime protection exclusion.

Thanks
Ash
« Last Edit: July 06, 2011, 10:12:14 AM by Ashish Singh »
Windows 7 Ultimate(32 bit), avast! free (always latest released or beta), Intel Core2Duo, 2GB RAM, Outpost Firewall Pro 7.5,IE 9,TuneUp Utilities 2011,Diskeeper 2011

http://www.incredibleindia.org 

Caution! Online world is full of man made Aliens

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11077
  • No support PM's thanks
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #5 on: July 06, 2011, 11:05:02 AM »
Ashish Singh you know why the web control feature is disabled if you have avast installed first ? because it can conflict with avast  ::) A firewall should be exactly that ( a firewall ) the other restrictions you mentioned can be controled with your browser and av.
If you have been using outpost for two years then why did you need advice from DavidR in febuary for exclusions  ???

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3309
  • Avast shall conquer the whole world
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #6 on: July 06, 2011, 11:31:30 AM »
@Ashish you don't need Outpost web control because they both conflict with Avast webshields so Outpost web control is not required at all, when you install Avast first on your PC and then Outpost second it will automatically detected your Avast that Outpost won't install web control and anti-spyware at the installation but you still have to check it during the installation set-up.

So please removed Outpost web control if you don't believe me ask DavidR he's been using Outpost longer than me, and he has better experience and understanding how Outpost set-up correctly along side with Avast ;) 
« Last Edit: July 06, 2011, 11:36:57 AM by SpeedyPC »
ASUS G75VX-T4153H - Avast Premium v21.1.2449 - Avast SecureLine VPN - Avast Secure Browser - Avast Driver Updater - W8.1 64bit - Firefox 64bit - Thunderbird 64bit - MBAM Premium - Adguard Premium - CryptoPrevent Premium - Privacy Eraser - MCShield - WinPatrol PLUS - Macrium Reflect Home Edition

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84612
  • No support PMs thanks
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #7 on: July 06, 2011, 02:22:48 PM »
I will put it as plainly as I can.

First Agnitum Outpost Firewall Pro has never had an adverse effect on avast on my system and that is going back from version 3.0 through 7.5.

Second Outpost will detect Avast if you have it installed and ask for confirmation that you have it installed. When you acknowledge that it will offer to run in Compatibility mode, disabling the Web Control and Anti-Spyware (as avast has both covered) and to avoid conflict. Why otherwise would Outpost suggest it.

So that is why you should install avast 'first' followed by Outpost firewall pro 7.5. I would go a step further and suggest that you do a Custom Install (may be called expert install or words like that), Outpost will still detect avast, but you have greater control of what gets installed (not just disabled) so you should uncheck the Web Control and Anti-Spyware modules so they aren't installed.

Outpost during the installation would have you exclude the Outpost program folder, cheat and say you have as I don't feel it necessary to do this. I do make one exclusion in avast, File System Shield, Expert Settings, Exclusions and that is for C:\Program Files\Agnitum\Outpost Firewall Pro\wl_hook.dll and nothing else. I have had no problems in the past 7+ years like this
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3309
  • Avast shall conquer the whole world
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #8 on: July 06, 2011, 03:06:16 PM »
Outpost during the installation would have you exclude the Outpost program folder, cheat and say you have as I don't feel it necessary to do this. I do make one exclusion in avast, File System Shield, Expert Settings, Exclusions and that is for C:\Program Files\Agnitum\Outpost Firewall Pro\wl_hook.dll and nothing else.

DavidR is this correct see attachment ???
ASUS G75VX-T4153H - Avast Premium v21.1.2449 - Avast SecureLine VPN - Avast Secure Browser - Avast Driver Updater - W8.1 64bit - Firefox 64bit - Thunderbird 64bit - MBAM Premium - Adguard Premium - CryptoPrevent Premium - Privacy Eraser - MCShield - WinPatrol PLUS - Macrium Reflect Home Edition

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11077
  • No support PM's thanks
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #9 on: July 06, 2011, 03:12:30 PM »
I hope you dont mind me replying Speedy but yes that is the correct exclusion  :)

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3309
  • Avast shall conquer the whole world
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #10 on: July 06, 2011, 03:27:47 PM »
I hope you dont mind me replying Speedy but yes that is the correct exclusion  :)

Thanks just checking  ;)

Cause I forgot about this to add in the file system shields since I had Outpost install for a while when I removed Comodo FW.
ASUS G75VX-T4153H - Avast Premium v21.1.2449 - Avast SecureLine VPN - Avast Secure Browser - Avast Driver Updater - W8.1 64bit - Firefox 64bit - Thunderbird 64bit - MBAM Premium - Adguard Premium - CryptoPrevent Premium - Privacy Eraser - MCShield - WinPatrol PLUS - Macrium Reflect Home Edition

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84612
  • No support PMs thanks
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #11 on: July 06, 2011, 05:05:23 PM »
Outpost during the installation would have you exclude the Outpost program folder, cheat and say you have as I don't feel it necessary to do this. I do make one exclusion in avast, File System Shield, Expert Settings, Exclusions and that is for C:\Program Files\Agnitum\Outpost Firewall Pro\wl_hook.dll and nothing else.

DavidR is this correct see attachment ???

For me I have it excluded in all three columns, R, W and X, though as far as conflict goes X is probably the most important.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3309
  • Avast shall conquer the whole world
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #12 on: July 06, 2011, 05:50:39 PM »
Thanks DavidR ;)
ASUS G75VX-T4153H - Avast Premium v21.1.2449 - Avast SecureLine VPN - Avast Secure Browser - Avast Driver Updater - W8.1 64bit - Firefox 64bit - Thunderbird 64bit - MBAM Premium - Adguard Premium - CryptoPrevent Premium - Privacy Eraser - MCShield - WinPatrol PLUS - Macrium Reflect Home Edition

Offline Ashish Singh

  • Poster
  • *
  • Posts: 437
  • Proud to be an Indian
    • Quick Heal
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #13 on: July 07, 2011, 04:58:39 AM »
Ashish Singh you know why the web control feature is disabled if you have avast installed first ? because it can conflict with avast  ::) A firewall should be exactly that ( a firewall ) the other restrictions you mentioned can be controled with your browser and av.
If you have been using outpost for two years then why did you need advice from DavidR in febuary for exclusions  ???

Well I am using both avast with web shield and Outpost with Web Control without any conflicts. And I have asked agnitum support about conflicts and they said it does not conflict rather it is disabled because avast scans web pages and as per their forum request. But I find Web Control useful as if harmful elements will not be loaded in my browser then there is 0% chances of infection (if avast fails to detect some malicious elements).

Agnitum people have also given me tricks to enable web control if its disabled due to avast installation.

Although every people have their own point of view

Thanks
Windows 7 Ultimate(32 bit), avast! free (always latest released or beta), Intel Core2Duo, 2GB RAM, Outpost Firewall Pro 7.5,IE 9,TuneUp Utilities 2011,Diskeeper 2011

http://www.incredibleindia.org 

Caution! Online world is full of man made Aliens

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84612
  • No support PMs thanks
Re: Outpost Firewall Pro 7.5 killed by Avast! 6 installation (repost)
« Reply #14 on: July 07, 2011, 11:53:55 AM »
I honestly can't understand why you would go against the advice of Agnitum and its compatibility mode, however that is entirely your choice but I certainly wouldn't recommend it for all.

Why do you feel that you need tricks to enable both, the outpost web control really brings little to the party that isn't already covered by the web shield. By Agnitum people giving you the tricks, I take it you mean the outpostfirewall.com forum rather than official Agnitum support, if so they aren't Agnitum employees, but users.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security