Author Topic: Windows security center not recognizing Avast 6  (Read 3339 times)

0 Members and 1 Guest are viewing this topic.

Offline middlfam

  • Newbie
  • *
  • Posts: 1
Windows security center not recognizing Avast 6
« on: July 07, 2011, 10:28:52 PM »
I have tried ths solutions posted her (1.uninstall Avast and reinstall 2.delete repository in wbem) and nothing fixes the problem.  Windows security center in XP does not recognize Avast 6. I have all the latest service packs and fixes on XP.  This just started happening after I upgraded Avast yesterday.  What should I do to fix this?

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 65912
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Windows security center not recognizing Avast 6
« Reply #1 on: July 07, 2011, 11:13:24 PM »
XP SP3 installed..?
Which avast..? Which version..?
Other security related software..??
Win 8.1 [x64] - Avast PremSec 20.6.2420.BUC [UI.542] - CC 5.68 - EEK - FF ESR 68.11 [NS/AOS/uBO/PB] - TB 68.11 - SB/CP/SL/DU.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 83511
  • No support PMs thanks
Re: Windows security center not recognizing Avast 6
« Reply #2 on: July 07, 2011, 11:19:48 PM »
Try these:
Windows XP SP2, SP3 Start, Run, type cmd and click OK from the command prompt type 'rundll32 wbemupgd, RepairWMISetup' without the quotes and enter.

- And Or

If you are running Windows XP, Service Pack 2 or 3 you can use a single command to detect and repair a corrupted WMI Repository. To do so, type the following from the command prompt (note that the parameter UpgradeRepository is case-sensitive and must be typed exactly as shown):

rundll32 wbemupgd, UpgradeRepository

- OR
Quote
* Click Start, Run and type CMD.EXE

* Type this command and press Enter:

net stop wscsvc
net stop winmgmt

* Using Windows Explorer, rename the folder %windir%\System32\Wbem\Repository. (For example, %windir%\System32\Wbem\Repository_bad.). %windir% represents the path to the Windows directory, which is typically C:\Windows.

* Switch to Command Prompt window, and type the following and press ENTER after each line:

net start winmgmt
net start wscsvc

EXIT
Reboot

This one on rare occasions can be the culprit, if for some reason the environment variables get changed.
- Check system variables -
Quote
- Also this, check system variables - I found out why windows didn't recognized avast as my AV. It turned out that my Path environment variable had been messed up and it missed the "C:\Windows\System32\Wbem" part if you need to add that put a semi-colon ; after the last entry before you add the WBEM path part.


Control Panel, System, Advanced tab, Environmental Variables button, find the Path variable, select it, click Edit (careful don't change anything right now) and just check that the variable includes what is in my image, click to expand.
E:\Images\CapturedScreenPrint\system_variables_wbem.gif
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.6.2420 (build 20.6.5495.561) UI-1.0.541/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro