Author Topic: Left 4 Dead 2 performance problem  (Read 30944 times)

0 Members and 1 Guest are viewing this topic.

Offline bob.f

  • Newbie
  • *
  • Posts: 4
Re: Left 4 Dead 2 performance problem
« Reply #15 on: July 11, 2011, 03:37:41 PM »
Me either, until now! And actually L4D1 is still fine.

Offline antrox

  • Sr. Member
  • ****
  • Posts: 201
Re: Left 4 Dead 2 performance problem
« Reply #16 on: July 11, 2011, 07:22:30 PM »
slow down in L4D2 is back today! 100% Avast fault, because help turn off all screens. I didnt understand

Offline Hagbeard

  • Newbie
  • *
  • Posts: 1
Re: Left 4 Dead 2 performance problem
« Reply #17 on: July 11, 2011, 10:08:58 PM »
I'm having the exact same performance issues, but with Civilization 5.  Starting the game takes much longer than normal, loading a saved game takes upwards of 15 minutes (versus about 1 min. before), and the game hangs for 30 seconds at a time.  If I disable Avast everything runs smoothly.  This only started happening when I moved to Avast 6. 

Offline Sandbox

  • Newbie
  • *
  • Posts: 2
Re: Left 4 Dead 2 performance problem
« Reply #18 on: July 13, 2011, 10:45:12 AM »
Since updating to Avast 6.0.1203, the only way I can play Left 4 Dead 2 is if I turn my Avast protection off. Prior to this update, Left 4 Dead 2 was working fine.

Upon launching Left 4 Dead 2, I would get stuck at a "Completing installation... 1%" message until an "Incomplete Installation (#)" error would appear. The only way I could get passed the installation % message and launch the game was to disable Avast. Since the initial disabling of Avast, I no longer receive the "Completing installation... 1%" message or the "Incomplete Installation (#)" error.

While Playing With Avast On, Left 4 Dead 2 would immediately freeze upon load of a game mode and sound would get stuck in an infinite loop.

While Playing With Avast Off, Left 4 Dead 2 would run fine.

Although turning Avast off is an option, I really would prefer to have my Avast protection on while playing the game.

There are other people who also have this problem. Here is a link.
http://forums.steampowered.com/forums/showthread.php?t=1981345

Can someone please try to fix this problem?

Thanks in advance.

OS:
Windows XP SP3

Offline Ledjlale

  • Newbie
  • *
  • Posts: 1
Re: Left 4 Dead 2 performance problem
« Reply #19 on: July 13, 2011, 12:36:02 PM »
It's not only for Left For Dead 2.
I have this issue for all my games on Steam.
I have to deactivate Avast to "complete the installation" (like sandbox' post) or to play a multiplayer game (like DawnOfWar Retribution). There are no errors, no popup to warn me about that : games are just freeze.

A temporary solution would be to cancel the installation of the update and come back to another, but this option is not implemented by Avast. (an idea to develop?)
Need a quick fix!

OS: winXP service pack 3
« Last Edit: July 18, 2011, 12:18:05 PM by Ledjlale »

Offline sarkster

  • Newbie
  • *
  • Posts: 1
Re: Left 4 Dead 2 performance problem
« Reply #20 on: July 13, 2011, 03:13:06 PM »
Yes, this update messed up my online gaming through Steam. I disabled Avast from the menu for 10 minutes during the game and it started working and after 10 minutes when Avast powered up the game stopped working. I'm switching to another program since this update was broken.

Offline Pholover

  • Jr. Member
  • **
  • Posts: 55
Re: Left 4 Dead 2 performance problem
« Reply #21 on: July 14, 2011, 09:42:41 PM »
I'm having the same problem with Left 4 Dead 2 freezing when I try to pick up something and going into sound loop while frozen.  When avast is turned off it runs fine.  Like most users here I rather not turn it off.  What can be done to fix this while having avast on and without rolling back after this update?

Offline Gargamel360

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2346
  • Memento Mori
Re: Left 4 Dead 2 performance problem
« Reply #22 on: July 14, 2011, 10:28:16 PM »
I'm having the same problem with Left 4 Dead 2 freezing when I try to pick up something and going into sound loop while frozen.  When avast is turned off it runs fine.  Like most users here I rather not turn it off.  What can be done to fix this while having avast on and without rolling back after this update?
Hi

The trick is finding which part of Avast! is the trouble.  Do this by disabling specific shields one at a time, rather than just disabling all protection.  If Steam uses http (not sure how Steam works), I would start with the Web Shield.  Just remember to re-enable them when you are finished.
Signature?  But I gots no pen....

Offline TheCakeIsaLie

  • Jr. Member
  • **
  • Posts: 23
Re: Left 4 Dead 2 performance problem
« Reply #23 on: July 14, 2011, 11:19:19 PM »
Does anyone know how to locate previous version(6.0.1125) for rollback install ?

I looked on filehippo but only saw latest version. I saw some other places after searching(http://dsaloka.blogspot.com/2011/05/avast-internet-security-601125-2011.html ) but I am suspicious that these are cracked versions.

I don't like option of disabling virus protection I paid for so I can play games I paid for...

Offline Gargamel360

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2346
  • Memento Mori
Re: Left 4 Dead 2 performance problem
« Reply #24 on: July 15, 2011, 12:52:47 AM »
Does anyone know how to locate previous version(6.0.1125) for rollback install ?
Better you try my above suggestion, but if it comes to that, Filehippo does have the back versions, they are along the right sidebar.
Signature?  But I gots no pen....

Offline TheCakeIsaLie

  • Jr. Member
  • **
  • Posts: 23
Re: Left 4 Dead 2 performance problem
« Reply #25 on: July 15, 2011, 01:20:12 AM »
I found the same link at (http://www.filehippo.com/download_avast_antivirus/ ) but need to install
the Internet Security version that includes Firewall and Anti-spam. Will my license key enable Firewall and Anti-Spam  if I download the version at the link ?

Offline Gargamel360

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2346
  • Memento Mori
Re: Left 4 Dead 2 performance problem
« Reply #26 on: July 15, 2011, 01:40:40 AM »
Oh, inserting the key into free versions upgrades them to paid, if I remember correctly.  But it might also upgrade you to latest version.

No one has suggested reinstalling yet, so I suggest that in addition to what I mentioned earlier.  There are plenty of people here with the problem, but a couple popped in and said they had no problems at all, so if this happened to all of you after a program update, perhaps something went amiss with your update process.  Try reinstalling Avast!. 

Signature?  But I gots no pen....

Offline Sandbox

  • Newbie
  • *
  • Posts: 2
Re: Left 4 Dead 2 performance problem
« Reply #27 on: July 15, 2011, 08:22:41 AM »
These four Avast shields appear to be causing the problem:

1. File System Shield
2. Mail Shield
3. P2P Shield
4. IM Shield

For the game to be playable, you cannot have any of these shields enabled. If any of these shields are enabled, the game will freeze and get caught in an infinite sound loop.

It doesn't matter what the heuristics settings of each shield are set to either. Even if you lower the heuristics settings of the shields, the game will remain unplayable.

Offline weee

  • Newbie
  • *
  • Posts: 2
Re: Left 4 Dead 2 performance problem
« Reply #28 on: July 17, 2011, 08:19:43 AM »
I've got the same performance issue with version 6, now i'm rolling back to 5.0 hoping everything will be fine, please solve this problem as it happens to a lot of users

Offline Fisheh

  • Newbie
  • *
  • Posts: 1
Re: Left 4 Dead 2 performance problem
« Reply #29 on: July 17, 2011, 01:07:23 PM »
I am getting the same problem... i nearly gave up trying to update l4d2 coz it would always fail... untill i came across a forum about Avast 6 stopping L4d2 from updating...

then found out you have to disable Avast or in game if you press "TAB" or "E" the game would freeze!

Please Avast sort this out as i dont feel safe playing L4D2 with Avast off!  :-\