Author Topic: Avast! Net Client Service - service stops Microsoft Office docs from opening!  (Read 11711 times)

0 Members and 1 Guest are viewing this topic.

Offline Michael Due

  • Jr. Member
  • **
  • Posts: 24
Regarding:
avast! Security for Business

Hi.

Since we upgraded from ADNM and 4.8 client installations to avast! Security for Business we are having major problems opening Microsoft Office Documents when the Avast! Net Client Service is started.

It takes several minutes before a document opens unless we manually stop the Avast! Net Client service service from running.

HELP! We already install the client on all our 100 PCs in the Hotel.

Kind regards
Michael Due.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Are you sure it's the Avast Net Client service, and not the Avast! Antivirus service?

BTW what operating system are you using?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Michael Due

  • Jr. Member
  • **
  • Posts: 24
Hi Vlk.

Thnx for a fast reply.

I've done some more testing.:

1. Yes I'm sure its the "Avast! Net Client Service" Service that I have to stop in order for Microsoft Office documents to open at normal speed again (see screenshot below) :)

2. Stopping or starting the "avast! Antivirus" service does nothing in regards to this problem.

3. The majority of our PCs are running Windows XP Proffesional SP3 with Microsoft Office 2007 SP2 - all of these machines are having the problem after installing this new version instead of the old 4.8 Avast Client.

4. We have 3 Windows 7 Proffessional 32-bit PCs also running Microsoft Office 2007 SP2, there are no problems running "Avast! Net Client Service" or opening Microsoft Office documents on these 3 machines, so it would seem  the problem is only related to Windows XP Proffessional and Avast Business Protection.

5. Ive also tested with a machine running Windows XP Proffessional and Microsoft Office 2003. The problem is persistent on this machine also (so its not Microsoft Office 2007 related).


Offline jx

  • Jr. Member
  • **
  • Posts: 75
Hi Michael,

we'll be looking into this, but have not seen such issue during testing. Are there any office plugins/addins installed on the computer?

jx

Offline Michael Due

  • Jr. Member
  • **
  • Posts: 24
Hi.

Are there any office plugins/addins installed on the computer?
- Only our booking department are using an office plugin for templates,

But the problem is persistent on all of our Windows XP machines across the entire Hotel.
- Even those available to our visitors in our Internet Cafe area, residing on a totally different VLAN network and installed from a different/seperate Avast Server than the one we use for our Administrative PCs in the Administration, Booking, Reception and Kitchen etc.

- I've tried stopping a whole bunch of services running on my machine to check if anything at all other than the Avast! net client service could be stopped to solve the problem but no luck on that i'm afraid. Only stopping the ANCS service helps on the problem.

Found out 6 more things to note!:

1. There is no problem just starting a Microsoft Office programs alone.
- Problem is only residing when opening a document that would then start/open the office program and open up whatever was saved in the document.

2. If you open a Microsoft Office program (for instance Word) and then go Files -> Open and then choose to open a word document from within the Office program then there is no delay on opening the document.

3. There is no difference in opening a Microsoft Office Document saved on the Machine's local harddrive C: or opening a document from a mapped network drive.
- Both takes minutes to open with the ANCS service running.

4. Fully uninstalling, rebooting and reinstalling the Microsoft Office product did not change anything either (neither after reinstalling all of Microsoft Office updates and Service Packs).

5. If you fully uninstall Microsoft Office and then use Wordpad from Windows XP to open Word files (.doc) then there is no problem or delay in opening the document.

6. So far i haven't had any problems opening any other types of documents (PDF, pictures, saved e-mail files etc.)
« Last Edit: July 25, 2011, 01:27:31 PM by Michael Due »

Offline jx

  • Jr. Member
  • **
  • Posts: 75
Hello Michael, 

would you mind trying one of the following:

1) Unplug the network cable, wait a few seconds and then try if opening word document is still slow?

- or -

2) Find the avast5.ini file, change the "SBCServerPort" to a different value, save the ini file and restart the ANCS. Then try opening word document to see if it is still slow?
[Do not forget to change the setting back after this test]

Also another question, do you see the same behaviour when opening .DOC and .DOCX file?

Thanks

jx

Offline Michael Due

  • Jr. Member
  • **
  • Posts: 24
Hi.

Once again thnx for a fast reply.

1) Unplug the network cable, wait a few seconds and then try if opening word document is still slow?

It is still slow yes im afraid even with network cable unplugged.

2) Find the avast5.ini file, change the "SBCServerPort" to a different value, save the ini file and restart the ANCS. Then try opening word document to see if it is still slow?
[Do not forget to change the setting back after this test]


I tried changing it to different ports, nothing helped im afraid.

Also another question, do you see the same behaviour when opening .DOC and .DOCX file?


Yes its the same behaviour opening .doc, docx, .rtf, xls or any other document opened by microsoft office 2007.

But if I open a .doc by right clicking and choosing open with Wordpad then there is no problem it opens up right away.

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 72901
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Sorry to interrupt here...
But as this only happens on XP machines, could maybe Petr's second patch help here..??
http://public.avast.com/~kurtin/patches/
Win 8.1 [x64] - Avast PremSec 21.11.6787.IBC [UI.681] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.4 - SecureLine 5.14 - Driver Updater 21.4 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
It's already solved internally. Will be fixed soon.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Michael Due

  • Jr. Member
  • **
  • Posts: 24
Thnx alot vlk !!! Much much appreciated  :)

Great support and help i must say  :) :) :) :)

Kind regards
Michael

Offline impuls

  • Avast Reseller
  • Jr. Member
  • *
  • Posts: 42
It's already solved internally. Will be fixed soon.

Thanks
Vlk

Nice to hear that...I got the same problem with OpenOffice on Windows XP machines... ;)

Offline Michael Due

  • Jr. Member
  • **
  • Posts: 24
Hey guys.

Any idea on release time on fix yet?

- Reason I'm asking is the computers are so slow they really can't be used for anything microsoft office related.

And im going on summer vacation tomorrow (in about 30 hours)
- So I either gotta uninstall avast on all 100 PCs before that.
- or apply a fix that will solve the problem before I go :)

If you know the fix / program update won't be within the next 30 hours then please let me know also cause then I might as well start the roll-back for now :)

Kind regards
Michael

Offline sedina

  • Moderator
  • Sr. Member
  • *
  • Posts: 237
Hi, we should release program update on Monday/Tuesday. We still need a few days for fixing another problems to be sure that released version is OK.
Michael, is necessary to uninstall avast! from all computers? What about disabling
NetService on critical ones? If you don't need central administation, standalone avast! 6
will serve you well during your vacation. Then you will be able to update to fixed version.

thanks,
Pavel Sedina

Offline Michael Due

  • Jr. Member
  • **
  • Posts: 24
Hey Pavels.

Yeah I disabled it for now instead of uninstalling :)

I Put the following into the Networks Login-script that runs when PCs start in the house, I'll change that back to automatic and start service when im back from vacation and fix is out :)
- So for now its just stopped and disabled yes instead of uninstalled :) :)

run 'SC CONFIG "avast! Net Client Service" start= disabled'

run 'NET STOP "avast! Net Client Service"'

Take care guys ^^