Author Topic: Ubuntu Software Centre requires an valid Installed-Size control field  (Read 6731 times)

0 Members and 1 Guest are viewing this topic.

Gurnolla

  • Guest
Hello

Trying to install avast4workstation_1.3.0-2_i386.deb on a fresh install of ubuntu 11.04 desktop x32. Dell Inspiron 1501.

When I open the downloaded install file in the software centre i receive a "The Package is of bad quality" error, the details state "The package doesn't provide a valid Installed-Size control field. See Debian".

Is there a work around?

Tia

#Updating original post

I extracted the .deb archive and added "Installed-Size 40430" to the DEBIAN/control file. The ubuntu software centre now returns a number of file ownership errors.

I'll update again once the uid/gid issues are fixed.

Cheers
« Last Edit: August 01, 2011, 08:42:58 PM by Gurnolla »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Ubuntu Software Centre requires an valid Installed-Size control field
« Reply #1 on: August 02, 2011, 03:49:53 AM »
The workaround is just go ahead with the installation.
You would also need to register and use this for updating: http://forum.avast.com/index.php?topic=57775.0
The best things in life are free.

Gurnolla

  • Guest
Re: Ubuntu Software Centre requires an valid Installed-Size control field
« Reply #2 on: August 02, 2011, 08:05:46 AM »
The workaround is just go ahead with the installation.
You would also need to register and use this for updating: http://forum.avast.com/index.php?topic=57775.0

That did the trick, Thanks much!

Cheers

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Ubuntu Software Centre requires an valid Installed-Size control field
« Reply #3 on: August 02, 2011, 01:18:19 PM »
You're welcome. Feel free to come back any time you need help or just to change experiences 8)
The best things in life are free.