Author Topic: [SOLVED] Change website port  (Read 7873 times)

0 Members and 1 Guest are viewing this topic.

Offline avadas.de

  • Avast Reseller
  • Sr. Member
  • *
  • Posts: 259
    • avadas.de
[SOLVED] Change website port
« on: August 12, 2011, 10:47:32 AM »
Hi,

is there any recommendation on what to do, when you want to change the Default Websites port, if it is already required by another application on the server?
« Last Edit: August 30, 2011, 09:25:32 PM by lukas.hasik »
Feel welcome to also visit the German Avast Community Forums for support and discussions with other security specialists as well as beginners!

Avast 19.6.2383 German Release Notes

pascal.g

  • Guest
Re: Change website port
« Reply #1 on: August 12, 2011, 11:25:45 AM »
We had the same problem with IIS 6 on a server using Citrix that had the default port 80 reserved.
The easiest way we found to resolve this issue is to:

- Open a command prompt and type netstat -ano <- This will show you currently reserved ports, you should see port 80, among others. Take note of these, you cannot use them as an alternative for your Default Website
- Go to IIS manager. Right click on the Default Website, go to Properties
- You can edit the TCP port (something like 8080 should do just fine if not already reserved) and apply the changes.
- Try to start the Default Website again

Now, to access your SBC, you just need to add the port to the url,like http://servername.domain:8080/avast/service.aspx

Hope this works for you.

Offline avadas.de

  • Avast Reseller
  • Sr. Member
  • *
  • Posts: 259
    • avadas.de
Re: Change website port
« Reply #2 on: August 18, 2011, 08:10:02 PM »
Hi Pascal,

sorry for the late reply. I tried it today. Checking which ports are in use, changing the Default Website bindings to 8080, stopping and starting the site. However same effect...the Administration Console didn't open. As soon as I switched back to the default 80 port, it was reachable again.

Did you perform any additional steps?
Feel welcome to also visit the German Avast Community Forums for support and discussions with other security specialists as well as beginners!

Avast 19.6.2383 German Release Notes

Offline avadas.de

  • Avast Reseller
  • Sr. Member
  • *
  • Posts: 259
    • avadas.de
Re: Change website port
« Reply #3 on: August 22, 2011, 01:25:51 PM »
*bump*

Maybe also Lukas could jump in and tell if there are any other things which have to be checked?
Feel welcome to also visit the German Avast Community Forums for support and discussions with other security specialists as well as beginners!

Avast 19.6.2383 German Release Notes

Offline JBG

  • Avast team
  • Jr. Member
  • *
  • Posts: 50
Re: Change website port
« Reply #4 on: August 24, 2011, 03:21:23 PM »
Hello,
could you please tell me the actual URL you are using to access the Administration Console?

Offline avadas.de

  • Avast Reseller
  • Sr. Member
  • *
  • Posts: 259
    • avadas.de
Re: Change website port
« Reply #5 on: August 25, 2011, 08:44:55 AM »
Hi,

URL is http://<servername>:82/Avast/Default.aspx (also tried with 8080 after changing the port of the Default Website in IIS)
Feel welcome to also visit the German Avast Community Forums for support and discussions with other security specialists as well as beginners!

Avast 19.6.2383 German Release Notes

Offline JBG

  • Avast team
  • Jr. Member
  • *
  • Posts: 50
Re: Change website port
« Reply #6 on: August 25, 2011, 10:30:53 AM »
Hi,

URL is http://<servername>:82/Avast/Default.aspx (also tried with 8080 after changing the port of the Default Website in IIS)

OK, please read http://forum.avast.com/index.php?topic=82941.msg680947#msg680947 for the difference between http://<servername>:82/Avast/Default.aspx and http://<servername>:82/Avast/Service.aspx.

Now to your actual problem, there is a known bug related to custom port (for Default website selection). But there is also a workaround:
  • Let's assume 82 is a port currently selected for Default website
  • Go to http://<servername>:82/Avast/Service.aspx (unsecure access, but should work) for access to Administration Console
  • Go to Admin->Settings->Advanced mode
  • Change Console address setting in Server core from /Avast/Service.aspx to :82/Avast/Service.aspx
  • Restart the avast! Administration Console windows service

Now you should be able to access the secure http://<servername>:82/Avast/ or http://<servername>:82/Avast/Default.aspx normally. Please let me know if described steps solved your problem.

Offline avadas.de

  • Avast Reseller
  • Sr. Member
  • *
  • Posts: 259
    • avadas.de
Re: Change website port
« Reply #7 on: August 29, 2011, 02:49:41 PM »
Works! Thank you
Feel welcome to also visit the German Avast Community Forums for support and discussions with other security specialists as well as beginners!

Avast 19.6.2383 German Release Notes

Offline JBG

  • Avast team
  • Jr. Member
  • *
  • Posts: 50
Re: Change website port
« Reply #8 on: August 30, 2011, 05:10:25 PM »
Works! Thank you

You are welcome :-)