Author Topic: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)  (Read 6067 times)

0 Members and 1 Guest are viewing this topic.

gdiloren

  • Guest
I just tested (negative reports) Outpost Pro 7.5.1 FW only from the pro suite and the Comodo FW only from their installer. They all went in the way of SafeZone Browser, Sandbox or both. With Comodo I couldn't even start  SafeZoneBrowser's Chrome. Outpost started Chrome but no internet connection inside SafeZone and a lot, really a lot, of pop-ups, each time I used a sandboxed browser.
So I installed PrivateFirewall from their web site. Everything is fine. It's the best FW after Windows FW for Avast Pro if you want to avoid trouble. ::)

Offline Cast

  • Sr. Member
  • ****
  • Posts: 302
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #1 on: August 26, 2011, 05:45:33 AM »
I just tried using safezone with outpost pro and i got nothing from it.
Also i do agree that Privatefirewall is one of the better free firewalls.

gdiloren

  • Guest
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #2 on: August 26, 2011, 05:57:59 AM »
Just install Private Firewall & don't try anything else. There are some legacy entries in the registry that are unmovable. This way, you won't mess up your computer. Take my advice. :)

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3398
  • Avast shall conquer the whole world
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #3 on: August 26, 2011, 06:20:16 AM »
Did you exclusion the file call "C:\Program Files\Agnitum\Outpost Firewall Pro\wl_hook.dll" in the Avast file system shield and did you add the Avast file call "AvastSvc.exe" in the Outpost Pro application guard exclusion, and try again if not wait for DavidR for further instruction.
« Last Edit: August 26, 2011, 06:22:15 AM by SpeedyPC »
Gigabyte 670 LGA1200 Full ATX MB | Intel Core i9-13900 CPU/LGA 1700 | GeForce Nvidia RTX-4070/12GB | 32GB DDR4 | 2 x 1TB Samsung SSD | W11 Home 64bit | Avast Premium v24.3.6108 | Avast SecureLine VPN | Avast Secure Browser | Avast Driver Updater | Avast BreachGuard | Firefox 64bit | MalwareBytes Premium | Adguard Premium | CCleaner Portable | Macrium Reflect | 7-Zip

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89434
  • No support PMs thanks
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #4 on: August 26, 2011, 02:45:39 PM »
I can't help as A) I didn't understand the problem as it was outlined in the other topic started by the OP and B) I don't have avast Pro, so I don't have the SafeZone and SafeZoneBrowser, so can't test.

If I had a problem then you would hear me holler.

That said I don't know if gdiloren had the Outpost Web Control module enabled.

The Outpost Firewall Pro Security suite even with the AV remover or custom install and not installed would potentially leave other modules. So the Outpost web control & avast web shield could conflict. Add to that running in what is a sandboxed environment of the safe zone and I think there is potential for conflict all round, as the Outpost firewall also has some sort of sandbox feature, see image of a search in the C: drive for sandbox, all of these files with the exception of the outpost sandbox.sys driver are in the Outpost program folder.

Now we are possibly getting into the area were someone was having a problem running an application running under sandboxie inside the avast sandbox. Here we are getting into dangerous conflict territory.

So I really wouldn't know where to start with this.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3398
  • Avast shall conquer the whole world
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #5 on: August 26, 2011, 03:25:50 PM »
Maybe Vlk or Avast programmer could investigate this issue before they release their final version soon, and can someone remind Vlk or Avast programmer about this before it to late :-\
Gigabyte 670 LGA1200 Full ATX MB | Intel Core i9-13900 CPU/LGA 1700 | GeForce Nvidia RTX-4070/12GB | 32GB DDR4 | 2 x 1TB Samsung SSD | W11 Home 64bit | Avast Premium v24.3.6108 | Avast SecureLine VPN | Avast Secure Browser | Avast Driver Updater | Avast BreachGuard | Firefox 64bit | MalwareBytes Premium | Adguard Premium | CCleaner Portable | Macrium Reflect | 7-Zip

gdiloren

  • Guest
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #6 on: August 26, 2011, 03:47:20 PM »
I can't help as A) I didn't understand the problem as it was outlined in the other topic started by the OP and B) I don't have avast Pro, so I don't have the SafeZone and SafeZoneBrowser, so can't test.

If I had a problem then you would hear me holler.

That said I don't know if gdiloren had the Outpost Web Control module enabled.

The Outpost Firewall Pro Security suite even with the AV remover or custom install and not installed would potentially leave other modules. So the Outpost web control & avast web shield could conflict. Add to that running in what is a sandboxed environment of the safe zone and I think there is potential for conflict all round, as the Outpost firewall also has some sort of sandbox feature, see image of a search in the C: drive for sandbox, all of these files with the exception of the outpost sandbox.sys driver are in the Outpost program folder.

Now we are possibly getting into the area were someone was having a problem running an application running under sandboxie inside the avast sandbox. Here we are getting into dangerous conflict territory.

So I really wouldn't know where to start with this.
Yes, I had the Outpost Web module and did all the exclusions. SafeZone and the Sandbox feature in Avast Pro are very "touchy":they don't work well with all FW, as I said Private Firewall is a no problem no mess around FW! ;)

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89434
  • No support PMs thanks
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #7 on: August 26, 2011, 05:08:20 PM »
Well considering when you install Outpost, it detects avast and recommends disabling both the web control and anti-spyware modules for compatibility. My feelings are you are potentially shooting yourself in the foot (as SpeedyPC can attest ;D) as far as compatibility goes.

You honestly can't compare what is a simple stand alone firewall, with the outpost pro suite, it is far more complex.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

gdiloren

  • Guest
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #8 on: August 27, 2011, 04:51:32 AM »
Thank you for reply but it's pure FW I wanted to install. Now Private FW has HIPS in it. Anyways, yes I installed also the web control but for the SafeZone problem and the Sandbox problem it has nothing to do. It is well documented in the Outpost forum that this is a bug in the actual version of Outpost Pro FW v.7.5.1. Has anybody been able to use these Avast Pro features with Outpost Pro 7.5.1 FW. I guess not. So that's why I'm recommending Private Firewall. The suite is rotten.

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3398
  • Avast shall conquer the whole world
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #9 on: August 27, 2011, 08:01:16 AM »
My feelings are you are potentially shooting yourself in the foot (as SpeedyPC can attest ;D) as far as compatibility goes.

 :'( DavidR was right about that and it not very nice when I shot myself in the foot as far as compatibility goes using Outpost, trouble is now I'm not quick enough against the "Fat Cat" going toward a slow recovery mode ;D

It is well documented in the Outpost forum that this is a bug in the actual version of Outpost Pro FW v.7.5.1.

Please show us the link information saying is a bug in the actual version of Outpost Pro FW v.7.5.1.
« Last Edit: August 27, 2011, 08:28:48 AM by SpeedyPC »
Gigabyte 670 LGA1200 Full ATX MB | Intel Core i9-13900 CPU/LGA 1700 | GeForce Nvidia RTX-4070/12GB | 32GB DDR4 | 2 x 1TB Samsung SSD | W11 Home 64bit | Avast Premium v24.3.6108 | Avast SecureLine VPN | Avast Secure Browser | Avast Driver Updater | Avast BreachGuard | Firefox 64bit | MalwareBytes Premium | Adguard Premium | CCleaner Portable | Macrium Reflect | 7-Zip

gdiloren

  • Guest

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89434
  • No support PMs thanks
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #11 on: August 27, 2011, 06:15:40 PM »
I only wish the Outpost Forums was as prompt and helpful as the avast forums, with a week going by before any input by Manny in the first link. But it doesn't have any developer input as such, just user based comment.

This is perhaps the worst thing about Agnitum's Outpost forum and isn't a patch on the avast forums.

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3398
  • Avast shall conquer the whole world
Re: AVAST PRO works fine with Private Firewall (SafeZoneBrowser works)
« Reply #12 on: August 27, 2011, 07:05:15 PM »
I agree with DavidR comments and I believe you have already shot yourself in the foot gdiloren maybe that's why you can't feel the pain ::)
Gigabyte 670 LGA1200 Full ATX MB | Intel Core i9-13900 CPU/LGA 1700 | GeForce Nvidia RTX-4070/12GB | 32GB DDR4 | 2 x 1TB Samsung SSD | W11 Home 64bit | Avast Premium v24.3.6108 | Avast SecureLine VPN | Avast Secure Browser | Avast Driver Updater | Avast BreachGuard | Firefox 64bit | MalwareBytes Premium | Adguard Premium | CCleaner Portable | Macrium Reflect | 7-Zip