Author Topic: notification that email was scanned  (Read 2667 times)

0 Members and 1 Guest are viewing this topic.

Offline killingtime

  • Jr. Member
  • **
  • Posts: 28
  • killingtime virus...
notification that email was scanned
« on: December 03, 2004, 10:14:21 PM »
I use Forte Agent 2.0 as my mail reader. With Avast 4.0, I was able to scan incoming email by changing the server to 127.0.0.1 and adding #<servername> to my login name. Each incoming email would have a nice little tag at the bottom:

avast! Antivirus: Inbound message clean.
Virus Database (VPS): 0448-0, 11/23/2004
Tested on: 11/27/2004 12:07:42 PM
avast! - copyright (c) 2000-2004 ALWIL Software.
http://www.avast.com

After upgrading to Avast 4.5, the above tags are gone.
How can I get them back?

TIA,
killingtime

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:notification that email was scanned
« Reply #1 on: December 03, 2004, 10:41:37 PM »
KT,

Firstly, make sure that you can send and receive email properly regarless of whether it is presently being scanned.

Secondly, send an email to yourself to ascertain if the "outgoing mail" is being scanned.

Thirdly, once this is done, go into your options in your email client and make sure the configuration is correct.

Fourth, open up the Avast On Access Protection Console and then Standard Shield.  Make sure that for POP, SMTP and IMAP, the "Insert......" box is checked.


Offline jhiker

  • Jr. Member
  • **
  • Posts: 53
Re:notification that email was scanned
« Reply #2 on: December 07, 2004, 09:48:50 PM »
I notice that  Avast will not insert the tag into SOME emails though a quick check of the email properties shows they are actually being scanned. I've never got to the bottom of this or worked out why.
Here's an extract from an email that wasn't tagged....

Return-Path: <n.bishop_dz@vangoghmuseum.nl>
Received: from mk-rewrite-3.mail.uk.tiscali.co (212.74.114.134) by mk-cpfrontend.uk.tiscali.com (7.1.016.19)
        id 41B4783A0003FF89 for galaxy2@screaming.net; Tue, 7 Dec 2004 15:59:51 +0000
Received: from f94080.upc-f.chello.nl ([80.56.94.80]:3169 helo=sueddeutsche.de)
   by mk-rewrite-3.mail.uk.tiscali.co with esmtp (Exim 4.30)
   id 1CbhVH-0004ga-0J
   for xxxx@xxxxxxxx.screaming.net; Tue, 07 Dec 2004 15:43:53 +0000
Message-ID: <56ab01c4dc78$9be727f3$a90aeeea@fncklyc>
From: "Natasha L. Bishop" <n.bishop_dz@vangoghmuseum.nl>
To: xxxxx@xxxxxxxx.screaming.net
Subject: testing.. [Spam][95.9%]
Date: Tue, 07 Dec 2004 16:20:06 +0000
MIME-Version: 1.0
Content-Type: text/html
Content-Transfer-Encoding: base64
X-Antivirus: avast! (VPS 0450-0, 06/12/2004), Inbound message
X-Antivirus-Status: Clean

I use latest Avast, Win XP SP2 and K9 spam filter.
Anybody have any clues?
Windows7

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re:notification that email was scanned
« Reply #3 on: December 08, 2004, 01:10:48 AM »
I'm quoting Igor:

There seems to be a bug in Outlook Express, in particular in its Base64 decoder. If a text is aligned (in Base64 format) using the '=' characters (as it should be) and a new piece of text is appended (e.g. when a note is inserted into the incomming message), Outlook Express ignores the alignment - so the inserted part "merges" with the previous e-mail, which results in the corruption you can see.

Try the following: open the avast4.ini file and write
PatchBase64=1
into the [MailScanner] section.

With this option, avast! will append the e-mail notes in a different way.
The best things in life are free.